Can't upgrade from Version 2.1.0 to any newer version

[Please describe your issue here. Try to include logs (Help → Logging) and add screenshots if necessary.]

Steps to reproduce issue:

  1. Download Windows version of TopazPhotoAI.3.0.4.msi (or older versions)
  2. Click on .msi file
  3. The installation process hangs with attached messages (see Screenshot
    TopazPhoto3.0.4
    )

Topaz Photo AI [3.0.4] on [Windows/Mac]

Have you attempted to download the file locally and install it in stead of updating?

Latest version is here:

I’ve tried both approaches, as well as attempting to delete the older version before installing the latest version.
Get the same pop-up message (attached) even when I try to run the Windows 10 Uninstall on the older version? Windows
will not let me Uninstall the app.

I had the same issue and Topaz support gave me the instructions to clear the registry. It worked for me if you would like to give it a try…

  1. I did a complete windows uninstall
  2. Manually deleted all the Topaz Photo AI directories
  3. Follow the instructions to clear the registry
  4. Restarted the computer
  5. Did fresh install

How to Clear Your Topaz Labs Registry Entries (Windows)

If you get error messages or have issues with our apps, often uninstalling the program,
clearing the registry (this article), and then re-installing the latest version
(Topaz Labs | Downloads) will solve it.

Important note: other than the specific entries we list in this article, do not delete
anything else from your registry. That might affect your computer in unintended ways.
How to Clear Your Registry

  1. Uninstall the software from the “Apps & features” settings on Windows 11 or
    “Programs and Features” on Windows 10.
  2. Open Registry Editor from the Start menu. Make sure not to change or delete
    anything yet.

  1. Delete the registry entries for the Topaz product at the following locations:
    Computer\HKEY_LOCAL_MACHINE\Software\Topaz Labs LLC\Topaz [Product] AI
    Computer\HKEY_CURRENT_USER\Software\Topaz Labs LLC\Topaz [Product] AI
  2. Close Registry Editor. Re-download and re-install the latest version
    (Topaz Labs | Downloads) of your product. It should work after that.

More info
Your Windows Registry contains preferences and settings that affect how your programs
function. Programs will usually set registry items upon installation and usage. A typical
example of something that might be stored in your registry is the directory that Topaz
products look to find the AI model files that we use to process your images.
Uninstalling, clearing your registry, and re-installing has a high chance to fix many
issues because it completely removes any traces of our products on your computer. This
can resolve issues due to a corrupt installation.

This is what worked (and I forwarded the results to Topaz support)

Deleted the registry entry, ran the 3.0.4 installer, but the same error message came up. Downloaded the 2.1.0 installer of my older version, then ran the 3.0.4 installer and when the error message popped up, I browsed to the folder with the 2.1.0 installer and the 3.0.4 installer completed but only stored some files in the app program location, but no executable.

I then ran the old 2.1.0 installer which replaced the incomplete 3.0.4 installation, and then I ran the 3.0.4 installer which correctly replaced the 2.1.0 version and the updated version runs fine??

1 Like

Wow talk about a wrap around!

Glad you got it working William.