Adjust Lighting Error & Crash | MacOS M3

When trying to add Adjust Lighting enhancement, the app crashes. Not just a random event. It happens every time. Tested with jpgs, pngs. Seems like anything above a photo size of 1M causes Adjust lighting to crash the app. Surprised that this made it through beta testing.

Steps to reproduce issue:

  1. Select Add Enhancement
  2. Select Lighting Adjustment
  3. App crashes

Macbook Pro M3 Pro, 18GB RAM, 1TB SSD. Sonomo 14.4. Doesn’t matter if original photo resides in built-in SSD or external via Thunderbolt 4.

Topaz Photo AI [v2.4.0] on [Windows/Mac]


I’m having the same issue, with a brand new MBP Max, 36GB Ram, 1 TB SSD, Sonoma 14.4


Ditto on this issue, have tried every version of photoAI that has this feature and the app crashes in the same way.

MacBook Pro 16-inch, Nov 2023 Apple M3 Max 64 GB Ram, 2TB SSD
macOS Sonoma Version 14.4

Please follow the instructions below to perform a clean install to better troubleshoot why you had this problem with Topaz Photo AI:

Start by clearing any previous plist files that are on your computer for Topaz Photo AI by following the steps in the link below:

Topaz Photo AI | plist Files Mac

After you have done this, disable any antivirus, firewall, VPN, or proxy software that might be active on your computer. These tools are sometimes known to interfere with the installer’s ability to download the model files.

Please also ensure that the Topaz Photo AI installer has all the proper settings in your system by going to your Mac System Settings > Privacy & Security tab and scrolling down to the security section. You will want to make sure you have 'App Store and identified developers ’ selected. Here is a video example:

Example of Proper System Preferences

Finally, rerun the installer. You can download a new installer from the downloads page directly :

Topaz Labs Download Page

Let me know how that goes for you and I’ll keep an eye out for your reply.

Thanks, I tried this, but it did not help. Adjust LIghting still crashes the app. I sent you a log file via email.

I have the same problem with my M3Pro MacBook Pro with 18GB RAM, 1TB SSD running Sonoma 14.4. I crashes every time I add Adjust Lighting enhancement. It does this on multiple images. I already reinstalled but still have the same problem.

I tried it on my late 2013 Haswell MacBook Pro 16GB RAM 1TB SSD Nvidia GeForce GT 750M GPU also running Sonoma 14.4. It has no problem, Adjust Lighting Enhancement works fine so this problem seems to be exclusive to Apple Silicon Macs.

I also have the same issue. Macbook Pro, M3 Max, 14 inch, 64GB RAM, 2TB SSD. New machine, freshly installed topaz.
The app crashes with JPEG, and PNG as well on every occasion.
Except the adjust lighting, other features seems working.
This is the end of the log:
[2024-03-15 01:39:52.048, 2.96 ms] [17055b000] Info | Writing input to cache 18446744072304577008 “Exposure Adjust”
[2024-03-15 01:39:52.048, 16.00 μs] [17055b000] Info | Cache get hash: 18446744072304577008 false
[2024-03-15 01:39:52.054, 19.02 ms] [1700fb000] Info | Cache insert hash: 18446744072304577008
[2024-03-15 01:39:52.054, 5.98 ms] [17055b000] Info | [ExpoEnhancement] Finished preProc: params: QMap((“auto”, QVariant(bool, true))(“locked”, QVariant(bool, false))(“mask”, QVariant(bool, true))(“param1”, QVariant(double, 0.25))(“scale”, QVariant(double, 1)))
[2024-03-15 01:39:52.054, 7.00 μs] [17055b000] Info | [ExpoEnhancement] Starting proc
[2024-03-15 01:39:52.054, 5.00 μs] [17055b000] Info | Cache get hash: 18446744073620686961 false
[2024-03-15 01:39:52.057, 3.31 ms] [1700fb000] Info | Cached image directly 18 71.4MB
[2024-03-15 01:39:52.057, 22.31 ms] [1f4fc7ac0] Info | Cache insert hash: 18446744072304577008

1 Like

It’s now a known issue with M3 Macs. I was told by Topaz that they are working on the issue and will release a fix in version 2.4.1 or 2.4.2. By the way, there was more or less the same issue in 2.3.x where Adjust Lightning does not work with an M3 Mac.

1 Like

It is still broken in 2.4.1

1 Like

This is a known crash that our developers are currently investigating.

If you need Photo AI urgently, you can access all of our previous versions here: Releases - Topaz Community

We appreciate your patience and understanding while we get this fixed.

Also crashes when using “Adjust Lighting” on MacOS 14.4.

Photo AI app crashes on the M3 MacBook Pro when selecting the “Adjust Lighting” option. I have the latest 2.4.0 version installed.

1 Like

I’d like to get some more information to help troubleshoot the problem you are having.

Could you send us your computer’s full system profile?

Also if you can, please try to recreate this crash in Topaz Photo AI, then go to Help > Open Log Folder, please send me all of the files within that folder. You should be able to attach them directly as a response to this email.

You can securely submit your files(s) to my Dropbox using the link below. Please be sure to send me a note to let me know you sent something.

Dropbox File Request

Hi John,

I reproduced the issue and attached logs from the last session.

Here is a system profile of my Mac:
Model: 16" MacBook Pro (2023)
Model Number: Z1CM000MALL/A
Chip: Apple M3 Max with 16 cores (12 performance and 4 efficiency)
GPU: 40 cores
Neural Engine: 16‑core
Memory: 64 GB (LPDDR5)
OS: Sonoma 14.4

Let me know if there’s anything else I can help with.

2024-03-12-08-41-22.tzlog (77.1 KB)
2024-03-12-08-41-33.tzlog (77.1 KB)

One more log file
lastSessionFiles.txt (60 Bytes)

Opening TIFF 16 bit file from NX Studio on Mac Sonoma 14.4, trying to add lighting layer, Topaz crashes. Doesn’t matter how image is opened though, or if raw, jpeg or tiff. Same error. Running Topaz Photo 2.4 on Mac Sonoma 14.4.

Steps to reproduce issue:

  1. Open image in Topaz photo 2.4
  2. Click Add Enhancement → Adjust lighting
  3. Topaz crashes

Topaz Photo AI v2.4 on Mac Sonoma 14.4.

I cannot reproduce this issue with a TIFF file from On1 PR, Lighting adjustment works just fine. Also on Sonoma 14.4.
Send log files

2024-03-10-13-57-16.tzlog (24.1 KB)

Attached log file

Let’s try updating you to the most recent version release to see if this resolves the issue.

Please make sure you’ve also turned off any firewall, VPN, or proxy that may be on your computer. These are known to block the installation. Also, make sure there are no settings or configurations in your OS system that could interfere.

Try using the appropriate OS system link to update:

If you are still experiencing problems, please reach out to us at the following link:

Topaz Labs | Support Page

I uninstalled 2.4 and installed 2.4.1, and it still crashes trying to add an adjust lighting layer. MacBook M3 128g ram, Sonoma 14.4.