3.3.8 Kernel Panic

Late 2020 Intel i9 10 core IMac
72 gb ram
AMD Radeon Pro 5700 XT 16 GB
Ventura 13.4

When trying to export a SD H264 video upsized to 4k Video AI chugs along tellinmg me I have so many hours to completion. I walk away for a while only to return to find my iMac rebooted with a kernal panic error

I have the same issue after the most recent update. First cursor freezes, then whole screen, then self-reboot. Movie is partially processed.

I am also getting partial temp mov. files, trying to export as prores. Only one with 2 seconds of video is actually playable

I was able to fix the issue (for now) by doing 2 things:

  1. Delete preferences per this tip, (How To Delete Your Plist Files - Topaz Labs) then reinstall.
  2. Go into Preferences and set utilize memory to something less than 100% (I used 90%)

Tried without sucess. I reduced memory usage to 80% and max processes to 1. It sucessfully rendered a sharpened and motion deblurred prores after about 2 hours. I then tried to uprez the new file to the 4k 60fps preset and it crashed and rebooted after about 10 minutes of trying to generate a preview

Yes, same here. It did successfully process a 5-minute upscale, but when I enabled live preview, it froze and crashed again. I’m going to delete the preferences, turn off live preview, and see if that works.

NOPE. Crashes no matter what now - process about 2.25 GB before crashing, but that file is not readable. I guess I’ll file a bug report tomorrow and wait for them to fix it, or perhaps downgrade if I need it bad enough.

My setup:

  • 3.5 GHz 10-core Intel Core i9
  • AMD Radeon Pro 5700 XT 16GB
  • 128 GB 2667 MHz DDR4
  • MacOS Ventura 13.5
  • 4TB Internal SSD, about 1.9 TB free

Hi all! Can you post your logs and system profiles here please?
How To Obtain Your System Profile (Windows)
How To Obtain Your System Profile (Mac)

To gather logs, please select Help > Logging > Get Logs for Support and attach the zip file to your reply.

Also, on Mac, we will need the console report.

iMac.spx (7.6 MB)
WindowServer-2023-07-30-110154.txt (1.3 MB)

upgraded to 3.3.9 Still rebooting when trying to convert sd to 4k.
Lateest crash report
recent crash report.txt (8.1 KB)

I too am having this same issue. Mac i9 with Radeon 6900XT. Constant crashes while doing 1min+ upscales…

Already had memory set to 80%. Still freezes up and reboots

Hi Everyone,

We have a new pre-release version of Video AI that includes a possible fix for the out-of-memory error you were experiencing in the app. Please test out this update if you have a few minutes and let us know if things are working as expected.


  1. The bug / behavior you have encountered
    Since updating to v3.3.9, virtually every batch process/export contains at least 1 failure saying Error. These are all identical format 720x480, 29.97, DV/DVCPRO - NTSC, Linear PCM, 16 bit little-endian signed integer, 48000 Hz videos and are all being processed to 1920x1080 with the same Iris 2x FPS model. Has zero errors in the previous 10 versions or so.

  2. Your system profile
    Model Name: Mac Studio
    Model Identifier: Mac13,2
    Chip: Apple M1 Ultra
    Total Number of Cores: 20 (16 performance and 4 efficiency)
    Memory: 128 GB
    System Firmware Version: 8422.141.2
    OS Loader Version: 7459.141.1.700.1
    Serial Number (system): DKGW61C7KH
    Hardware UUID: B9798158-C251-58A1-B916-514D236A853B
    Provisioning UDID: 00006002-001A08862102401E
    Activation Lock Status: Disabled

  3. Your log files (Help > Logging > Get Logs for Support)
    logsForSupport.tar.gz (2.8 MB)

  4. Any screenshots as necessary

Same here. M1 MacMini, never had such issues, but with 3.3.9 its no longer working.
Previews render, but exports mostly gives an error.
Upscaling proteus to HD or 4k.
EDIT: went back to 3.3.8, same problem. 3.3.5 works

My 2 M2 Macs do not work due to a Ram leak, so no rendering at all currently.

2 log files from My M1 Mini with 2 different input files.
logsForSupport.tar.gz (1.4 MB)
logsForSupport2.tar.gz (935.3 KB)

I had one failed export on the M2ultra recently as well.
Still, mostly it works.

@virtualtracks @jo.vo @tobias Can you please try the Alpha build above?

Same problem.

Tried the Alpha on my MacBook Air M2 with the same file and settings (square pixels and Iris upscale to 4k)
Ram use went up as with previous builds and the swap explodes. I thought we were at Alpha?
Or does that mean that the 3.4.x alpha has been abandoned?

Anyways this version brings back (or still has) the fill up all memory bug when using Iris for 2x upscales and RAM set to 100% - a thing that the and already had solved.

And every preview with this immediately failed - actual export seems to be working, though.

Error log of the failed previews:
logsForSupport.tar.gz (915.0 KB)

This RAM filling bug is/was solved with the 3.4.0.x.a versions, so you might want to try these. And with SD Iris 2x upscales there is a big speed gain.

But then those early 3.4.x Alpha versions have their own different problems: HD upscales and/or 4x upscales are much slower and the App gets unresponsive after longer encodes, often needing a forced shut down (while it most often does finish the actual encode).

So, there is quite some work to do.