2x de-interlacing parameter never saves itself in a preset (keeps reverting to 1x)

Hi, I don’t think it is going to make any difference regarding screenshots since this bug is self evident. It is simply that any preset I save where I choose 2x de-interlacing at 50p, the 2x de-interlacing parameter never ever “saves” itself, instead reverting to 1x de-interlacing at 25p upon choosing the previously saved preset. Even if I try to save the preset yet again after changing it back to 2x de-interlacing, every time I go to load it subsequently it still reverts back to 1x de-interlacing.

If you did need further info I can provide it but as I say, this seems to simply be a issue relating to a preset not saving all the parameters correctly.

1 Like

Just a further update. This issue also occurs with NTSC source input at 59.94 fields per second (29.97 fps). When I save the template at 59.94 (2 x de-interlacing) and then subsequently re-load it later, it loads as only 29.97 (1 x de-interlacing).

So it is happening on any template I create that needs to perform 2 x de-interlacing regardless of whether it is 59.94 or 50 fields per second.

I just tried creating a preset with 2x de-interlacing, and the preset was held when applying to multiple other clips in the same session.

However, I was able to get it to revert to 1x de-interlace after closing the app and reopening it. I will share this update with the team.

It should also reset if you load up another input file, change to some other preset then go back to the de-interlacing preset (so all in the one session with Topaz open the whole time).

Sorry to keep going about this problem but it also effects the batch (multiple input processing).

So in addition to what I have mentioned above, if you try to process more than one input file (so I “select all” on the inputs) then regardless of whether I have “corrected” each individual input’s output parameters to 2 x de-interlace, it still reverts back to 1 x de-interlace as soon as I click on the Export button.

Ergo, it is impossible to do a batch process where I click on Export and Export is showing more than one file in brackets.

What does appear to work (as a partially mitigating workaround) is to load an input file, correct the parameter to 2 x de-interlace, start the processing on that then open the second file and do the same. And so on up to the maximum number of processes selected but no more (which for me is 3).

That will at least do more than one input file per “human intervention” but only up to a maximum of 4 (and probably more realistically only 2 or 3 at most). So although this is not as bad as having to do one file at a time it obviously does not allow for true batch processing.

I don’t know if you noticed but, it will not only revert back to x1 when you load a batch of videos, it will also revert all the other videos to Proteus instead of what you selected (e.g. Iris or Dione)…

check that out if you like to understand more about this bug…

1 Like

I have found a partial workaround. And that is to load each input file separately, load the preset for it, amend the de-interlacing parameter to 2x then hit the Export button. As soon as that first export job starts, load the next input file and do the same - load the preset, amend the de-interlacing and once again hit Export. It will then just sit there with the clock timer icon, ready to start once the first job is done. So far as I can tell you could “stack” up as many of these as you like and the 2x de-interlace parameter sticks in this instance.

that is not a batch process. you describing a single video process , just done multiple times.