1.3.4 Activation Not Working [Fix to be released in 1.3.5]

When I start Photo AI after updating to version 1.3.4 the program wants an activation with every start up.

Steps to reproduce issue:

  1. start Program Photo AI
    2.click activate
  2. Click continue

and the program runs.

Topaz Photo AI [v1.3.4] MacOS Ventura V 13.3.1


Hi - can you please send us your last two log files from Help > Open Log Folder?

You can have mine. Same problem.

2023-05-12-10-31-1.tzlog (9.7 KB)
2023-05-12-10-25-42.tzlog (12.7 KB)

Thank you. Looking into it.

I am having the same problem.

Same here!

2023-05-12-14-17-45.tzlog (343 KB)

2023-05-13-20-58-50.tzlog (12.8 KB)

I was getting the same issue (additional info: reported that my login had expired).

I deleted the app and all its support files. Then re-downloaded the full installer (Mac) and installed it. Did the activation the first time and the problem appears to be gone now.

Same problem for me as well.

I’m experiencing the same issue on a Mac (Apple M1 ultra chip/64 GB) running Ventura 13.3.1.

Me too. I uninstalled Photo AI and reinstalled on drive D: to free up space on C: and now it asks me to activate every time I open the software

Same problem. Macbook Pro, M1, Ventura 13.1
2023-05-14-17-37-34.tzlog (126.4 KB)
2023-05-14-16-49-34.tzlog (353.0 KB)

1 Like

I’m having the same issue as well. Not sure if its exactly for the same reason as others. I had to reinstall windows and the software this week. Not sure if I’m having the same issue or if its related to having to reinstall windwos/Topaz (my log files are measured in MB’s while the other commentor’s files are
measured in KB’s)
2023-05-13-18-00-42.tzlog (10.8 MB)
2023-05-14-12-54-2.tzlog (9.3 MB)

1 Like

Hello everyone. I am collecting the necessary information for us to fix this issue. Please follow the instructions below to get me the token information from the registry (Windows) or send me the plist files for Topaz Photo AI (Mac) so we can determine the cause.

Windows instructions.

Mac instructions.

You can upload the files to my Dropbox here:
Dropbox File Request

Done. Also, deleted and reinstalled, and it did not fix the issue either.

Thank you for sending this. I’ve passed it to a developer who is looking into it.

If anyone has more examples that would speed up the process.

I have a new build from the developers which has a potential fix for this issue. Please install the below version and let me know if you still have the authentication issue. Note: this version will replace your current version like a normal update.
Windows Download
Mac Download

If it’s working, let me know and we can make sure this fix goes into the next update.

Just tested the windows version you uploaded and that seems to have worked for me. I was having the same issue and it now seems to be resolved.

I assume it’s just redundant to write I am having this problem too, but it was weird that in my laptop, where I work everyday it keeps asking for activation, but at work, were I use my second seat, it only reclaimed a seat I used in my home PC this weekend and that was it.

@Lingyu - this worked for me (Mac download) - thanks! It was driving me nuts and killing my workflow.