WMV Files don't work anymore!

Video A.I. 4

If I pay $300 for something, I expect it to work! :expressionless:


Especially when the previous versions didn’t have this problem. You can’t even seek through the timeline, or preview test with this new 1!

1 Like

What that error message is telling you is that you can’t copy the audio stream of your original video into your export output container. This is probably because it’s Windows Media Audio, which is not compatible. The audio has to be converted during export, or not processed at all.

I’ve just done this with a wmv sample with wma sound, and it works fine.

1 Like

I can confirm that VAI supports decoding WMV. I’ve processed nearly 100 of those clips a few days ago.

MP4 and MOV containers don’t support wmv/wma media streams, so you cannot copy the audio into those container without re-encoding. MKV does, but I wouldn’t use this combination, becasue it’s more than uncommon. Converting the sound, as already mentioned by others, is the best bet you have, if you need the sound.

Topen the panel with the related settings for the current export click the button next to Export lower right hand side:


To change the default export settings, use File->Preferences->Export up left.


I already tried that before, with every different setting (including Audio Mode: None), and the issue still remained. Can’t seek with the timeline, and the preview button doesn’t even highlight, let alone trying to export.

Again, the same .wmv files worked in ver. 3, but not in ver. 4! So they broke something with this update!? :woman_shrugging:t2:

So whoever tagged this topic as “solved” is wrong.

1 Like

I can only suggest you raise a support ticket and give them your logs, as not much can be done via guesswork if wmv is processing fine for others.

You can contact support on the main site.

Issues here also. Ever since 4.1, wmv imports erratically. Sometimes they work ok, sometimes they come in with the wrong FPS and won’t process. And the same file can work fine one time and then error out the next.

As a matter of interest, any chance to share one or more of those troublesome clips?

Unfortunately, they’re someone else’s IP.

It’s not really an app killer for me, I just open the files in my editor and convert them to another format. It’s just annoying that TVAI keeps forgetting how to do very basic things it used to be able to do.

I’ve also seen some flaws in VAI, which I didn’t expect to see. However, as mentioned, I processed really a lot of WMVs in various flavors and from different sources recently and had no problems at all, surprisingly to be honest, because I find that WMV is a troublesome format outside the world of Microsoft encoder/decoders. Regarding the error message you’ve shared, I thought that the original poster used MP4 or MOV as output format and tried to copy WMA audio streams into it, which cannot work.

TVAI will tell you if you’ve done that so you can change copy to convert. Prior to 4.1, that was all you had to do and WMVs would import and process correctly.

It wouldn’t be so irritating if it had never worked.

If the original poster cannot, for whatever reason, would you mind sharing a WMV file which doesn’t work?

Just to be clear: I’m asking for a sample, because as you can see from the comment above this issue has been flagged as solved. In other words Topazlabs consider this to be an operational issue and WMV works as expected.

Unfortunately, all the WMV “problem files” I have are part of the same project and are not my IP to share. The good news is, once this project is done I probably won’t be seeing many WMVs.

Here’s something I can show without exposing the IP. The WMV file imports with zero FPS, and if you try to set an enhancement anyway it errors out when you try to export.

Wrong fps is a problem different from what we are discussing, but yes, I’ve seen frame rate issues with WMV files, but not only in VAI, but also with other applications, which use FFmpeg to decode WMV media.

One sample based on metadata: The troublesome WMV shows in VAI 4.2.0, 0 FPS and a randomly assigned frame rate of 23.976, the same as in your last screenshot. In earlier versions of VAI (no screenshot) it showed 1000 fps, the same as FFprobe lists as container metadata: “1k tbr” (see below):


Metadata as shown by ffprobe:

WMFSDKNeeded :
DeviceConformanceTemplate: L1
WMFSDKVersion : 12.0.7600.16385
IsVBR : 0
Duration: 00:10:36.41, start: 0.000000, bitrate: 4783 kb/s
Stream #0:0(spa): Video: wmv3 (Main) (WMV3 / 0x33564D57), yuv420p, 960x540, 8192 kb/s, 1k tbr, 1k tbn
Stream #0:1(spa): Audio: wmav2 (a[1][0][0] / 0x0161), 44100 Hz, 2 channels, fltp, 128 kb/s

Mediainfo reads the time stamps of a few ten frames at the very beginning of a video stream to calculate/verify its frame rate. It shows variable 29.97 fps:

Complete name : M:\Tech\Samples\False1000FPS.wmv
Format : Windows Media
File size : 363 MiB
Duration : 10 min 36 s
Overall bit rate mode : Constant
Overall bit rate : 4 783 kb/s
Maximum Overall bit rate : 8 385 kb/s
Encoded date : UTC 2012-01-28 01:15:35

ID : 1
Format : VC-1
Format profile : MP@HL
Codec ID : WMV3
Codec ID/Info : Windows Media Video 9
Codec ID/Hint : WMV3
Description of the codec : Windows Media Video 9 - Professional
Bit rate mode : Constant
Bit rate : 8 192 kb/s
Width : 960 pixels
Height : 540 pixels
Display aspect ratio : 16:9
Frame rate mode : Variable
Nominal frame rate : 29.970 FPS
Color space : YUV
Chroma subsampling : 4:2:0
Bit depth : 8 bits
Scan type : Progressive
Compression mode : Lossy
Language : Spanish

ID : 2
Format : WMA
Format version : Version 2
Codec ID : 161
Codec ID/Info : Windows Media Audio
Description of the codec : Windows Media Audio 9.2 - 128 kbps, 44 kHz, stereo 1-pass CBR
Duration : 10 min 36 s
Bit rate mode : Constant
Bit rate : 128 kb/s
Channel(s) : 2 channels
Sampling rate : 44.1 kHz
Bit depth : 16 bits
Stream size : 9.71 MiB (3%)
Language : Spanish

In fact, I found that the file has variable 25 fps. Media players, e.g. MPC-HC, play the video correctly because they use the timestamp on each frame and not container metadata for the timing of playback.

To fix a problem like this (read: wrong container metadata for fps on a file with variable frame rate) an application must scan the time stamps of the entire file to recalculate the container frame rate, which takes a while.

Well, as I said, if this had always been an issue with TVAI I would’ve just shrugged and chalked it up as another of Microsoft’s little annoyances. But it was never an issue for me until Topaz rolled out 4.1.0, which is a very long time for something to work and then suddenly not work anymore.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.