Wine Installation for Windows | Installer fails

It used to be possible to install Topaz software under Wine (e.g. Denoise, Sharpen, Giga) and even if they didn’t use the GPU, they worked OK. PhotoAI seems to do something different - the installer just bails out with some generic error message that offers nothing to contact support with.
Is there a way to get this installed and working under Wine?

I want to get some more information to troubleshoot the problems you are facing during the installation process. Please follow the directions below:

First, please disable antivirus, firewall, VPN, or proxy that may be on your computer. These are known to block the installer from downloading the model files. Then, please follow the below instructions to get the installer log for Topaz Photo AI.

  1. Delete all Photo AI installers from your Downloads folder.
  2. Download the latest Topaz Photo AI installer from the downloads page: Topaz Labs Download Page
  3. Make sure the installer is in your Downloads folder and has the filename: TopazPhotoAI-2.3.1.msi
  4. Open Command Prompt from your Start menu. You can type in Command Prompt in Search and open it.
  5. Copy and paste “cd downloads” (without the quotes) into the Command Prompt and hit Enter.
  6. Copy and paste “msiexec /i TopazPhotoAI-2.3.1.msi /l*v logfile.txt” (without the quotes) into the Command Prompt and hit Enter.
  7. The installer should open up. Run it as usual.
  8. After the installation finishes, please send me “logfile” created in your Downloads folder.

This should show me exactly what is happening in the installer that is blocking the internet connection if the issue isn’t any of the above security applications.

You can securely submit your files(s) to my Dropbox using the link below. Please be sure to send me a note to let me know you sent something.

Dropbox File Request

If you would you like you can reach out to us at the following link:

Topaz Labs | Support Page

TPAI can actually be installed under Wine and runs well under Linux. Everything I’ve tried seems to work and it even appears to be able to make some use of my old GPU (Intel HD Graphics 530, circa 2015).

The only serious problem I’ve seen is that the installer always fails with a message saying that it “ended prematurely” (attached image 1.jpg).

For a long time, I used to give up att this point. There is, however, a workaround that will install TPAI under recent versions of Wine (I use version 9.2, but I guess that version 9.0 would work also).

When the installer fails, you have to terminate its process to prevent it from deleting everything that it has installed. I use the ‘kill’ command to do that in Linux (image 2.jpg) but there are other ways to do that. Just don’t let the installer run beyond this point or it will delete everything. Don’t click on “Finish” or the X (top right).

Then run the installer again and it will offer to repair the installation (image 3.jpg). Choose that option and everything will be fine (image 4.jpg). Here you can click “Finish”.

I’ve used this procedure to install Topaz Photo AI versions 2.3.0, 2.3.1 and 2.3.2. I hope that this workaround will continue to work with future versions, but it would be much better if the installer could do the whole thing automatically (as it is obviously meant to do). I have submitted two logfiles (using the Dropbox link above):
logfile_1.txt - the first attempt, until the installer fails
logfile_2.txt - the second pass, when the installer successfully repairs the installation

Hopefully this can be fixed relatively easily given that the installer (‘Setup Wizard’) is actually capable of installing the application properly although it does seem to get confused over something and needs to run a second time.

I also have one minor observation: If you look at the last image (number 5) you’ll notice that the icons for (presumably) closing, maximizing and minimizing (top right, encircled) all look the same. I presume that they are meant to look differently and that the corresponding icons couldn’t be shown for some reason. I don’t know whether this is a Wine-related or a Topaz-related issue. I don’t have any other Windows programs so I don’t know whether they would show icons or the problem is specific to Topaz. The Topaz installer doesn’t seem to be affected though, so maybe the TPAI application does its own thing with those icons? Like I said, this is a very minor issue and it is not really a problem, just an observation.

1
2
3
4

Just installed version 2.4.0 and it worked just like with the previous versions, i.e. I had to run the installer twice (terminating the process from the OS when the installer fails and then rerun the installer and wait until it has successfully repaired the installation). It is a little cumbersome but I’m not complaining as long as it works. The downside is that new users will probably give up when the installer fails on the first run.

1 Like

Upgrading to 2.4.1 also worked and required the ‘usual’ three steps (run the installer; interrupt the process with xkill or kill; rerun the installer to repair the installation).

Unfortunately, others seem to have problems with GPU support under Wine (e.g. NVIDIA: Linux Support (Wine) - #36 by xioren00topaz) although Intel GPUs seem to work. Not sure about GPUs from AMD. (The lack of GPU support is not specific to this release.)

1 Like

Upgrading to 3.0.0 today worked without a glitch on Linux/Wine! Just running the installer once was enough; no need to kill and restart it. Thanks for fixing that annoyance!

This topic was automatically closed after 59 days. New replies are no longer allowed.