Video shot vertically from phone gets flipped to horizontal

Video shot from an old iphone has a resolution of 640x480. The video was shot vertically. When I play the video on the PC it displays fine, when I put it in Video Enhance AI it flips it horizontal. Does anyone have a solution for this issue?

1 Like

don’t use VEAI for that :grinning_face_with_smiling_eyes:

I’m not saying I want the video flipped. I am saying VEAI is flipping it from vertical to horizontal when it renders it.

Have you tried entering a custom resolution? It could be you are accidentally cropping it to the landscape version of the resolution?

This is a known issue for VEAI for a long time.

VEAI ignore the “rotation” flag in metadata and cause vertical video become horizontal after processing.
It seem that developer is writing a new video IO for VEAI, and the problem should be fixed in future release. But ETA is unknown.

At the meantime, you may use ffmpeg, exiftool, etc. to add back “rotation” flag to the processed video.

ffmpeg -i input.mp4 -c copy -metadata:s:v:0 rotate=90 output_r90.mp4
ffmpeg -i input.mp4 -c copy -metadata:s:v:0 rotate=270 output_r270.mp4
1 Like

There are many ways to adress this:

the “not so elegant one”: Load it up in whatever you like, rotate it by hand, save it as losless as possible and then feed it to VEAI

As Ihjacky noted: After processing the file in VEAI, put the flag back in the file to tell the player to rotate it when playing back…

put out single images… When importing the into your encoder, tell it to rotate them prior to encoding

load the video into avisynth / vapoursynth and rotate it there, then feed it / frameserve it into VEAI (this being the most elegant and fastest method…)…


2023, TVAI still ignores rotation metadata, so you still need to re-encode the video with different rotation instead of changing just the metadata without re-encode.

Rotation is correct in MPV/VLC Player and wrong in TVAI, setting different rotation metadata with the following command does not change things for TVAI, only video players.

ffmpeg -i IMG_1507.MOV -c copy -metadata:s:v:0 rotate=180 IMG_1507-rotated.MOV

The best part: it’s correct in the thumbnail

edit: it’s rotated in the output now??