Video Enhance AI v2.2.0

Yes of course I know that, what I want to show here is that a version of VEAI is not working correctly compared to the previous version, example given here: from some versions depending on how you install the product, you lose to always what was in the previous preset that fits in this new version, well, this kind of thing is inadmissible, at least in everything I’ve learned about programming and its relationship with the end user, I have to give the user facilities, many don’t even know of what was said here if they do not participate in the community. What is certain is that they keep all the compatible presets, and the user chooses whether or not to continue with them, and not simply as a default installation, that it will do a clean installation, only with the new presets that “they think the program must have”, see what problem they are creating with it, think about the following: I buy the VEAI today, I will install it, and none of the presets suit me, and a compatible from a previous version that I didn’t have could work very well for this, and look how this is a very dumb thing at the programming level, I would say that the problem here is architecture, that is, the responsibility of the SOFTWARE ARCHITECTS TO BE MORE EXACT. I see Muf talking all the time about Artemis AA, and I don’t see this preset in my VEAI 2.2.0 version, so if I started today by buying the product and installing it, I will never have access to Artemis AA since it belongs to previous versions, this is a very serious problem, and then I’m forced to do a workaround and no one from TOPAZ is concerned about this, a software architecture error, mercy, this is very serious.



Ok, I am not a programmer. So, I trust your expertise. I know VEAI has many faults, but it is a new, experimental technology. So, for me, as long as I can get good results more often then not, then I am happy enough with the program. However, when I see a problem, I post and let the developers know. They don’t always reply because they are busy, but I know for sure that they read the comments.


Well, in fairness, the beta is the next version. It’s the one to critique and bugcheck, not the current release.

How so? There is a beta running now.

You’re only here since 15 days… :frowning: … so

  1. does topaz dev answer here or on the beta (private) testing page, (and facebook page as well) and listen to the community and aswner or to the beta testers as well, and try to improve the software ? YES.
    VEAI is one of the software i saw the most updated in my whole life, answer when they can.
    alpha sometimes open to public etc… no company, no software are perfect, and people will always complain about everything all the time anyway.

  2. are presets are improved and corrected with time ? yes.
    there is actually in the last beta a new model, very interesting, called Proteus, because it gives a lot of controls to what can be changed.

  3. serious company ? i can’t talk about the other software of topaz, but for what i see, they are very serious with VEAI. but this software alone will not cook a whole diner ! it’s to take in consideration. For example, for now, the best de interlacing feature is Not in VEAI, and has to be used in an another software, etc…

  4. at some point you’ll see the dev coming here to talk or etc… if it’s needed. if you take a look for now, most of the complains, are about feature not implanted, or not yet, or still in dev (like the de interlaced one).

as far as i can tell, i never saw a software like this, it’s pure magic and a one in a kind.

Edit :
5) the issue of a model disapearing , replaced by an another one, which was better at some time for some etc … is known. it’s marchine learning software, and as they said, too, at some point, some models can’t be be learned more without giving bad results, and some have been kind of abandonned or removed (like some Gaia and Theia).

actually there is a lot of models, and a very nice GUI who is present since 2.0 the software is, as someone said young (a bit more than one year old). For most people, it does the job, and do terrific result. People want a all in one software to de intereslace videos that professionnal does directly on film Scan… This is a small software which does it best, and so the dev team with it. it’s Not perfect, but each new version I see, except about some issues or when a bug appears or can make the software being a step backward, is usually an improvement.

1 Like

I really hope this “ProRes HQ (Fast)” issue gets fixed in whatever the next release is. I can’t output anything with HQ selected. I assume that compared to “ProRes 422 (Slow)”, the “HQ” quality is better.

hello, there are still no updates ??

1 Like

Next update is in beta currently

1 Like

Have you improved Dione models to deinterlace “i” footage?

There are two new beta models; Chronos and Proteus, general engine improvements and smaller UI fixes. No modifications to existing models are listed in the changelog for the current beta.

Can somebody explain how compression factor is working? Formula of output bitrate.
h.264 video 1000x1000 12000 bitrate
upscale 200% into 2000x2000 with compression factor 25
What will the final bitrate be?

Anything related to audio passthrough or mkv container option in there?

Nope, or not yet.

What is the target for these new models? Which type of footage?

I’ve made you a beta user, try it out here and let us know what you think.

Anyone else who’d like to try out the beta, click the link above and request to be a beta tester and I’ll add you.

Anyone else getting crashes on VEAI 2.2? I just upgraded my GPU to a 3070 from a P2200 and i cant seem to even get 1 video enhanced now without crashes.

Try a clean install of the latest Studio Driver 462.65 not the Game Ready Driver. Don’t forget to reboot just to be complete.

I have tried with both the game ready and studio drivers, still having the issues. I went back to 2.1 and I was still having the BSOD crashes (Memory Management). I tried taking out the GPU and putting it back, I have also changed BIOS setting to change the PCIE from Auto to Gen 3 (although the slot is Gen 4 capable), I have also used DDU to remove all drivers and installed them back, I am still having the issues which is kinda crazy. I have been trying to upscale a 480P video to 1080P with ALQ.

I am using an i5 11500, B560M Pro Ax Mobo, 32GB Ram and a 3070. I have already stress tested the GPU and that doesn’t seem to the problem and I doubt the PSU 750W is a problem all all the temps seem fine to me.

2 scenerios:

  • Your CPU is too hot.
  • Your motherboard cannot handle RAM X.M.P

My RAM isn’t overclocked and I just did a memory test and that wasn’t the issue. ALQ does push the CPU quite high in usage for me but I am using beefy Dark Rock Pro 4 and temps in HW Monitor seems to be fine, for all the components. I am trying another upscale with ALQ and see if it still crashes.