Video Enhance AI v1.7.0

Download: Windows, Mac. Released November 5, 2020.

Major features

  • New AI inference engine
  • AMD GPU support for dedicated GPUs on Windows, including new RX 6000 series
  • Nvidia RTX GPU tensor core and new RTX 3000 series support
  • More efficient use of GPU VRAM, working better with other GPU intensive apps.
  • New v7 Artemis models with better motion consistency, denoising, and sharpening capability.
  • Jpeg and EXR sequence input support
  • Output MP4 h.264 CRF setting to control output video quality/size

Improvements

  • Theia “Restore Detail” parameter wording changed to “DeBlock” to more closely representing the effect of the parameter

Know issues:

  • Gaia-CG produce less sharp result than V1.6.1. Still trying to resolve it.
  • Support Windows 10 1909 and above.
13 Likes

Finally AMD support !
Thank you so much i will try now !

2 Likes

I understood that up until version 1.6.1, at some point Windows 7 support was dropped. But, it still ran on Windows 7.

It looks like starting with the 1.7.0 release, it will no longer run on Windows 7.

It complains that the following files are missing:

d3d12.dll
msvcp_win.dll
api-ms-win-core-sysinfo-l1-2-0.dll

DirectX 12 is Windows 10 only, but I still tried downloading the above files from dll-files.com and put them into the Video Enhance AI directory. Alas, it did not work… it gives an error:

veai_error

So I guess this is now the final end of the line for Windows 7 x64 SP1. (?)

If so, the installer really should not continue if it detects it’s being installed on Windows 7, or at least warn the user that they can continue installing but the program will not run.

It seems like if I’m running on a non-GPU machine with OpenVINO (no graphics card), it really shouldn’t need DirectX 12 or Windows 10, unless it started using the WinRT C++ libraries or something (which have to run on a Windows 8 or 10 kernel).

(By the way… why is there a super old MESA opengl32sw.dll file in the application directory that isn’t even used?) :stuck_out_tongue:

So, it looks like I’m stuck at 1.6.1 unless / until I can get a Windows 10 system up and running.

DANG!!! :frowning:

1 Like

Also, users should be informed that the GaiaCG model has been changed. I can’t run it myself, but I’ve been reading on the Facebook group that the new GaiaCG model is not as sharp as the old one.

1 Like

I have AMD too, but I cannot use this AI with CPU only… I will try it!

Really nice to hear, that AMD version is added.

Please tell me how do you compare processing speed (efficiency) vs Nvidia?

Also is it worth to buy the tensor equipped card (3070 8Gb) instead of 2080 TI 11GB without tensors?

1 Like

When we tried it on a cheap GPU (AMD/Radeon RX 560), it took roughly twice as long as the CPU only (Ryzen 5 3600):blush:

How are computing speeds in that new version? Especially for Gaia HQ.
Thanks!

On my PC, it’s a few percent slower than before (1.6.0).

And talking about quality? Is there any Ai better than Gaia HQ now?
Thanks

For me, with a 2080ti, processing speeds generally increased by 100 to 200%. Varies with model used.

Artemis V7 was just introduced, and it is a BIG improvement. Both HQ and LQ.

I’m getting 0.08 seconds per frame on 2x scaling of 720x576! So I can do an hour of video in just over 2 hours.

Note that, for best speed, the program must have access to the internet and download the appropriate model for the size and amount of upscaling. Once downloaded that model will be used for the same values in the future. If not downloaded it will only use the base model. Models are located in a models folder - look at your log folder and go up one level to see the models folder. The total number of models is 234, but there will be a different set of 234 for people with and without tensor cores and other graphics differences. For me the total size of all files (I figured out how to download them all) is 7.41GB

5 Likes

I have 0.5 sec per frame at Theia_F with notebook RX580, and 2,2 sec per frame with the same notebook, 3.6 GHz Ryzen 1700X.

So speed-up is impressive.

Thx, Topaz! :heart_eyes:

2 Likes

Really having speed issues in this new version and it started with 1.6
Now let’s compare v1.5.1 and v1.7 using GAIA-HQ @200% with SD 480p input video

5 7

First you can see that V 1.5.1 has all my memory available usage and that GPU load is constant varying between 85 and 100%. Make it constant 0.25s/frame
With V 1.7 , only half of memory available is used and GPU load is very irregular with gaps at 0%. Making it always fluctuating between 0.3 and 0.4s/frame

question to the developers.
I have three GPU TITAN RTX and in previous versions at startup
of the three applications, all three TITAN RTX GPUs were running.
In version 1.7, only two TITAN RTX GPUs are displayed and work
the overall speed dropped accordingly.
Please answer if I have a problem or a problem with the program.

2x 1080 TI and only 1 is available.

1 Like

Unfortunately the new ai engine will not support win 7. Sorry.

1 Like

Is it better in that version Artemis HQ or Gaia HQ for you?

Definitely Artemis.

1 Like

About 2x was a bit of an exaggeration; it was about 1.7x.

I’ve used GaiaCG a lot in the past, but the new version of the GaiaCG model doesn’t look very good. It looks fuzzier than the previous model.

I’m not good at English, so I don’t know if it will be transmitted well, but when I tried the new GaiaCG, I felt that some sources had the effect of reproducing the texture of human skin. Is it because of my mind?

Another thing to note besides speed increase: My temps are waaaayy below what they were with 1.6.1 and earlier. My laptop with 2060 would get too hot to handle and really be whining, while beginning with the first 1.7 beta the fan speeds increase only a small amount.

If I run 2 instances of VEAI on my 2080ti the fans will go up to almost 100%, as they did with one instance in the past, and the speed of each instance is only about 10% less than a single instance.