Video Enhance AI v1.5.2

Download: Windows , Mac . Released August 27, 2020.

Fixes

  • Option to Select H.264 or H.263 for Video Output
    File sizes are smaller with H.263 than H.264, but H.264 is better quality. We consider this a temporary solution while we re-write our video IO engine to better accommodate different formats.
  • UI Fixes and Messaging Improved
    The phrasing of errors and messages has been changed along with some new notifications to give the user more choice in how the application behaves.

Known Issues

  • CPU Selection
    When there are no GPUs present in the system the GPU selection is blank rather than showing Use CPU
2 Likes

A quick test of a few previous bugs:
The “Setting as Default” does not appear to have any of the previous problems, as far as a few tests go.

Issues with ending frames still exist. Ran a short, small 524-frame video through, and the last frame displayed in the output is 523. Clipped it to end at frame 184 and it went all the way, but double-printed frame 184. Note that this is with MP4 output - JPG output appears at a glance to end properly both for the full and partial outputs.

Loaded a video that had Rotation at 90 degrees, and that was ignored in preview and not written in the output.

I guess that if we don’t output h263 we don’t need to update from v 1.5.1

Im running slow coding times with low GPU usage on my 2070super…

Also im using more CPU…

Did this update broke something?

Topaz VEAI 1.5.2 command-line veai.exe has regressed compared to the last beta 1.5.2.x releases, it no longer outputs to specified file type. Example tiff 16 bit file type option “-f 16tif” outputs jpgs. Output folder path “-o \\server\share\folder” does not work.

This is machine translated from Japanese to English, so please forgive me if the text is difficult to understand.

I have been testing the preview function of the new version (1.5.2), but in my environment, the CPU usage has increased by about 30% and the processing time has increased to about four times that of the previous version (1.5.1).
The settings are SIZE: 1730×934, SCALE: 100%, Gaia-CG
The other settings were similarly heavy and slow.

When I check the task manager, I see AMD’s dGPU usage going back and forth between 0-20%, is this behavior normal?

I tried several times to set it to CPU only, but the settings were not reflected when I restarted the app.

Very disappointed to see Gaia-HQ processing time for scaling 720x576 PAL by 2x to PNG out has increased from ~4-5 seconds per frame in version 1.5.1 to ~16-20 seconds per frame in 1.5.2. I’m guessing OpenVINO is no longer supported on my machine?

This option now appears blank (was “Use CPU” in 1.5.1):

I can select CPU:

I get this message:

Application closes but does not restart. Restarting manually, the option is once again blank:

And processing continues to take ~16-20 seconds per frame, using the same CPU resources as version 1.5.1. That’s a pretty drastic drop in performance.

There’s no way for me to troubleshoot whether OpenVINO is working or not as the app doesn’t provide any feedback for that, other than the huge performance drop.

I guess I’m stuck now at version 1.5.1. Very disappointing! :frowning:

1 Like

If I stop processing and exit the application, I get this error before it closes:

That never came up before…

I tried what you told and don’t have that issue. did you think to open a ticket and explain this ? did you uninstalled 1.5.1 before installating 1.5.2 (in case the issue would come from something like this ?). any beta or alpha installed ? i use my Cpu too for rendering (i7-7700 with HD 630 iGpu). just tested a 640x464 to 1920x1440 300% with Png output in Gaia-Cg, and i get a 2.82s/frame.

Yes, 1.5.1 completely uninstalled, manually checked reg keys and user folders.

Here’s what 1.5.2 looks like processing on my machine (it’s ClassicShell on Win7, not WinXP!)


Compared to 1.5.1:


It’s probably unique to my machine and I’m not going to be able to go beyond 1.5.1. That s**ks.

Are you on the latest windows 10 feature update? If you are having problems with speed upgrade to Windows 10 2004 feature update that came out a few weeks ago. It’s not required for this version but may solve some problems. I believe the next major releases 1.6.0 will require it.

CPU is selected. It’s a known bug if there are no GPUs in the system. If you are seeing worse performance upgrade to the latest windows 10 update (2004) and try again.

Why are you still on Windows 7 ?

Because I don’t want to be on 10.

So that’s it for me then. It was fun while it lasted. Thanks for the support up until now!

1 Like

Thanks for the reply.

I see.
I will try to update from Windows 10 1909 to 2004.

Be aware that there are tons of users unable to update. I don’t know the percentage, but I have a lot of Windows 10 machines, and ALL of them say on the update screen “The Windows 10 May 2020 Update is on its way. Once it’s ready for your device, you’ll see the update available on this page.”

1 Like

Are you exporting to image sequence? It could be that the H.264 encoder if you are using that is taking the CPU from processing.

Ok I dug into this more. Still try to do the update, but I’m less confident that will solve the problem. If it doesn’t as I expect, please contact support and give them your logs so we can diagnose the problem. Just send in your username with the logs and a quick explanation and we should be able to get some data.

You can still send in your logs to support and we can take a look to see if anything can be done! We aren’t officially supporting Win 7 since Microsoft doesn’t anymore either, but since this seems to effect both win 10 and win 7 we are still going to look into it. Just include that you were from the forums and one of the Devs asked for your logs.

My mistake. It’s 1809 that will be required I believe.