Video Enhance AI - Current Issues

This is a very promising product.

I’ve only just started using it and have had no results as of yet, but I wanted to make sure I’m not doing anything wrong.

I’m finding the software incredibly slow, even to process a few seconds of footage. I understand it may take some time but I’ve literally waited hours. I have a relatively powerful machine but am finding the responsiveness of the software slow - for example when you start and stop operations etc. I’ve had to resort to crashing out. Is anyone else having this experience?

Hello Dan and everybody,

I have similar, maybe even identical errors. I downloaded the production version 1.0.1.

Error # 1. The program cannot detect the GTX 1070 GPU (on Win 7, 64-bit).

BTW: I use Python + CUDA 8 because I am also a developer and my programs work with GPU very well.

Video Enchance AI 1.0.1, on the other hand, only “worked” in CPU mode.

.
Error # 2. I wrote in quotation marks because the program renders frames, but then doesn’t save them anywhere. The effect can only be seen in the preview window, not on the disk.

I tested small and large images. As a source I used my graphic works, files of the .png type. To shorten the rendering, I made the animation for 2 frames.

.
Error # 3. Like you, after pressing “Stop” before finishing work, the program hangs (crashes) and you need to remove it manually from Windows tasks.

.
! Interesting fact: I tested the program several times (from 672 x 605 px to 2376 x 3780 px).

, and only one time the program saved the resulting .png images. The result is very good. I tested my work, a little boy’s drawing

Unfortunately, I can’t repeat it because I changed parameters and order randomly (e.g. preview first and then normal, then vice versa). However, in normal mode I could not force the program to do “save pictures” - neither in “preview” nor “normal” mode.

(I used the “Process Monitor” software to check if the program saves ANYWHERE images to disk, unfortunately they are nowhere to be found :slight_smile:

Conclusions: the program has a revolutionary idea, but you have to refine it technically because it works on some systems and not on others.

Regards,
Lech

The program is not designed to run on windows 7, Windows 10 is a minimum requirement

The following is the minimum specs you need:

  • nVidia GPU >4GB VRAM to run fast (CPU can run but quite slow). (Minimum GTX 1050).
  • Cannot handle “interlaced” video directly, footage needs to be to de-interlaced first.
  • Window 10 platform

If you have the minimum requirements you should get this option in the Process Menu:

image

Hello Don,

Thank you for trying to help me, that’s very kind of you.

But before I downloaded the program, I checked the exact requirements here:

Your informations are different.

Maybe they come from another manual? If so, support should agree and equalize information on all websites so as not to mislead customers.

Regards,
Lech

AlsoWin7

I downloaded the free 30 day trial of Video Enhance AI to see how it compared with other programmes that claim to upscale SD video (none of which in my opinion produce good results.).
I would class myself as a reasonably competent video editor and can work pretty well with programmes such as Vegas and Adobe Premiere but I do not understand all the technical stuff that lies behind video such as codecs and colour space etc. Thus, if the average video editor needs to know all this stuff to use Video Enhance AI then I’d say it is not fit for purpose.
So, my initial comments are as follows:

  1. In the UK at least, pretty much all SD video cameras dating from the late 1990s to the mid 2000s produced interlaced video and I’m sure many of us would rather upscale this format to say BluRay rather than BluRay to 4K. Video Enhance AI doesn’t work well on interlaced video (as I found out, lots of lovely razor sharp, horizontal lines around any hint of movement!).
  2. I de-interlaced some SD video in Vegas and put through the ‘progressive’ clip through AI. The clip contained a fast moving train. The result was very good, the best I’ve seen with much improved sharpness and no evidence of the lines seen in upscaled inter-laced video. So, pretty impressive. Static subjects even better.
  3. The biggest problem for me was the processing speed, 4h to process 30 seconds of video (that’s 20 days continuous processing for 1 hour and I have hundreds of hours of material!). My PC has an Intel i-7-6700 CPU @3.4GHz and a high end Graphics Card so reasonably powerful for home use.
  4. Even if I spent another £400 to get the recommended Graphics Card (on top of £160 for the programme) and it speeded things up 10 fold it would still be far too slow for general use.
    Overall, impressed as I am with the results on a very short section of de-interlaced SD video, the above problems will need to be addressed before I would consider purchasing the programme. I do hope Topaz manages to fix these issues as I think it is a great programme in the making but a long way off at the moment.

If you don’t meet the minimum GPU requirements the application will use the CPU.

My GPU (GTX980) is significantly faster than a GTX 1050, yet it is falling back to CPU rendering. Why not just let the user decide? It seems that Topaz is using a baked-in GPU whitelist which is rediculous as it’s both incorrect and will be a pain to maintain over the coming months and even years.

I think making assumptions about whitelists is ridiculous… in your case have you raised a support request to get your issue looked at?

clicking on your link shows win 10 only.

They must be using a whitelist because they’re not running any sort of benchmark to determine GPU speed, and I’m running the latest drivers (442.50). Either that or there’s some sort of software black magic trickery I’m unaware of :man_shrugging:

To be fair, I see that screen with my GPU, but it still falls back to the CPU. I’m wondering if it’s a bug rather than a hardware requirement issue.

have you raised a support request?

Regardless of specs, VEAI doesn’t support graphics cards less than the 10xx series unfortunately.

Unless there’s a functional reason behind that decision, it’s a very, very bad one.

Yep, we’ll see what happens. It’ll be significantly narrowing the customer base if it’s true and they only support 10XX GPUs and above. What about AMD? What about new cards, or old beasts like th Titan series? Having a limit on what GPU can be used makes zero sense.

Why don’t you raise a support request as you absolutely have no idea, pure speculation on you part.

Good Morning,

The reason Video Enhance AI does not support NVidia cards that predate the 10 series (ie your 980) is because they aren’t compatible with TensorFlow.

We are currently working on adding AMD compatibility.

3 Likes

What’s wrong with speculation? In software, there’s not always a million ways to achieve an outcome :man_shrugging:

This official Tensorflow documentation suggests that several more GPUs prior to the GTX 10 series are capable of TensorFlow:

https://www.tensorflow.org/install/gpu

Hardware requirements

The following GPU-enabled devices are supported:

Software requirements

The following NVIDIA® software must be installed on your system: