Video AI watermark on owned copy

i have paid for Video AI but the new update is showing a watermark and I can’t get it to go away.
How can I get the app to recognize that I own it?

If you scroll down, there is a link on the bottom of this page to support. I’m sure they will get you squared away.

Hello and thank you for using Topaz Video AI,

Logging out of the app and re-activating after an update can help reset the watermark status.

Control+L on Windows/Command+L on Mac will sign you out and bring up the dialog box to activate.

If the issue remains, please file a support ticket and a member of our team will be able to assist.


  1. My license expires in 2024, but 3.1.10 is incorrectly stating I need to renew my license to upgrade to 3.1.11. It’s also now watermarking my videos

Manually downloading the newest version worked around the false ‘you need to renew’, but 3.1.11 still is watermarking videos

This is a serious bug that requires an out of cycle fix

Logging out in the app and logging back in also doesnt resolve this.

Hi Brad, thanks for reporting this issue. This is a bug that is known to our developers and will be fixed in the 3.2 update. I will reply in this thread with a link to the beta release for 3.2 as soon as it is available.

Apologies for the inconvenience.

1 Like

Thanks Tony!

Hi Brad,

Here’s a link to the v3.2 beta release thread:

When is this going to be fixed? I’m using 3.2 but i can’t get rid of the Trial Mode either.

I also just got the 3.2 update, both 3.1.10 and 3.2 have this issue (Trial mode/watermarking).

I JUST renewed my upgrades, what the heck is going on? I hope those of us experiencing this will be given additional time on our licenses.

Hello, for users with active licenses that are still seeing watermarked output, we recommend the following steps:

  • Navigate to “/Applications/Topaz Video” (macOS) or "C:\ProgramData\Topaz Labs LLC\Topaz Video AI\models" (Windows)

  • Delete the file “auth.tpz”

  • Relaunch the app and sign-in

I’m using v4.0.8, and I have paid for the software.

There’s a large Topaz watermark in the middle of my video. I imported a 1080p video with 29.97 framerate and left those settings alone, then I chose the Artemis model on HQ. (3.4 MB)

it’s not just artemis…it’s also happening on gaia!!!

Seems like it’s fine now. It logged me out and asked for my license again, so I tried with a 1 minute video - no more watermark. Annoying that it wasted over 6 hours the other day though.

Hi @Vee1408 @shawn.danker This was a bug with the later v4 series patches around the new year. Can be resolved by logging out and logging back in again.

this seems to started happening a few hours ago. first whatever i upscale at the output now suddenly has a topaz labs ai watermark right on the video. despite the fact i’ve got an active sub. i try to resolve it by logging out and logging in but now the stupid system won’t let me in because everytime i try to sign in via browser i get an error msg saying site can’t be reached. WTH is going on???! this is unacceptable