Video AI running slow on M1 Pro 16" Macbook Pro

I have been using Video AI on my M1 16" Macbook Pro since V3.0 went GA. It’s been working really well for me however, in the last few days it has become very slow. I noticed yesterday that v3.1.9 would take longer than usual to load a video, and the general performance of the app was sluggish. For example, if I opened up the Preferences menu, it would take approx 5 seconds to open. And then, if I selected any of the options in the preferences menu, they took much longer than usual to load. Something is defiantly wrong. I made sure to run a disk utility check on my Macbook Pro and also tried Video AI in Safe mode, which made no difference. Updating to 3.1.10 has not improved the situation, nor has downgraded to 3.1.8. I also noticed that when the application opens, I can see the Trial Mode logo in the top right-hand corner for about 5 seconds, and then it finally disappears. This never used to happen previously.

Once a video is loaded, it takes much longer to click and skip through to a later section of the preview timeline. General performance is now not useable, which is a shame as I have been enjoying the app for months without issue. The only change made to my system recently was installing MS Edge browser but not sure if that could cause any issues??

FYI I tried attaching my system profile but it fails as the size is over 6mb

My Macbook Pro has 16gb ram and running MacOS Monterey 12.6.3

I think I have resolved this issue for the time being. Removal of the app including the preference files, a system restart and then a clean install of v 3.1.10 has got it working back to normal for now. Hopefully it stays that way.

I’m having a similar issue (2019 16" MacBook Pro, 2.4 GHz 8-Core Intel Core i9, 64 GB 2667 MHz DDR4 and 3GB available space on internal SSD) and in addition to the tool running really slowly, I repeatedly get “out of memory” or out-of-disk-space errors with the app freezing-up even with videos that have a run time of less than 8 minutes when upscaling from SD to HD or greater. This is happening regardless of the upscale settings.

Can you please reach out to support directly?

I managed to fix the app’s UI speed, but like you, I now have the “Out Of Memory” problem.

Just an update, It is still proving to be an issue with more instances of the memory error happening when using Gaia as opposed to Proteus or Artemis. I have since lowered my Topaz app memory to 90%, and it seems to be holding out ok. Definitely, an issue introduced in more recent releases. I don’t recall having this problem so frequently in the past.

Wow this totally fixed my issue. Apple M2 Max with 96GB ram and the app’s UI took ages to respond. I’d tried uninstalling but it hadn’t helped. I caught your preference file comment and that made all the difference. Thank you!

1 Like

I am glad it helped you too :slight_smile:

@trevor-0965, I’ve got the same 16" MacBook running the demo version, and the gui is fine and responsive, but running a couple of filters at the same time on 30s of video is taking 30m to process. I’m thinking it’s just the way it is with the state of Apple Silicon and their GPU, but if anyone thinks this is not normal, I’d love to know. Thanks!

If you are running multiple filters simultaneously on 30 secs of 4K, then you may well expect such processing times. Either the process times are worth it for the supierior results, or I’d recommend using one filter at a time.