Ver 3.0 Batch processing images crashes after processing 50 - 60 images

Batch processing images in Topaz AI 3.0 sees it crashing after process 50 -60 images. It does not use the Nvidia GPU as it used to. It increasingly slows down after processing the first few images. It hard uses the CPU 13 - 14% but it does bump up the power consumption. What went wrong? Every release you take one step forward 2 back and then race a new release that is unusable except if your processing 1 image at a time. This has been going on for 18 months and your product is commercially unusable.

Steps to reproduce issue:

  1. load a couple of hundred .jpgs or tiffs or DNG’s
  2. Select all images
  3. Press save
  4. Then process
  5. Watch the resource manager as available memory keeps growing
  6. Crashes back into Topaz AI and you will have fun working out which files it processed.

Topaz Photo AI [v1.x.x] on [Windows/Mac]

1 Like

Please send me your system profile information so I can check if your computer hardware is up to date.

You can securely submit your files(s) to my Dropbox using the link below.

Please be sure to send me a note here to let me know you sent something.

Hi John, systems information has been deposited in the dropbox account as requested.

Mark

Hi John,

I have posted my systems details to your dropbox account.

Regards,

Same problem here.

Sent my system configuration to the dropbox folder.

Hi John,
I have done 10Hrs testing and can report the following.

  1. That 3.0 is not using the GPU but rather the CPU no matter what you set it to in the preferences. It makes no difference if you us Studio or Game Drivers.
  2. The antimalware service in Windows 11 is constantly being triggered when Topaz AI is generating / saving images.
  3. That after processing 15 - 20 images Topaz AI slows down to a crawl. This can happen if you just process 15 -20 images individually without quitting Topaz or if you just run them as a batch. If you keep processing the system will crash.

Regards,

Mark

What I can add, on top of what Mark said, is that when I am processing more than 40-50 photos and I try to apply the same settings to all of them, I see a surge in RAM usage, going from 10-12GB to 64GB (on my machine that is the memory installed) and then going back to normal. When that happens, then if you try to export all the images, it will fail at some point.

Yes, I have been investigating this in detail and can report that after processing 10+ images in a batch that the link to the GPU gets dropped (stopped being used) that Topaz AI then drops to just using the CPU which then starts to increase in memory usage with each image that it processes (slowing down dramatically as it goes) until it completely fills the available physical memory at which point it crashes and restarts Topaz AI with all your images there but the AI processing settings all dropped off every image that you individually had to set. This also happens if you edit images one at a time in the time line and save them as you go. It is currently usable for processing more than a handful of images at a time. You have to exit Topaz AI after processing a handful of images and restart it to continue which clears the memory and allows the GPU to be used again. I’m not sure who’s programming / testing this but they clearly only have a 1 image testing system given this release got out. I have found an absolute host of other bugs and will not using the tool for at least 4 updates from now! Just one of these issues is that in batch processing you can see that Topaz AI runs the autopilot first before it detects your settings and then reruns! How much power is being wasted with just this one bug? Another is that if you change a settings slider in one element when making adjustments it reruns ALL of the other elements to generate a new preview image. How much power is being wasted doing this? I could keep going but don’t have the time to waste.

This is at least the 3th time dat Photo AI crashes during a batch of 200 photo’s and I still have to finish it !

Steps to reproduce issue:

  1. Drop 200 .DNG files (Samsung S20) files into Photo AI
  2. Select All 200 photo’s
  3. Add denoise and sharpening enhancements and finetune parameter
    4 Save 200 images as 16bit TIF-files with zip-compression
    5 Sit and wait to see it crash

FYI information. I never had this problem before on previous releases, although this is the
first time I run it on this brand new ASUS laptop ( I5 16GB Nvidia Geforce RTX 2050 2TB).

I added all Topaz Photo system logs and also dxdiag.ex result.

Bert Fokke Topaz Photo AI Logs.zip (3.6 MB)

Topaz Photo AI [v2.4.1] on Windows

Thanks for sending in those log files our developers are currently investigating this problem with Batch Processing. Are you able to use a smaller batch to see if this issue still occurs?

Hi John,
I’m sorry but I’m glad I got Photo AI stable again on an older version.

Will wait for a new release before re-installing.

Kind regards,
Bert

Yeah I have the same issue. I imported 326 photos.
image

Let’s try updating you to the most recent version release to see if this resolves the issue.

Please make sure you’ve also turned off any firewall, VPN, or proxy that may be on your computer. These are known to block the installation. Also, make sure there are no settings or configurations in your OS system that could interfere.

Try using the appropriate OS system link to update:

If you are still experiencing problems, please reach out to us at the following link:

Topaz Labs | Support Page

Least I know I am not the only one with this issue. I already did a clean re-install “grabbed a new install file from topaz site” still having batch crash issues. Guess we wait for an update to resolve :stuck_out_tongue:

Hi,
I am still having issues with Topaz photo 3.0.

  1. I am importing Tiff photos (150mb files)
  2. I found the number before a slow down and then crash is about 100 tiff photos

Standalone batch processing Sony A7R5 .ARW raw [lossless] files stops processing queue after processing around four files [may vary based on other open programs]. Files are being saved as DNG with compression enabled. It appears that Topaz Photo AI does not release memory after saving a processed file.

Steps to reproduce issue:

  1. Place 8 .ARW files into the queue
  2. Select all images
  3. Save all images as DNG with compression enabled

Topaz Photo AI v2.4.2 on Windows 11 Pro

I’m currently crashing 100% of the time loading .ARW photos into Photo AI 2.4.2 from my Sony A7RV. This is on a Macbook M2, Sonoma 14.4.1 (23E224). If I load a photo taken from my old Sony A7iii, it works flawlessly. Note that I have my A7RV set to “Lossless Comp (M)” RAW type.

It is a nearly instantaneous crash. It crashes whether I load from Lightroom, whether I right click on the Photo in Finder and do “Open With.” Or whether I load Photo AI first and select the photo from within. I can convert to TIFF and load it that way, but that is not my normal workflow.

Things I have tried already unsuccessfully:

  • Uninstalling and reinstalling
  • Uninstalling and installing 2.3.2
  • Rebooting
  • Deleting all .plist files and rebooting
  • Loading the photo from my local drive or loading from my NAS
  • Loading from Lightroom and Photo AI directly
  • I have no firewall, VPN, or antivirus other than what’s natively in MacOS.
  • Using sRGB or Adobe color spaces.

Steps to reproduce issue:

  1. Load the attached RAW in Photo AI 2.4.2.
  2. Observe crash.

2024-04-09-17-57-56.tzlog (19.6 KB)

_DSC4023.ARW (46.4 MB)

Let me know if I can provide any further information. Thank you!

Topaz Photo AI [v2.4.2] on [Mac]

Thanks for sending in that file and information. I was able to replicate this issue on my machine and have reached out to some of the developers to get some more insight into what might be happening while using this .ARW file with Topaz Photo AI.

In the meantime, can you tell me if problem occurs with other .ARW files from the A7RV or just this particular image?

1 Like

That’s right - Any ARW from my A7RV will crash the program as far as I can tell. This is just one example but I can provide as many as necessary.

1 Like

I’ve talked with the team and learned that the Sony Lossless medium and small format images are unsupported in Topaz Photo AI currently. A workaround for this would be to use the large format for now or convert those ARW files to a DNG, non-raw format (TIFF), or use Topaz Photo AI as a plugin to a third-party application (Adobe, Capture One) to read the file.