Upscale not working in Photoshop filter

New Photo AI user here. I opened a small file in photoshop (2k x 2k) and tried to use the topaz filter to upscale. But in the upscale pop out window, the pixel numbers cannot be edited. No way to enter in a new size. I can change units, but not enter numbers. The sliders work fine, but there’s no point to that if I can’t upscale.

I can use the standalone Photo AI with no problem, but I’d like to use the PS filter too for quick, lower-res edits. I just updated to 2.4.2, and same problem.

This is on my PC. Very fast machine and GPU. I often work with files around 20GB. Haven’t checked it yet on my macbook pro.


Topaz Photo AI [v1.x.x] on [Windows/Mac]

robin, I believe that function is not available through the PS/LR filters. It must be done in the stand alone application.

1 Like

To upscale in Photo AI when invoked from PS you need to use the File>Automate method - if you try through the Filters menu then upscaling is disabled in Photo AI (an Adobe limitation).

2 Likes

Ah, ok. Thanks so much Paul!

Hey Paul, neither GP or TPAI have worked for me trying automate through. I can see them but when I attempt to use the link it closes PS. Any suggestions?

I’m afraid not - they’ve both worked for me whenever I’ve tried them (which isn’t very often). Sounds like one for support.

Appreciate the response. I rarely use the functions and most of the work is completed through the filters. It would just be an added bonus.

I’ll reach out for the Topaz team once the get some of the more important challenges resolved. THX

If you are still experiencing problems please reach out to us at the following link:

Topaz Labs | Support Page

This topic was automatically closed after 60 days. New replies are no longer allowed.