Unable to process anymore, crash of ffmpeg.exe randomly

[If you are posting a new bug, please include the following]

  1. The bug / behavior you have encountered
    Suddently, since 2 days , i am unable to process anymore, crash of ffmpeg.exe randomly, in middle or at the end of processus, ending by un unknown error.

in log, the error code is
2023-05-06 18-42-36.909 Thread: 12004 Info EXITED: 4 -1073741819 1

the crash occurs using any configuration (VP9, nvidia, etc)

  1. Your system profile
    Windows 11 home, RTX4090
    TVA 3.2.4 , but also tested with 3.2.1 ,2 and 3

last events :
Microsoft KB (KB5026447) 05/05/2023
nvidia driver update 531.79 , but also tested back to 531.68

  1. Your log files (Help > Logging > Get Logs for Support)
    logsForSupport.tar.gz (170.1 KB)

  2. Any screenshots as necessary

[Please be sure to have searched for your bug before posting. Duplicate posts will be removed.]

i also tried to run the command line in debug mode

C:\Program Files\Topaz Labs LLC\Topaz Video AI>ffmpeg "-hide_banner" "-nostdin" "-y" "-i" "S:\test\B5_t03.mkv" "-sws_flags" "spline+accurate_rnd+full_chroma_int" "-color_trc" "5" "-colorspace" "5" "-color_primaries" "5" "-filter_complex" "colorspace=ispace=5:space=5:primaries=5:trc=5" "-c:v" "h264_nvenc" "-profile:v" "high" "-preset" "medium" "-pix_fmt" "yuv420p" "-b:v" "12M" "-map_metadata" "0" "-movflags" "use_metadata_tags+write_colr " "-map_metadata:s:v" "0:s:v" "-an" "S:\test\B5_t03_tvai.mkv" -loglevel debug

and there is no error message at all ! just the crash notified in eventlog, and also file deleted.
here the end of the stdout

i m goign to try by killing background apps, and if no result i will reinstalll windows :frowning:

Hi Fredo!

I wanted to double-check that this is not a permissions error. Can you confirm that tvai has proper permissions?

If it’s not a permissions issue, you will need to perform the following to verify your Windows OS and then do a clean install.

  1. Open an Admin Command Prompt

  2. Paste in DISM.exe /Online /Cleanup-image /Restorehealth

  3. Hit Enter

  4. Next paste in sfc /scannow

  5. Reboot

  6. Uninstall Topaz Video AI

  7. Delete the AppData > Roaming Folders for Topaz Video AI
    As a note, this folder will be hidden. To view this file, select View > Show Hidden, and here is the path;
    C:\Users<username>\AppData\Roaming\ Topaz Labs LLC\ Topaz Video AI

  8. Delete Registry Entries using the steps below:
    Open program RegEdit from your Start menu explorer and delete the registry entries of Topaz Video AI

I. Computer\HKEY_CURRENT_USER\Software\Topaz Labs LLC\ Topaz Video AI

  1. Reboot Computer
  2. Reinstall

Hello ida.topazlabs ,

i completelw reinstall the whole computer this weekend, then i can not process all of your suggestion, but i can tell :

  • i tried the sfc /scannow , as also the regkey cleaning, but no luck.

i have no idea what could corrupt what , but pretty sure it is related to KB MS.

i will retry the application 3.2.4 today , as reinstalling it on a clean windows. i ll keep up to date

1 Like

Thank you for the update

Hello ,

well, not really good news :

after my fresh install of windows, all drivers installed, and newly installed the last version of TVAI 3.2.5,
but still having the unknown error at the end . also , here the logs, i can see in that the format changed, there are more information, but message at the end seems for me nonsens, as it tries to delete original file (???) , the temp file (??) , and it warns about “Warning Unable to open empty filepath” , like some variables are wrong.

logsForSupport.tar.gz (105.0 KB)


also to precise, TVAI let files in the folder

an update :
i tried the same file , but original size, with h265 nvidia, but output format as mp4 or mkv, and it works.


here logs
logsForSupport.tar.gz (113.2 KB)

i will retry now by just upscaling


i think i found something :

i do not have the crash when i used mov ,mp4, mkv output, if i use upscale to HD and encoder ProRes422 .

then it tried the same settings but with h265 nvidia and h265 10 nvidia
this is both nvidia encoder which crash

here last logs
logsForSupport.tar.gz (375.1 KB)

then , i think something is related to nvidia drivers, or shared program with devices.
I will try to kill some stuff, and se if i can identify what.

also , in windows eventlog :


Well …

holy i get crazy :crazy_face:

i stopped some program like oculus, rainmeter, sandboxie, steam,epic , steam, afterburner as they could use some overlay, or do something related to the Gcard.

I did some test and all were successful , then i was happy to think i found something.
to investigate more, i restarted the pc, to this time stop one by one these program and identify which one is the culprit.

i am not able to make crash anymore my testfile …

here the last logs, but i will restart again and redo test .

some assumption would be an order of the start of programs which may be the culprit, bu it is too early to say…

I ll keep posted …

logsForSupport.tar.gz (239.6 KB)


was able to get a crash again. something is annoying ffmpeg, somewhere.

here the logs, you will find a success one and a failed one
logsForSupport.tar.gz (248.6 KB)


i ll keep testing , but if you have some idea based on logs … do not hesitate to ask to me to test.

another log with one succes , and a Dio failed (this one crashed in middle of processing.)

logsForSupport.tar.gz (270 KB)

the same with Dione :frowning:
logsForSupport.tar.gz (605.3 KB)

well , it keeps crashing , tested also on a local drive.

it crashed at the end, when temp file is completed; and the temp file is always the same size.
I would imagine this part is successfull (the file is useable)

What is the next action ffmpeg is supposed to do, just after finished the temp file ?

logsForSupport.tar.gz (194.9 KB)

I will try different model, as i can finalize with some model

1 Like

Hi Fredo, something is wrong with the end of the video, can you trim the last few frames out and try again?

Holy … good point, you put the finger on it !

thanks for pointing a direction !

I trimmed half of the video and it … worked…

I tested now with others video files which were giving the same problem previously (i had a problem with several files).

it also worked, if trimmed before the end.

on another hand, i need to understand 2 things :

  1. how the extraction of source video is damaged (will work on this on my side)
  2. how to detect/identify if video file is damaged . currently all source files appear to be running fine when played.

As i reinstalled my whole system now, i will retry the whole process to see how it react .

while analysing, i discovered something : when i trimmed video filed, the last frames displayed in Topaz Video AI are not the same than in VLC (it is like it miss 2-4 min of video).

On another hand, if VLC is able to play the source video file, i did not notice that no duration was displayed. and of course i have the whole movie with generic at the end.

then i controlled the prime source of the video file (the first extraction) , and this time i see the duration in VLC.
This point me out the part of process were the culprit is.

to clrify my wors, here my whole process :

  1. i use MakeMkv to extract from a disc.
  2. i use gMKVExtractGui to extract from previous step to different files , video, audio, subtitle etc.
  3. i use Topaz Video AI to work only on video.
  4. then i use MKVToolNixGui to merge back the new video, the audio and processed subtitle if needed.

the issue is the result of step 2.
also it is related to some specific sources ( some interlaced 576p and 480p)

i will investigate, but again, thanks for pointing me this direction , i was totally blind.

so bad that mediainfo nor another tool can tell if something is wrong with the video file.

here some screenshots to explain the whole speech :stuck_out_tongue:

A. Originale video file (with sound viode sub etc) [in VLC]

B. here the extracted video in step 2 (the culprit step) [in VLC]

C. and here that you helped me to pint out with trim [in Topaz video ai]

i will try on my side to understand what s going on with the step 2 (extraction) ,
as it is clear now that the file is damaged.

Maybe a suggestion, if TVAI could detect this when importing into the application, it could be useful, but i do not know if it is possible.

Thanks a lot !


that i was able to check, is if in TVAI i see the same last frame than in vlc.

i keep investigating, but seems related to some MPG file , but i will confirm that later as testing one MPG file showing the good size.

I use now media info to see if something is wrong with the duration of the video file, as i was able to see some video of 25min, showing a duration of 40s, while being large like original size.

thanks again !

I confirm , it is related to a failure in batching extraction.

imagine that i reinstalled the whole computer lol …

point resolved !

PS : thanks for the extra logging info in the last version.

1 Like

To complete, i found thé culprit: USB controller issue, where drives were connected…

1 Like