Unable to play H.264 files on my TV


what happens with H.264 on the latest version of Topaz? Previously I was able to read the files generated by Topaz without any problem on my television and since the last version, my television indicates file not supported.

I also tried to play them on my Blu-ray player which manages to play it but indicates that the file has problems…

Please solve this problem as soon as possible because it is not normal, especially at the price that the software costs!

When I look at the new and old files generated by Topaz, I notice that previously you are using the High@L4.1 profile and now the High@L5, could this be related to my problem?

1 Like

Are you upscaling to 4k? L5 only allows for max 3,672×1,536@26.7, whereas UHD is only supported as of the L5.1 Profile.

Try export with CRF 1, not 0. Should also give you thumbnails on more systems.

It doesn’t look like he’s using H264 as an intermediate format (as he’s watching the output on TV); in which case CRF=0 is ludicrous. :slight_smile:

Nope. Only 1440x1080 (4:3). I’m just upscaling a 720x540 SD source to 1440x1080.
With the previous version before the December update, I had no problem.
I only encounter this problem with a Hisense 1080p TV. With my 4K TV, no problem or error message.

Okay. Yeah, then L5 is too high. Needs to be L4.1 (theoretically, even just L4 will do). Depending on your TV’s sensitivity, it may indeed trip over the specified L5 Profile. You can try and use a simple tool like tsMuxer to change the Profile, and remux it.

This to me that is not a bug. They just use industry standard codecs. It is not their problem if your TV is out-dated. This should be moved to another category.

Posts like these need to be organized into other categories.

It is problematic to search through this forum on posts related to bugs in the operation and functionality of the software.

Better moderation is needed for this jungle gym. It would help us all.

I get confused where to post and read about software issues.

Wait, no. This is not about a TV being outdated, but about TVAI apparently writing an output file (according to the OP) that tells the TV the content is High@L5, when, in fact, it’s just High@L4. His Hisense 1080p TV then (correctly) determines it can’t play High@L5 content (as it’s limited to 4.1, max). At least that’s what I think is happening.

If TVAI outputs to 1440x1080p, it should decidedly not give the output file a High@L5 Profile.

So someone needs to examine the metadata of the file to see if there is an issue with the codec / wrapper being used? Seems simple to do?

OP said that’s exactly what he did. :slight_smile:

I need reading glasses.

No, my television is not obsolete and for good reason, it manages to decode videos encoded in H.265!

So yes, you’re probably right, it’s not a bug strictly speaking, but it’s still annoying for those who use Topaz for television use.
I think Topaz should allow more flexibility on codec settings because currently we are quite limited.

I tried to use TSMuxer to modify the profile but this box is grayed out, making manipulation impossible.

Strictly speaking, I think it really IS a bug. :slight_smile: Attempting to play content that is beyond the capabilities of your device (too high Hz, too high a resolution, HDR, etc) could potentially damage your TV. So, your TV does well to obey the rules, and be strict about choosing not to play the content when the container headers are telling it the content is too much for it to handle.

You have to select the checkbox in tsMuxer, btw:

Thank you for your reply and for all this information. Let’s hope that Topaz will quickly fix this bug in this case because it’s really restrictive! :neutral_face:

Concerning TSMuxer as I explained to you, the box is grayed out for me (see the image). No matter how hard I tried, I couldn’t modify the profile.

Small nitpick, unless you are playing these movies directly off your TV, it decodes nothing. It’s your media player that will do the (usually hardware) H265 decoding. H265/H264/MPEG2, whatever, to your TV it’s all just a raw data stream.

That is peculiar. Tried it with an .m2ts file here now too. Also, what’s with the no framerate set? Sloppy, Topaz.

Maybe you can mux the stream with mkvtoolnix first, to .mkv? Or do a preliminary pass, where all you do is set FPS. Very strange.

P.S. After my current encoding is done, I will try and replicate this bug. What container did you choose for output?

Please excuse me for this error. I am writing to you via an online translator. I just wanted to say that my television is capable of playing videos encoded in H.265.

Topaz makes me an MKV file, then I us MKV Merge to add an audio track.
I don’t touch the fps since it’s already good.

Only with Topaz videos, Tsmuxer refuses to change the level. On files encoded on Avisynth, I have no problem changing the level.

I don’t know what Topaz does.