Unable to install Photo AI 1.3.7

When I download and then try to install 1.3.7 the installer terminates prematurely and closes the program…

I’m currently running 1.3.4.

Steps to reproduce issue:

  1. Step 1
  2. Step 2
  3. Step 3

Topaz Photo AI [v1.x.x] on [Windows/Mac]

Hi @paul.hoburg, is this the in-app updater you are using or are you using an installer that you downloaded from our Topaz Labs Download Page?

Thank you. I had actually tried it both ways neither of which was successful. However, I just tried the link you provided and it worked, so thank you.

Neither the original emailed link nor this provided one work for me and apparently there is zero other way to ask for specific tech support. Everything is up to date and as a bonus I ran first aid on my hard drive which returned no problems. It’s on your end.

You can reach out to us for tech support at help@topazlabs.com.

You can also write in through the beacon (purple bubble on the bottom right) of Topaz Labs pages:

I’ll send an email about the issue I’m having but FYI that little chat bubble doesn’t show up in my firefox browser on any page under topazlabs. Everything’s fully updated on my end re: system and browser, no idea what settings would be blocking that otherwise since similar chat options work for other companies.

See this description on what you need to do with FireFox …

Suggestion that you use Chrome as it is easier than FireFox.

Thank you for the information.

There are good reasons some of us don’t use Chrome. Being that enabling chat is doable on Firefox for other webpages without disabling this feature, Topaz should consider going with a design that allows for that. I know every developer’s go to is to just tell people to use a browser they feel like coding for but, since this problem is not inherent to Firefox but rather a design choice, I hope they expand their code to consider this in the future since it’s not a no name browser choice and nor are privacy settings inconsequential considerations.

I guess there are good reasons as they have a 5% market share as compared to the others. Most of us use more than one browser anyway. It is only a website design question but you still have to allow popups no matter which browser you use.

Which webpages is it working for and which web pages is it not working for?

The tracking protection is similar to ad block. It does not differentiate between “good” or “bad” popups, it simply blocks them all.

We do not have an alternative to the beacon at the moment, nor will we be developing one without javascript for this specific situation.

It does not work at all in any iteration of Firefox for me, on any subordinate page on the topazlabs domain, including in incognito which usually allows for ads and popups in other websites that prompt for it and which I use to view those sites to allow ad revenue for them. It works in Safari, which I didn’t try at the time because I wasn’t even aware a chat bubble would have been an option since there’s nothing otherwise on the website to indicate I should be looking for one, such as a “need help? click the chat icon” type banner. All I know is no matter the source of download link the package does not install and only tells me to contact the developer (which I have not heard from yet for the original installation problem).

I have used multiple websites that do use javascript and many that either prompt to allow ads or don’t seem to have any problem from the start. Having looked through Mozilla’s pages on the subject, javascript is enabled as a default which explains why other web pages with chat pop up options don’t have a problem. Their incognito browser in my experience immediately disables adblock. If you don’t have an alternative to the beacon consider adding a page overlay that asks you to enable or allow popups as some news sites do. I always allow that when given the option for access to something I want to use. However, since going incognito is my usual solution to this I’m not sure what to even suggest since the chat bubble doesn’t appear there either. I’ll just go to safari in the future, but I doubt it is javascript blocking settings specifically. It certainly could be a setting I’m unaware of. I do not have all cookies automatically blocked, only cross site tracking cookies. I do not have all ads or all popups automatically blocked.

All of that said, I still can’t install the package from either email or posted link here despite a supposedly successful download. At least one that does not indicate a problem and runs the installer up to a certain point before failing without a specific error.

In the past I’ve had the install fail consistently when using a wifi connection to my router. A wired connection worked, which I’ve always used since then for installing Photo AI.

I think you need to say which actual sites you use where the setup you use allows popups and JavaScript …

"Which webpages is it working for and which web pages is it not working for?“

You clearly state that it works for other websites. Note incognito is not an option as JavaScript won’t be allowed under v23 or later.

To see your environment do the following…

In the address bar, type “about:config” (with no quotes), and press Enter.

That will tell you if popups or JavaScript are enabled.

Definitely says javascript is enabled unless “true” means something else in their world.

Off the top of my head, cookie permission popups are allowed whenever I visit a random stack site or news sites especially if they’re UK/EU. Amazon customer service chat works without being prompted to change a setting and that is a popup that then opens a window without issue. Apple support, my friend’s random web page that was built to practice js, Nikon’s similarly designed bottom right chat support. I’ve had some sites not ask for permission and it will just show up working fine, others I have to approve, but I’m given the option to approve or warned that something was blocked so I can manually give permissions which helps. Listing 99% of the internet is not really going to help figure out what’s wrong. It is harder for me to find the one or two past examples where it doesn’t work than it does since I usually just go to incognito vs having to switch browers entirely.

Thank you. I’ll try that if the next attempt fails since I’ll have to buy a cable.

From asking around, the beacon seems to function off cookies. Aside from that if your installation for Topaz Photo AI is still failing please reach out at help@topazlabs.com so I can troubleshoot faster and give more detailed information

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.