Unable To Delete Desktop Icon

Using version 3.1.10. The installer does not give an option to not create a desktop icon and I am unable to delte the one it creates. Selecting the icon and pressing the delete key brings up a delete confirmation dialog. I click OK, yet the icon is not removed. There should be a prompt to grant admin rights for this action, but there is none, so that could be the issue. Very strange behavior. Using Windows 10 22H2

Hi Lee,

There should be a dialog box for Windows User Account Control that appears when you delete the desktop icon. Are you on a standard or administrator profile?


I am on a standard profile, but we use something called BeyondTrust Priviledged Management that handles the admin rights. Normally when admin rights are required, I get a confirmation dialog similar to the default Windows dialog if you have UAC turned on. But when deleting the icon, I never get that, so the icon does not get deleted. Seems like somehow Topaz has not registered it correctly with Windows maybe.

And as a follow, I deleted an icon from my desktop from another app today and it worked as expected. When I deleted it I first got the normal Windows prompt asking me to continue or not, then got the Privileged Management dialog to confirm admin rights. With Video AI, no dialogs are presented, so I don’t think it is somehow setup correctly in order to trigger Windows to prompt for admin rights.

And what have BeyondTrust Priviledged Management support said ?

Nothing because being that this is the only application in the Topaz suite that exhibits this problem shows it Video AI specific.

What’s worse now is that when trying to install the April 18th update from within the application, that now fails too, because it doesn’t prompt for admin rights the way it did before. Before, the Privileged Management admin rights confirmation dialog would be shown, now it shows a Windows dialog for which you have to enter in admin rights credentials, which is not possible for the normal user. So with not being able to update the application from within itself, I closed it and uninstalled it, then ran installer for the new update. Fortunately, that still worked as expected.

This problem has never been an issue until developers re-wrote the application starting with version 3. Most basic things in it were broke it seems, like the login, but now that works. I think some attention needs to be made to how the application works in a user restricted environment.

Why is having a desktop icon such a problem in the first place?

I would bet 99% of Topaz users aren’t running things in a domain/enterprise environment. If you are, then talk to your IT administrator and get them to log in as admin and delete it.

It is a personal preference but was just pointing out a bug with the program. It’s obviously getting worse in later builds because nothing else in this scenario is changing but Video AI.

How does it get worse? You either can or can’t delete it. And it’s not technically a ‘bug’. The Topaz installer created the icon with certain permissions and your software suite is not recognizing those permissions and is stopping you from deleting it. To me, that seems like an issue with ‘Privileged Management’ software.

Also, you’d be better off posting this in the correct category. This is the ‘ideas’ category which is supposed to be for feature requests/suggestions.

There is a separate category for bugs/issues: Bugs and Issues - Topaz Community

The updater mechanism got worse… see previous posts.
OK, did not realize it was in wrong category.

Hi there,

Our team is aware of the inability to delete the desktop icon in managed Windows environments and we plan to fix this in a future update to the in-app upgrading system.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.