TVAI 3.2.x - AUTO bitrate H265 results in poor video quality

  1. Video source = Dragon Ball Z Opening (Japanese-Creditless) HQ - YouTube

  2. The BUG = With latest TVAI 3.2.x (stable and also with latest beta) i noticed that the final enconig quality in H.265 with my Intel UHD 630 iGPU, by selecting the “AUTO Bitrate” with Proteus v3 AUTO option, is really poor! (Also, I noticed that the file size by upscaling to 2x or 4x remains essentially almost the same, and the result is that the conversion to 4x is qualitatively worse than to 2x).
    With the same source video, if I use TVEAI 2.6.4 instead, again in Proteus v3 mode in manual (this time using x264 CQP 20), the quality and bitrate are higher, and there is quite a difference in weight between the video upscaled to 2x versus 4x.

  3. My SISTEM = JakSpoon_DxDiag.txt (132.9 KB)
    CPU: Intel Core i7 10700 (with iGPU UHD 630 enabled)
    GPU: Nvidia RTX 3070 8GB - with Latest STUDIO Drivers v. 531.61 WHQL
    RAM: 32 GB DDR4 SO-DIMM 2922 MHz (Dual Channel 2x16)
    SSD: NVMe PCI-E Gen3 Crucial P3
    Windows 11 Pro 22H2 v22621.1555

  4. LOG File = JakSpoon_logsForSupport.tar.gz (202.1 KB)

  5. Screenshots/Video = TVAI 3.2.x - AUTO bitrate quality bug (versus TVEAI 2.6.4) - YouTube

the problem is not quality , I also experience the same. the issue I noticed when using proteus in TVAI , is that the image is not sharp and even blurry.
the solution I found that works good for me is to set the settings to “Relative Auto” and bump the deblur between 50 to 65.

try it and see if you feel the difference in quality.

NOTE: Value of “0” in relative Auto mode, means it is set to Auto for that/those filter(s). it doesn’t mean it actually set to “0”. so in the above case (picture), you can see everything is set to Auto, apart from Deblur which is set to 65. so you enjoy both worlds.

1 Like

Thanks for the tip, Akila, but I tried the “problem” remains:

in fact I had already tested with the “Artemis” model (and as you suggested, also with “Proteus” and the “Relative to Auto” parameter, but the final quality remains worse:
the problem highlighted by me is a problem that arose with the latest versions, I try to explain better: in practice the final bitrate, selecting precisely the “Auto” method in the “Output settings” section, seems not to adapt properly to the final video: in fact, upscaling the video by four times, it gives as a result a video with a bitare almost identical to the same video upscaled by two times, and this does not make sense, since the video upscaled by 4 times, in automatic bitrate mode, should be much higher than the one upscaled by only 2 times!

Here are the details of the final converted videos with the two versions (details with MediaInfo):

TVEAI 2.6.4. = output MP4 h264 - CRF 20 - Proteus v3 manual
Dragon Ball Z Opening (scale 2x prob-3) = Resolution 1280x720 - Bitrate: 5 029 kb/s (vbr) = Video size: 65.8 MiB
Dragon Ball Z Opening (scale 4x prob-3) = Resolution 2560x1440 - Bitrate: 14.7 Mb/s (vbr) = Video size: 190 MiB

As can be seen from the data, obviously the video upscaled by 4 times with the CRF 20 method, having an adaptive quality, greatly increased the bitrate in relation to the final resolution, while maintaining a quality appropriate to the resolution, indeed!
Now let’s see the results version 3!

TVAI 3.2.2 = Output H265 main (INTEL) - container MP4 - Bitrate AUTO - Audio Transcode
Proteus V3 relative to Auto
Dragon Ball Z Opening (2x prob3) = Resolution 1280x720 - Bitrate: 6 106 kb/s (vbr) - Final size: 81.4 MiB
Dragon Ball Z Openint (4x prob3) = Resolution 2560x1440 - Bitrate: 6 281 kb/s (vbr) - Final size: 83.7 MiB

In this case, on the other hand, the quality expressed in final bitrate is almost identical between the two versions (uscaling 2x vs. 4x), and this suggests that there is a problem with the program or encoder in evaluating the correct bitarte for the uscaled output!

I just have to try doing the same thing with the NVENC encoder, instead of the Intel one: it is clear, however, that there is a fairly serious underlying problem!

ok ok, now I understand better the issue. to me it seems that the issue is not TVAI quality issue in v3.x as how the filter(s) work (i.e. Proteus 3), but the final encoding of the H265 in TVAI 3.x
that is strange, when i choose Auto in NVIDIA h265 in TVAI it always outputs at around 16mbps for 1080p upscale. Honestly i never upscaled x4 to around 4k, so i don’t know what mbps I’ll would be getting there.
in order to be sure that the issue is the h265 encoding that effects your final quality and not the Proteus 3 in TVAI (in your installation of course). please try to upscale with lossless (to approve or dispel it is only the mbps and not a combination of mbps and something in TVAI v3.x) and see if you getting roughly the same “bad” quality or you getting a good quality like in v2.6.4
to encode with lossless follow this short process (it will take you exactly 3 min of your time to set it up in TVAI, then you can use it as many times you like with one click).

1 Like

Hello everyone,

Thanks for your feedback on the auto bitrate settings for video exports. We are in the process of completely redesigning the UI for exporting and that will include more clear descriptions of the bitrate options and their effect on final output quality.

1 Like

Finally I found the BUG: this problem occurs only by selecting as encoder “H265 Main (INTEL)” inside “Output settings”, while if I select “H265 Main (NVIDIA)” the quality in bitare of the final video upscaled by 4 times increases significantly compared to the video upscaled by only 2 times, and thus also the final perceived quality.

@tony.topazlabs This is definitely some bug or problem of the program with the H265 encoder of Intel’s integrated graphics…
maybe it depends on the fact that in the settings, under “AI PROCESSOR” I selected only the RTX 3070, and not the other item I find in the list called “All GPUs”?

1 Like

or it’s a Intel driver issue, Topaz mentioned few times.
Try Maybe this:

1 Like

Hello and thank you for testing with both encoders, it really does help us narrow down the issue. In this case, it seems that Intel QuickSync encoders are not receiving the right auto bitrate setting from the app, I will forward this to our dev team to have a look at.

1 Like

Thanks for the reply! Could this problem depend on the driver installed or the type of GPU integrated in the processor?
I need to try what happens if I change the AI processor to “All GPUs” instead of just using the RTX 3070!

Thanks for the thread quote.
The only thing is that that thread mentions Intel ARCs, while the GPU mounted in my processor is older; at this point, as mentioned above, there is a question of whether it is a problem specific to this iGPU or a driver problem (or even a simple program bug)

Intel UHD Graphics 630 GPU - Benchmarks and Specs - Tech

The issue should be consistent across Intel GPUs that use QuickSync for video encoding. In your case I’d recommend using one of the Nvidia encoding options which will be more consistent in bitrate allocation while we investigate this issue with the Intel encoding options.

1 Like

Ok, so I am waiting for news on when this annoying bug will be fixed, thank you very much developers for your continued support!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.