Topaz Video AI v4.0.9

Hello everyone,

A new release of Topaz Video AI is now available.

v4.0.9
Released January 2nd, 2024

Changelog from 4.0.8

  • Updated EULA and added it to help menu for viewing.
    • These changes only affect Enterprise users working with Video AI in certain venues such as movie theaters and premium streaming services.
  • Adobe After Effects plug-in now available for macOS.
  • Disabled audio automatically when there are no audio tracks in input.
  • Batch processing now preserves more from video input settings on export.
  • Setting priority on outputs now respects your priority decisions.
  • Fix rotation bug where it won't rotate around 180 degree axis of current selected rotation.
  • Batch processing crop will only apply to cropped input videos, not all the selected ones.
  • Fixed incorrect version labels in UI.
  • Added "Recover Original Detail" slider details to labeling.

Known Issues

  • Batch processing selection will overwrite individual video filter settings.
  • Inconsistent “Preview X frames” enable status.
  • Rotation w/ previews will intermittently be over-rotated.
  • Looping previews has a stutter.
  • Live preview can have frame de-sync.
  • 11 Likes

    Is it just me or does live preview not work at all where u can compare frames side by side while processing? It’s been like this for like the last 10 releases now… It just says “not processed”.

    The priority todo list is a hot mess. How about you start with one of the most crucial tools actually needed for the app? This app has been totally useless since preview broke.

    9 Likes

    Live preview was enabled in Video AI v4.0.7:

    Here’s an example of the live preview system in the redesigned app UI.

    We’re working on improving the speed of the loop mode, which currently has a short gap between playback at the end of each loop.

    We’d definitely like to get more detail on any cases where the live preview does not automatically take over the selected view, either in this thread or at support@topazlabs.com.

    2 Likes

    Where exactly was this added? I checked all enhancements and couldn’t find it. Just the usual “Recover Detail”. I had assumed it was an IRIS LQ/MQ slider, as that’s where other users have been asking for the feature, myself included.

    It’s in the names of the files generated for previews and exports.

    My topaz isn’t working at all the quality looks the same.

    I haven’t found the live preview option yet. Not when exporting. :eyes:

    4 Likes

    There isn’t a live preview during export. It’s on the “coming soon” list.

    5 Likes

    Do you know how to fix topaz not upscaling i put in the settings and everything but it looks the same.

    i hope it does come soon

    How I can use the Plugin?
    I extracted the DMG, but there is no Plugin-File, where it asks to install… :thinking:

    https://docs.topazlabs.com/video-ai/plug-ins

    1 Like

    But is the Plugin also available with the Trial Version?

    Hello,
    There is a new major (for me) issue with this new release.

    “Frame Rate” setting is not retained when exporting more than 1 clip at a time
    I want to convert plenty (hundreds…) of DV clips (720x576/25fps) to 1440x1080+60fps+stab, but when exporting multiple clips at a time the Frame Rate setting is not applied (remain 25fps). When selecting a single clip and exporting, 60fps is applied fine.

    I’m rolling back to v4.0.8.
    Thanks in advance to look at it.

    2 Likes

    I am setting up the Framerate from 23.976 to 60Hz and Video Upscaling without black border from 1696x954 to 4K(3840x2160)
    Remove Duplicate frames is set “on”
    At a lot of positions in the resulting Video there´s this Image-Sequence:

    M-M-M-M-F-M-M-M-M-F-M-M-M-M-F

    M= Frame with movement
    F= Frozen Frame without Movement

    There are also some places in the Video without Frozen-Frames.
    Used: Apollo & Apollo Fast

    I have to run the result Video again with just Apollo Fast and removing those frozen frames takes as long as rendering the entire video with upscaling and Enhancement with Iris-LQ.

    Rendering to 60Hz or to 59.94Hz makes no difference.

    Now i have to upscale and setup the framerate to 60Hz(without removing duplicate frame because frame interpolation is creating those) and run it a second time using just FrameInterpolation with remove duplicate frames.

    Is it possible to do Frame-Interpolation from 23.976 to 60Hz without creating frozen frames ?!

    Going from 23.976 to 25 doesn´t create Frozen frames. Maybe it´s an idea to go after that from 25 to 50 or 60 ?!

    For macOS systems you will need to upgrade using the .pkg to enable the plugin component.

    1 Like

    I tried a few tests. Checking Replace Duplicate Frames on Apollo 8 did create 3 duplicate frames near the start of the clip. So like MMFMMMFMMMF, but then the rest were motion as expected.
    Running it without Replace checked, worked as expected with no frozen frames. (The first 3 were duplicates, but that’s another issue that’s been reported here before.)

    Every time I try to use the AE Topaz plugin, it crashes After Effects. I’ve done this on 2 different Intel iMacs with the same results. Anything I’m missing or should I just stick to the app for now?

    We would need to know more about what you are trying to upscale and what settings you are using.

    Will Topaz be available as a plugin for Final Cut Pro?