Topaz Video AI v4.0.2

Hello everyone,

A new release of Topaz Video AI is now available.

Released October 31st, 2023


Changelog from 4.0.1

  • Adds related preview ranges underneath preview group, including processing status and stats for each preview.
  • Adds looping of preview ranges by clicking the “Loop” button in the preview list.
  • Adds: jump directly to a preview in the timeline by clicking on it in the list.
  • Adds: mouse scroll wheel zooms timeline when hovered.
  • Adds: choose under “preview” button if you would like to process both views or just current (default current).
  • Fix: only show message about Nyx scaling when using old nyx-1 model.
  • Fix: do not reprocess previews starting at the same starting timeframe as an existing preview.
  • Fix: looping on in-out range.
  • Fix: “Auto”, “Relative” or “Manual” showing in preview info for enhancement models that don’t use this feature.
  • Fixes: various minor UI issues.

Known Issues

  • Overlapping preview ranges may have strange playback effects. This will be addressed in the next few releases.
  • Inconsistent “Preview X frames” range selection (example: selecting 10 frame preview may generate 9 frames)
  • Preview frames syncing may be off by roughly 1/2 a frame.
  • Rotation w/ previews will not be rotated.
  • Some users may see a slight “stutter” during playback of rendered previews. This is file-dependent and does not affect output videos.
  • Cropped videos will show the full input dimensions during Preview, but the applied Crop setting will be applied to Exports.
  • Currently not all the models are supported on Intel ARC (model support will be added week to week).
  • Videos with mismatched metadata and streams will display incorrect duration.
  • Using Telecine mode can cause a mismatch in playback over time. This will be addressed in a future release.
  • B&W toggle is causing a color shift in image sequence output.

I have not tested yet this version will try to see if less bugs than previous releases in 4.X version


Unfortunately I can’t install this version nor the previous version (4.0.1) because I get an error message to the effect that my CPU doesn’t support AVX2 instructions!

My present system can’t be upgraded to a CPU with AVX2 support.

So it appears that if I want to run Topaz Video AI V4.0.1 and later, I’ll have to build a new computer!

This is not good!


Hello, it’s been a long time since I posted my opinion. With my work and the rest I actually don’t have much time. So, having tried this version and the one before, that’s all really amazing. I don’t know if it’s me who feels this since the release of version 4, but I have the impression that it is a total regression there😯 What’s going on? In addition, version 3 was not yet finished, there was still so much to refine and settle with version 3. Why did you immediately launch version 4? Besides, I saw the number of opinions on version 4.0.1 it’s disastrous, full of negative things. Lots of bigs, and I totally agree, it’s stuffed with bugs like this version 4.0.2 . I don’t know what’s going on in your business right now, but a lot of things right now aren’t going. For example, why did you suddenly stop the development of Gigapixel So many don’t really like Topaz Photo AI. Then why did you stop Topaz video AI 3 when there were so many things to do above. in any case me personally I stay on 3.5.4


Please back the support of CPUs without AVX2 !!!


What’s going on there? I am so very disappointed. I would like a version that finally runs completely on my Apple M1 MacBook Pro. Some of the V3 versions even partially worked. But in contrast to the Windows version, only partially. V4 doesn’t run at all and I can no longer get reinstalled earlier V3 versions to work. What a waste of money!

There´s a lot of other software out there that´s running on Systems without AVX2.
It´s because there are devs out there knowing it´s not a good idea to offend someone.


I’ve just gone off the end of my support period - I can run 4.0.2 under my licence, but I don’t have AVX2 so no point and 3.5.4 is it, plus I suspect if they fix a lot of the bugs and/or remove the AVX2 limitation (has anyone tried the software implementation BTW?) we’ll be on 4.1.x or whatever and I won’t be able to run it. (It is a little annoying my support period made it to v4 but I don’t get to use it, for the bugs even if I had AVX2.)

As my whole licence period was for v3 and it really didn’t quite get there over time, still being a bit beta at the end, I can’t see my buying any more upgrades if after another year I don’t at least get a solid version of the product I bought. I will say I’ve got some decent use out of it, so don’t regret the purchase, but sometimes it’s been so hard using it with assorted issues coming and going…

Sorry, but one not-that-well QA’d release a week turned out not to really work for me. Having a stable version, a bunch of weekly alphas or betas (depending on the risks) and then another stable version would seem more of a plan. If you could have multiple versions installed I could maybe live with the current scheme as you have an instant option for any new issues - BTW can you have both v3 and v4 installed? Failing that then how about not moving on until you have a really solid version (so start a v4 version and stop adding features with any risk element to v3 to make it a solid workhorse - still possible BTW, or would sales hate that?).

Also in the same vein I wasn’t happy that GPAI ended up (well, apparently, I still have upgrade support for photo) with a version with a standard model that has some serious issues (e.g. pixilated noise-like areas often appear), would it have been that hard to do a 6.3.4 with both the 6.3.3 standard model as “Standard (V2)” and the 6.2.0 one as “Standard (V1)” if GPAI development was stopped now?


I understand that in this version (4.x.x), we are changing the workflow. We have a comparative preview. I understand how it should work. But I don’t know how my “fellow sufferers” are doing it. In my case, I would like to be able to compare with the same model by just changing the parameters or maybe just one parameter. Unfortunately, this is still not achievable. I link “view 1” to a preset, then I link the same preset to “view 2,” change the parameters, and preview. Surprisingly… Although both versions are apparently processed, there is absolutely no difference between them. I must be doing something wrong. Probably, I should load the preset and then modify it and save it with a different name… But that is counterproductive…

PS: I’ve noticed that no one from the staff seems to respond to public posts anymore.

PPS: Honestly? I don’t even know if it’s necessary to continue “pointing out” various bugs or dissatisfactions. I actively read this forum, and psychologically speaking, I think the developers are already in depression (I’m not joking, nor being ironic or malicious).


They never reply because people just bitch and cry. You never update to the newest with software. You update to version 4.5.4 you will always have bugs

There are people here on forum who have legit criticism of false advertisement. It says beta tester on your profile. If you choose to be one that is one thing. If someone sells you beta product advertised as finished product, that is a different matter. Maybe you fail to see the difference, but people who “bitch and cry” as you put it, do not. Hence its not what you think it is.


What exactly doesn’t work? You can’t install it, it crashes when you start it, or it doesn’t give you good results? Some models or filters don’t function or all of them?
I have a MBP M1 with 32 GB RAM and just finished a movie of 43 minutes, converted to HD with Iris2 in 3 hours 44 minutes. The results are quite impressive in my book.

Known Issues still outweigh Fixes and a lot is still broken.

I am going to stay with 3.5.4 on both my PC and Mac until this becomes more stable and less Alpha or Beta.

1 Like

I have the identical configuration as you. The program starts, but neither preview nor export works. No model works at all.

Weird. I’m still under macOS Monterey, version 12.7. Could that be the difference?

But there is one Problem:
If I set a Zoom to the preview and pan the Picture a little bit, then the Loop-Preview always get reset with the next Loop, instead of remaining this Position :frowning:

Pointing out anything in this release thread is encouraged, but getting a response has always been a bonus. They have said they cannot respond to everything said here, but they do read it. The Bugs and issues section is loaded right now. I think they’ve got their hands overfull.
And that’s not taking into account that messaging support directly probably takes precedence—and probably has more traffic than before too.


I’m tired of reading this nonsense!!))
I tested 4.0.2 today. Preview - it works!
Export works.
8% faster than version 4.0.1.
80% faster than version 3.5.0.
Developers, you are great and moving in the right direction.
In version 3.5.3, I immediately made a 16K video from the FHD video for testing and after approximately 10 days, I will post a link to an excerpt of this video so that everyone can download and watch the 16K video.
I have a MacBook Pro 16“ M1, 512 SSD. macOS Sonoma 14.


Well then there was something wrong with your setup before.

The speed hasn’t really changed in the last several releases 3.5.x -4.x on MacOS other than Iris having become slow as a dead snail.
Hell, even a GTX 4600 now is much faster than a M2Ultra.

This is a screenshot for the 16K video. I’ll post the video later. I don’t have time for this now. Health and good luck to everyone!!)) TOPAZ is an amazing and amazing software!