Topaz Video AI v3.3.9

Hello everyone,

A new release of Topaz Video AI is now available.

Released August 1st, 2023


Changes from v3.3.8:

  • Reworked custom output resolution workflow to better support presets
  • Added tooltips for video output settings panel
  • Fixed preset migration for video output settings
  • Fixing Theia to Interlaced Enhancement UI bug
  • Fixing Proteus and other sliders text box bug
  • Added tooltip for automatic pillarbox/letterbox removal in crop tool
  • Fixed textbox focus for output resolution
  • Fixed Interlaced Iris naming
  • Fixed integer overflow issue for start frame number
  • Changing toggle box to checkbox in UI
  • Added version labels for Proteus and Theia
  • Exports / Previews now show filename when hovering over thumbnail
  • Fixed video setting handling of SAR values for custom resolution
  • Fixed “proteus” showing up in FFmpeg command and added additional preset migration safeguard
  • Updated the live preview checkbox in preferences

Known Issues:

  • Videos with mismatched metadata and streams will display incorrect duration
  • Frame number preview length may shorten on app restart
  • Seeking/preview may not work well with DPX inputs

Please upload problem videos and logs here: Submit Files .


The Benchmark obviously does not reflect a real world workload. When I acutally run a real processing either with a 100 % GPU power limit and with a 33 % GPU power limit via the MSI Afterburner the processing speed shown remains the same, but when I run the Benchmark the results are very different, in this case 17 fps for Artemis 2 x on 100 % GPU power limit and 13 fps for Artemis 2 x on 33 % GPU power limit. :eyes:

1 Like

Is it possible the benchmark process bypasses Afterburner settings and goes straight to the heart of the GPU? To get the best performance numbers.

Small gripe but this has been happening for4 a long time. Can you make it so that when I update the software I don’t have to pin it to the start menu every time?

With my Ryzen 7 5800x system and whatever GPU (3060 ti and 4080 specifically) my real world upscaling with Artemis is maybe 30% or so slower than indicated by the benchmarks, with everything else turned off including detail recovery, and audio set to none. Prores. Well that’s a lot, and I am sure there is a logical reason for it - but it doesn’t help to maintain confidence in the software claims and makes GPU/CPU combination comparisons very very difficult (you should see my spreadsheet!).

Assuming that others see this too, it seems to me that the benchmark program needs to be re-done to better reflect real world conditions. That’s for upscaling - but also, comparing slomo and e.g. Apollo with Chronos, that’s just as difficult for 2x slomo because the benchmarks only do 4x - which flatters the Apollos. Chronos is just as fast as Apollo for me at 2x, and much the same as Chronos Fast.

Is the benchmark issue on the list, Topaz?

1 Like

3.3.9 update killed the app for me. I need to edit- how do I use it since the latest update broke it?

v.3.3.9 - a lot of useful fixes - is it worth updating to it or staying on the old version?

still using v.3.3.5 - this version is more stable
because versions 3.3.6 -3.3.7 -3.3.8 were terrible - with many different problems due to “Preview”


I actually stayed on 3.3.0 after few failed experiments with newer versions. Will wait for good news at some point in the future.


I am unable to work with v. 3.3.9 because of the continous ongoing stuck preview. This issue is present for months now and happens to any single video I try to process. I can not work with Video AI in its current state. I know I often say please be patient. I have no idea why it can’t get fixed and why there are even releases with this issue included. :pensive:


The export preview issue isn’t specific to v3.3.9 so your post is somewhat misleading. I do agree though, that the export preview needs to be fixed.

FYI if you try and export using ProRes you will notice the export preview is a lot better, for whatever reason…

in version 3.3.5 I was able to turn off Preview and set it to ignore Preview and Trim
and starting from version 3.3.6 everything is bad - so try version 3.3.5 and set to ignore Preview

Missleading? Do you want me to write down any single version number where the preview got stuck continously for me? Does it make any sense to refer to older versions at all?

1 Like

My point is that you referenced 3.3.9 specifically, when the problem has been present for all v3 releases since it’s inception. Which makes anyone reading your post think, oh, there’s a new problem in 3.3.9? So yes, misleading.

Okay, just for the completion please mention any single version in detail where it happened before just for the case that nobody might think this is a new issue. Thanks. :smiley:

1 Like

It’s never worked properly. As you know, I’ve already posted about it here, and I’m sure the devs are aware. When it gets fixed, or even can be fixed, is anyone’s guess.

1 Like

Preview works fine when I load the video from my samba NAS and play the preview directly on my LG TV.

There are so many SSD sluishness problems caused by MS Dollar ever lasting patches

Versions from 3.3.6 to 3.3.8 introduced a bug that I could not live with, namely the estimate function in Proteus manual mode did not work. This version seems to have fixed it, thank you.

I also tried the 3 functions for presets, create, delete and update and they work well. I did run into a little inconvenience: I want to create a preset for upscaling to 4k at a fixed 8k bit rate so I select the built-in “Upscale to 4K” then I changed the encoder bit rate from “Auto” to “8k”. Now to create a custom preset, I have to change the preset to “None” first before I can create a new one. I wish that create function (+ icon) is added to all the built-in presets in the future.

1 Like

I thought the preview worked perfectly, but when I trim the clip, the preview doesn’t work.

If you are working with 720p input resolutions and up, and exporting to anything other than ProRes, you will quickly see that export preview is broken.

I’m talking about the in-app export preview, so I’m not sure how you’re running Video AI application on your TV…