Topaz Video AI v3.3.6 - v3.3.8

Hello everyone,

A new release of Topaz Video AI is now available.

Released July 26th, 2023


Changes from v3.3.7:

  • Fixed image sequence previews overwriting or deleting previously completed exports

Released July 26th, 2023


Changes from 3.3.6:

  • Iris Interlaced now has Recover Original Detail slider


Changelog from 3.3.5:

  • Reworked Preset creation, modification, delete, and apply user workflows.
  • Reworked custom output resolution flow.
  • Removed (Modified) text from presets.
  • Fixed video scan type changing bug when switching presets.
  • Fixed Preview switching Iris.
  • Fixed auto crop stabilization preset issue.
  • Fixed Proteus defaulting to V1 instead of V3 in some cases.
  • Output FPS combo box does not duplicate the selection.
  • Enhancement filter will now stay enabled for custom output resolution.

Known Issues:

  • Videos with mismatched metadata and streams will display incorrect duration
  • Frame number preview length may shorten on app restart

Please upload problem videos and logs here: Submit Files .


All year, Topaz Video AI updates (I’m running Win 11, Intel(R) Core™ i5-4570 CPU @ 3.20GHz 3.20 GHz, 32GB RAM, 101GB free disk space) mostly fails (over 90% of the time) to launch, but repeated attempts eventually succeeded. I haven’t been able to get v 3.3.6 to launch at all, even after >50 attempts. Restarting computer, Run as Administrator, Control Panel → Repair. Registry-fix tools, etc. do not help. Complete uninstall/reinstall has not worked either.

To be honest it sounds like a problem with your setup.
Not sure what you’re expecting from VEAI on a 10 year old 4 core cpu with no gpu.
Post some logs for any help.


Release after release each week and still no sign of improving the performance or even better addressing the M1/M2 SOC’s from Apple.
Do we, Mac users, all have to buy a Mac Ultra M2 to have a bit of performance like on the pc with their Nvidia RTX cards?
WHEN after so many years is Topaz is going to address this?


Ditch the macs and switch to a real PC! (just kidding) :rofl:


I have an NVIDIA RTX 4090, an Intel I9-13900K, a Samsung 990 Pro SSD and 64GB of GDDR5 6400 SDRAM…

I have absolutely no problem upscaling and deinterlacing my old Madonna Concert 480i DVD’s to
8K 60p H265 10bit (Main 10) mp4 videos with Motion Deblur!

Smooth as a whistle and the results are gorgeous!

Blowing my mind :boom: that this is even possible what I am finally acheiving.

Thanks Topaz! :heart_on_fire:


Using Iris on 29.97fps vids; until now could select 29.97fps as output. But in 3.3.6 cannot select 29.97fps output: default is naturally & correctly 59.94 and can select any frame interpolation EXCEPT back to original 29.97fps. Is this intentional & if so why? Also the Recover Original Detail slider has disappeared from Enhancement

Thanks for your views on this, but that was not my point…
The point is that these Apple SOC’s are not used at their max capabilities in comparison with your 4090 Pc config.
So my question remains: When are these SOC’s going to be sued fully on this product?
What’s the point of supporting these SOC’s in this product if they perform slower than the other platform…

I have no idea what you are talking about or what a Soc is,
but I do truly hope you receive an answer soon and find a resolution.
Good luck!

I understand what you mean… but are you sure that TVAI doesn’t take advantage of the M1/M2 SOC properly? have you checked the actual CPU and GPU usage with any program? or do you only deduce it from the encoding speed?
If the components are exploited properly but the speed is not as high as you think, then you are overestimating your Mac components!


The answer as so often lies somewhere in the middle.
I believe a RTX4090 does have more processing power specifically for this task than the AppleSilicon chips - but still there are signs that Topaz is not fully optimised for the latter e.g. that if you force the software to use GPU instead of Neural Engine by setting RAM to 10% you can get sometimes much higher performance or that running more than one instance simultaneously also yields higher performance. Also, seeing the GPU vs. Neural Engine issue I don’t understand why not use Both? And so on


3.3.6. works flawlessly and quickly.
Also preview bug is fixed.
The new preset editing is well implemented.
Very nice - Thanks :+1:


I can also confirm preview at any frame besides the first frame functionality is restored on all AI models. Good job!


No Slider? I would not want to install this v3.3.6 if this is the case! DEVS - Pease answer! Also when I use IRIS Deinterlace on previous versions it always doubled the frame rate as expected fro. 25i to 50p and I would use APOLLO FAST to knock it back down to 25p and also have THEMIS on as well.

1 Like

Seeing the same here.
Selecting the original frame rate in the dropdown is simply ignored and the deinterlacing will be performed at 2x the original rate anyway.

The drop down will revert to the 2x value automatically.

Just tried v 3.3.6 . There is problem ! When you load image sequence and set output settings “image sequence” and some image format like .jpeg , png or tif - after the jobe is “done” the output folder is EMPTY ! FIX this ASAP please !

I am unable to create new presets unless I start from a completely blank slate. This is unacceptable. I should be able to load a preset, tweak it, and re-save it as something else, however the “Create new preset” option is greyed out and this message appears by default I don’t want to overwrite existing presets!!!

1 Like

SOC = All in one processor. it’s a normal Cpu with all in it, Gpu, Wifi, etc … it’s usually used on small machines, (tablet, smartphone etc). the apple one is a all in one processor.


Also Win 11 does not support your hardware.

Hi Albert, in today’s version 3.3.6 the audio is absent.
deinterlacing AVI 4.2.2 10bits to D.P.X. of the same characteristics the sound does not appear.
In the first versions I made this conversion and at the end of the file you had the complete original audio version.
Thank you if you can review the problem raised…

logsForSupport.tar.gz (657.5 KB)