Topaz Video AI v3.1.1

very funny… in french we have a line to tell to someone doing that “t’es lourd !” …

This would be a great addition at some point.


Hi Ole - can you please confirm if you’re on v3.1.1? If you can also send a screenshot of the results when Add Noise is set to 10 vs when it’s set to 0, it’d be very much appreciated. Thank you.

Sent it. File name: Winnie 1.mkv
Video is 12.5 fps (25/2). Because original source contains dups every second frame (old animation). So dups dropped.
Same problem on other sources (even in 3d animation) where movement is large from one frame to another. Interpolated frame contains ghosted/blurred part where large movement happens. But should contain object intact.
As you can see on RIFE example its better. Not blurred. But still bear is not very same.
Maybe for animation a special model needs to be trained.
Maybe its not possible to make it for all animations and model needs to be trained on each animation.

Add noise slider has been recalibrated to be similar to the pre noise added in 2.6.4, so do not expect it to give similar output to 3.0.x
The idea is to get better results from the model. So ideally no matter how much noise is added the result from the model should not contain any, if noise in the output is needed use the grain setting.
The maximum range for noise is

Noise at max(before model processing)


Did I understand correctly, in most cases I will not see changes in the final video, no matter how I move the slider ADD NOISE?

I also don’t seem to see any changes by moving the sliders for Relative to Auto.
Wonderful changes to the program!

I can only hope that I will at least see the changes by selecting a larger video size.

Are the new appolo models being worked on, appolo sharpen and soft? I dont see them

Unusable for me: doing 2K->4K Proteus. Hit Export and get:

Last FFmpeg messages:

Could not find codec parameters for stream 5 (Subtitle: hdmv_pgs_subtitle (pgssub)): unspecified size
Could not find codec parameters for stream 6 (Subtitle: hdmv_pgs_subtitle (pgssub)): unspecified size
Could not find codec parameters for stream 7 (Subtitle: hdmv_pgs_subtitle (pgssub)): unspecified size
Could not find codec parameters for stream 8 (Subtitle: hdmv_pgs_subtitle (pgssub)): unspecified size
Input #0, matroska,webm, from ‘D:/VideoMkv/Videos/S_t01.mkv’:
Decoder (codec hdmv_text_subtitle) not found for input stream #0:9

does removing all this from your mkv fix the issue ?

Removing all what? Oh, the subtitles! Yes, video is processing. Thanks.
(It should be able to handle copying those, IMHO.)

I don’t want to come off as a grump, but it seems that every update is a bit “two steps forward, one step back.” While I do appreciate the decrease in processing time almost by half, in the custom preset that I’ve been using for upscaling DS9, 3.1 has introduced a kind of glittering halftone effect to the processed video that I’ve only seen in small (but acceptable) quantities in 3.0.

I’m using Dione’s TV deinterlacer from a ripped DVD source. There is also noticeably more grain left in the picture that was in 3.0. Dione seems to be a mixed bag when it comes to deinterlacing. Sometimes it’s working miracles, other times it’s a grainy mess. But yes, it seems that 3.1 has done something to the Dione TV model that’s introducing this glittery halftone pattern in nearly every scene where there isn’t a lot of motion.

Examples of the halftone dots can be seen in the figure of the woman in image 1, and definitely in Odo’s hand and sleeve in image 2.

1 Like

I agree, but it seems that here , in regard of the message, it’s more an issue related to ffmpeg instead of VAi. it’s Pgs subtitle so, certainly a .m2ts from a bluray which has been converted directly in Mkv with all the streams. I didn’t tried to convert a MKV with internal pgs subtitle. a report of someone else who tried would be interesting and so we could make a request for the dev team in case it’s a common issue (like keeping all the audio tracks in the stream as well when there is more than one).!

1 Like

Getting out of memory failures again.
Logs are in the dropbox.

If the result looks plastic, use the add noise slider to make it more natural. There are some other scenarios where they are useful, but in most cases it is not required. All the enhancement models are designed to remove noise.

Relative to auto seems to be working as expected in all our tests. If you are seeing differences between 3.0.x and 3.1.x please provide full details with expected and actual outputs.

1 Like

BUG (minor, but annoying):
Making a new preset doesn’t remember noise and grain setting.

Well, actually adding noise of any value is very visible on the model output… even without adding any grain.
Version 3.1.1 on Mac.

There seems to be some confusion about “add noise” not appearing in the final result. If you want to add noise to the final video use the “add grain” option. The “add noise” option is applied BEFORE processing and enables the application to remove strong compression artifacts better.


Upgraded from 3.1 to 3.1.1, and now Topaz is producing files where Premiere cannot recognize the video track. I import the .mov’s into Pemiere and it just gives me audio. How do I restore v3.1?

why you want to already uninstall the software ? you don’t want to know if it’s an information you missed or something you didn’t found in the software ?

so here it is : your issue is related to this (change log , 1st post of this thread)

" * Added different export options to avoid clean-up pass or creation of temp files"

you have now 4 differents way to export a video , it’s in the preference, “export video”.

some export are not working with some external player (why ? because each export has it’s up and down). certainly you’re like me, one export option fail to import in vegas pro , only the audio track.
so try the 3 other export options. one of them will work ;). (maybe even all the 3 others :slight_smile: )

P.S : special Thanks to MikeF for this !


Yes, they said it’s something they will look into to see if it’s possible. It should be possible. Maybe not soon, but eventually. I hope they can add it because it’s very important for faces to look clear. Once this becomes good enough I’d love to test it on some old command and conquer fmv videos.