Topaz Video AI v3.1.0

The servers simply download the latest rendering instructions. They all live in a common folder. The application, TVAI, checks for the latest ones. If the server has nothing new to download, the application just uses the ones from the folder. If it’s new, it gets downloaded.

Formerly, there was a control to turn this behavior on and off in preferences.

Motion Deblur themis kills any details on all models

I disagree. Every time I use the same model - it is always downloading it. Yet nothing has changed in my image quality. They remain identical.

I would use a different enhancement model, maybe Proteus or Gaia HQ.

same result with proteus ;-( if i enable motion debleur themis

Your reasoning is flawed. That’s not how it works thank gawd.

Currently, only 2x4x models are available, but I would like a 3x model.
During the transition to FHD, there were many 720p HalfHD due to hardware limitations.
Considering upscaling to 4K (2160p), I think that 3x from 720p is more efficient than 3x from 4x with a reduction.

1 Like

How do you get those speeds? I use Mac M1 Pro and and set my processing to that (as opposed to CPU) but wonder what I have to do to get the speeds you have. Mine are usually between 6 and 7 fps.

The new 3.1 version still loads my RTX 3060 GPU just between 20-40% !? I dont believe this is a good resources utilization . My OS is Win10_64.

Hi… I am trying the new 3.1.0 with some files, but I have problems with Proteus that are not present in version 3.0.11. It’s like dehalo is 100 and you can’t change it
These are the drive links with the two files for comparison

What happens if you use just Themis, without other enhancement added?

1 Like

Actually, the 2.x versions worked exactly the same way as version 3.x, for scaling.


It could be my setup. I use a 13900k cpu and a 4090 gpu. If I run a single process I could get anywhere between 33-35 FPS. If I run two instances at the same time (ex: upscaling two episodes at the same time) I’m getting a good 25-26 FPS each. I have the memory at 90%. It used to take a about an 2:15 hours to upscale a 24 min episode from 480p to 1080p. Now I can convert the FPS and upscale it same resolution and it takes me about 40 minutes tops if I process two at the same time. Less if I’m only upscaling one.

1 Like

@yazi.saradest @gregory.maddra
Perhaps we need a clarification of the current policy; especially what TVAI’s (official) download cache behavior is after an active user license times out.

1 Like

They have not clarified anything.

3x would be perfect for 720p sources! Bring it!


no it did not. 2.x scaled up as close as possible and the missing scaling was done the classic way. 3.x scales up further and then downscales the image to the need.

Hey all,

I don’t understand why, but I can’t run topaz video enhance, I always have errors… I have an rtx 3080 and the latest driver 528.02. I also have windows 11 updated.
Every time I launch an upscale with proteus or artemis I get an error and/or a computer crash…

Do you also have these problems with the rtx3080?


I don’t mean to disagree, but I do disagree. :blush:

In between sizes are scaled using traditional Lanczos scaling. This is the same in VEAI 2.x and TVAI 3.x.

“In between sizes are scaled using traditional Lanczos scaling.”
right :slight_smile:

“This is the same in VEAI 2.x and TVAI 3.x.”
wrong. :roll_eyes: