Topaz Video AI v3.0.2

Trim is broken since latest bugfix it marks trim at the start point and then that’s it. Can’t see any of the video after start point, so pointless as you can’t set an end point. Have to reinstall 2.64 it was much better and had more control, I genuinely hate the new setup I find it so dumbed down it’s much worse than 2.64. Wish I did not choose to update to 3.0.

Completely agree with everything you said and will do the same.

Stabilization does not work normally! Squares, as before. Drivers of the latest version, at first they are not there, then after 2-3 minutes they appear, and then constantly.

Win 10, 32 Gig DDR4, RTX 3060Ti, R9 5900X, Latest Nvidia Game drivers

1 Like

When reading: FAQ for TVAI 3.0 Frequently Asked Questions for Topaz Video AI v3.0 - Topaz Labs
chapter “What is the difference between Video Enhance AI (VEAI) & Topaz Video AI (TVAI)?”
"… Most of the issues stemmed from the fact video was being treated as a series of constant-rate images. All the current models operate on this assumption and as a result, had issues processing videos with variable frame rates, repeated frames, scene changes, etc. This was hampering the development of new models and processes that require multiple passes, like stabilization, scene detection, etc. To address these concerns and allow the addition of new features, we decided to rewrite the code base.

This approach allows us to focus on our core expertise to create and improve our models to perform better on all user videos. …"

That explains essentially why the “old” 2.6 AI models need to be “retrained”. I still hope that this will be done timely.

1 Like

This is like some of the blurry screens I got when I tried Stabilization. I am also doing stabilization by itself. It worked great on a small 2 minute file, but not on the larger ~23 minute file I tried. I think it might also be important to list your system environments in case that might be related.

Win 10/64 Pro, 32 Gig DDR4, RTX 3080Ti, I7 12,700k, Latest Nvidia Game drivers

1 Like

Please excuse my rudeness as I do not speak English and this is my first time posting here. I have been using your software since the previous version, and I would like to write a few things that I would like you to fix.
I basically output videos with the following settings, but I have the following problems.
[Imgur: The magic of the Internet]
・When I output trimmed videos, the chapter information is not deleted, which causes problems during playback.
・When I playback enhanced videos on my PC, they do not play at maximum size even if I set them to full screen.
・Sound is out of sync (sound is about 0.3 seconds early).
The above two issues did not occur in the previous 2.x version.
Thank you in advance.

Is there any chance we can get Constant Rate Factor back as a GUI option?


I can confirm that the sound layer sometimes begins between 0,3 and 0,6 seconds to early. not only this. when trimming the video sometimes the first 0,3 - 0,6 sec of the trim start is a repeating of the end of the video layer before the trim so if you move the sound layer back later it overlaps with the sound layer of the region before the trim start. this leads me to the question if at the end of the video or trim are 0,3 - 0,6 sec of the sound layer is missing. :eyes:

2022 is the most unsuccessful year for topaz


This might have something to do with the fact that ffmpeg only wants to cut at key frames. I don’t know what that means professionally, but in my usage of ffmpeg as my only tool for cutting videos into parts, if I tell it to cut at 00:03:00.000, the sound will often have a length of like 00:03:00.300, but the frames cut right when I told it to.
If I join the two clips back, I need the extra blank frames or the sound becomes off by those .3 seconds.
Appending clips with MKVToolNix delays the playback of the second clip until the sound finishes playing, so the sound stays in sync. If I take all the frames from clip two and renumber them to become a continuation of clip one then convert them into a movie, the sound becomes off at the point where clip one ends.

Maybe this is something not accounted for in TVAI.

yes, I also noticed that sometimes the gui itself is not able to cut exactly often changing my input time to something slightly different.

I definitely agree. I used to use it a lot. previously. And I believe that they will reintroduce it eventually.

In the meantime, I suggest the nearest thing to lossless video currently on the menu. That is ProRes 422 HQ.

It is also a good idea to use if you plan to run the same video though process more than one time.


@gregory.maddra I can not find Main10 and 10bit encoding in H265 Main10 VEAI files.Using MediaInfo to Read.

Have you chosen the right setting?
That is what I see:

Hello! small problem, I produced a 6-minute video in 1h20 with the artemis medium model of version 3.0.2, in the end it failed me, I would have posted the end of my log, but the lines are long, if someone can tell me where it comes from! thank you :wink:

Sorry if it’s already been answered, but can someone explain why the models are so much worse than 2.64? I was getting really good results with that version, but my equipment (RTX3090) wasn’t being utilised properly so I was excited to swap over to the new version but the results now aren’t even usable anymore. The faces are absolutely horrible, like someone tried correcting them in Paint. I was holding off my upscaling projects for this version and now I can’t even get usable results. I’m just curious why they’re so different? Wouldn’t the models be the same as VEAI is just a GUI for the backend? Or has something else changed? And is there any time frame of when they’ll be fixed? I’ve noticed it’s been mentioned in the patch notes for quite some time, but I hadn’t seen any talk of a fix?


Does this version support tensor core calculations on 30 series graphics cards?

@yazi.saradest @gregory.maddra @ida.topazlabs

Main10 Info is striped.
@yazi.saradest Uploaded Source File:)

1 Like

I recall hearing that the audio being compressed would be fixed in 3.0. Has that been the case? Does it now allow for pass through of the same audio quality of the original file?

Just upgraded to v3.0.2, Win11 i7-6700K 4Ghz, 16GB RAM, Nvidia RTX3090.
Getting crashes when starting to render to MP4 - H264, Progressive, Proteus, Auto with MP4 settings on Auto, but render to MOV (PRORES422 LT) worked without crashing.
Previously using different container formats of input files rendering to MP4 - H264 output without crashing using Medium-Progressive-Proteus Fine Tune.

I really prefer rendering my files directly to MP4 and I hope a future version addresses this continual crashing, but I hadn’t noticed anyone specifically mentioning rendering to MP4 container issues. Please let me know if I’m incorrect. Thanks!