Topaz Video AI v3.0.2

Hello Everyone!

A new version of Topaz Video AI is now available.

v3.0.2
Released November 1, 2022

Download: Windows | Mac

NVIDIA users: Driver version 522.25 or higher is required
Changes from v3.0.1:

  • Fixes login issue with special characters.
  • Fixes UI not opening or crashing at launch.
  • Fixes Open Command Prompt on Mac.
  • Fixes next frame needed to be clicked twice.
  • Fixes Reveal in Finder / Show in Explorer.
  • Updated Preferences UI.
  • More meaningful error messages with possible solution.
  • Fixes issue with Deinterlace and FPS changes.
  • Misc. bug fixes and improvements.

Known Issues:

  • Quality mismatch between 2.6.4. and 3.0.x for some models.
  • Some users may experience reduced performance compared to 2.6.4
  • Preview experience needs to be improved

File Submission Dropbox: Submit Files

9 Likes

Just downloaded it and installed.

Cleans up nicely!

:grinning:

@gregory.maddra

I was wondering if we could get a more detailed reasoning why Nvidia driver 522.25 or higher is required? What would be the outcome of not using the latest compared to say driver 517.40? I’m not a huge fan of just changing drivers for a slight improvement. Gamers found this out last month when the latest driver with Geforce Experience installed caused many headaches after Microsoft updated Windows 11 to 22H2. People had to either uninstall Geforce Experience or downgrade the driver package completely.

5 Likes

Trimming doesn’t allow forwarding or rewinding frames easily. You’re stuck having to enter the frame number manually in the timecode or using the mouse to change the trimming boundaries. You can forward and rewind, but your current frame can not be selected as the in or out point of the trim.

5 Likes

Hi
The updates are impressive, given the short time span. However preview is still completely broken, Without a before and after the software is useless I’m afraid.

I hope fixing it is of top priority. I realize you have your hands full but it really is that important.

Thank you

Would appreciate some advice about an error message if anyone has a sec. I tried the 2.6 demo and liked it, but since it couldn’t be relied upon to work on my offline PC without requesting activation again I waited for version 3.

Now I’m trying version 3 (3.1 and 3.2) and it fails with an error message at least 75% of the time when I try to run a preview, saying “Error Message from AI Engine: Model Failed”. It also seems to take 4-5 mins to try and preview a 1 second clip.

I also don’t seem to be able to download all models which is, given the whole point was to put it on an offline PC, rather frustrating. Does anyone know if you can download all models with the 2.6 version then move the files over?

I don’t have time to try and grab any logs right now but is there something obvious going on with the AI Engine: Model Failed error? I’m on the latest drivers with a gtx 1060. It worked fine with 2.6.

1 Like

Can’t start the process with error “Error message from AI engine : model not found” .
This error occurs only in v3.xx on Mac. How can I solve this problem?

Thanks for the reply.

The ‘offline’ problem with 2.6.4 was that it was supposed to be able to work offline but was apparently unreliable in this regard, as confirmed by support staff, which was why I chose to wait for 3.

Regarding my ‘AI Engine: Model Failed’ error, the model does say it’s downloaded and the model folder does seem to have a in file there, so I assumed it was telling me it has downloaded but won’t run successfully for some reason.

I’ve also double-checked, and a preview that took a few seconds to generate on 2.6.4 takes 4-5 minutes in version 3.2 so something is clearly very not right.

I also feel like there are fewer options in 3 just generally, or perhaps I haven’t spent long enough with it? But going back to 2.6.4 straight afterwards, my gut reaction was that 3 doesn’t feel ‘ready’ yet. Hopefully more fixes and updates will be coming quickly.

Can anyone tell me: It offers to download models that are ‘optimised for your hardware’ when you use them. Is the ‘all models’ download for 2.6.4 every model optimised for your own hardware only, or literally every possibly variation? Sorry if I’m asking stupid questions but I’m only just starting with this.

These are basically the two main “deal breakers” for me. When these are fixed, I’ll probably change.

By the way, I’m an OpenVINO user, and I would love to see 3.x use optimized models like 2.6.4 did (256x352, 384x480, etc.).

3 Likes

The user you are replying to does not work for Topaz.

1 Like

I reverted back to 2.6.4. The quality of the Proteus model is far superior on 2.6.4. I did an A-B test with the same file, and there is no comparison.

Also, can you please add back the granular grain controls? Having a grain control that just says 2 is not very helpful. The ability to fine-tune it under 2.6.4 makes the quality of upscaling 480p files a lot better.

Lastly, as everyone else said, 3.0.2 is significantly slower than 2.6.4 (Using AMD 5950x and RTX 4090, 32GB of RAM, the previews are broken, and the user interface just drives me up the wall. The Previews, All Outputs, and Export below the main video are janky at best and broken most of the time, where I have to click back and forth between Previews and all outputs to see the other previews.

I will be sticking with 2.6.4 for a while until a lot of these issues are ironed out.

1 Like

Actually, I started it up did a few things that brought the previous VEAI 3 version to their knees and it stayed up. - It appears to be much more stable. (I have family coming and so not as much time in front of the monitors today…)

I did notice it was rendering rather slowly, but I wasn’t certain whether it was my settings or something else. - They say it’s the first hundred years that’s the hardest. :thinking:

1 Like

So multiple - bugs I reported in 3.0.1 are not listed in fixed, or known issues. Do I interpret that as not fixed, fixed but not included in the update notes or missed entirely from the feedback from 3.0.1?

Ultimately i will check again to see if they are fixed, but if you are having us give feedback and reporting problems, please have the courtesy of having them listed - either in Known issues or Fixes - that way the onus is not onto us to continue to bug check the same bugs on the new release just to even find out whether they are fixed or not, report again, and then have no idea if that post was even looked at.

I tried a preview of one my standard tests - old 360x480 video.Cropped to 16x9 and upscale to 1920x1080. Input not interlaced. I got a preview failed with “unknown error”. Since I saw DTS in the error text, I changed TVAI Audio Settings to Copy and the preview ran okay.
The audio in the input is
Advanced Audio Codec Low Complexity

Preview - ERROR Unknown error

Last FFmpeg messages:

Terminating muxer thread 0
Non-monotonous DTS in output stream 1:0; previous: 127488, current: 127488; changing to 127489. This may result in incorrect timestamps in the output file.
All streams finished for output file #1
Terminating muxer thread 1
Statistics: 162843725 bytes written, 2 seeks, 625 writeouts
Input file #0 (D:/DVD/dark shadows/Dark Shadows 0230.mp4):
Input stream #0:0 (audio): 2219 packets read (824376 bytes);
Input stream #0:1 (video): 1526 packets read (3774050 bytes); 1512 frames decoded;
Input stream #0:2 (data): 0 packets read (0 bytes);
Input stream #0:3 (data): 0 packets read (0 bytes);
Total: 3745 packets (4598426 bytes) demuxed
Output file #0 (C:/Users/john/AppData/Local/Temp/488275802/temp/_tvai_689285947/%06d.tiff):
Output stream #0:0 (video): 300 frames encoded; 300 packets muxed (3763513220 bytes);
Total: 300 packets (3763513220 bytes) muxed
Output file #1 (C:/Users/john/AppData/Local/Temp/488275802/previews/Dark Shadows 0230_436717466_prob3.mov):
Output stream #1:0 (video): 300 frames encoded; 300 packets muxed (162020412 bytes);
Output stream #1:1 (audio): 2170 packets muxed (806174 bytes);
Total: 2470 packets (162826586 bytes) muxed
1512 frames successfully decoded, 0 decoding errors
Uninit called for prob-3 0

that is all? I was hoping for significant improvements, but now processing the video is more confusing and takes twice as long!

1 Like

3.0.2 will be my last Video AI for a while as my subscription is about to expire this month. And I hate to say the performance is still abysmal. Incredibly slow. Around 0.6 to 0.7 fps for upscaling a video to HD.

Please Topaz, please just confirm you all are aware of the performance regression on M1/M2 Macbook and have been working on this issue. I’m not asking you to fix this anytime soon. Just please reassured you don’t neglect users like me and can solve this issue in the future.

I love this product and has been using Gigapixel AI since 2018-ish, but it’s sad this is how we end up.

3 Likes

While I like the new version 3 UI quite a lot, it’s super laggy on my 16 GB M1 Mac Mini, during a export or preview creation is running. Menu items or sliders in view may take up to 10…15 secs until they react - even under medium or low load of the system. Please decouple UI better from exports to keep it reactive at all times. In Version 2.6 UI was super fluid under any condition, also if split view was used in preview, the slider always was super smooth and reactive. Please try to bring that fluidity/smoothness back into UI.

BTW a Feature Request: It also would be a nice setting in the presets to give tasks (exports) a default priority. Sadly it can’t be changed on running exports, but other entries in the queue can be a priority set.

1 Like

Please stop spamming the forum with the same comments over and over again. You’ve made your point several times but once is enough. Any future recurrences will be removed.

2 Likes

Nothing negative to report, 3.0.2 with 3 videos in parallel 1280 → 1920 (progressive, medium quality/Halo → Artemis/Denoise, Sharpen; H.265; mp4) 0.38spf, CPU (3x ffmpeg ~15%), GPU 87-93% 10,7/12GB. Everything looks very balanced. Trim, Crop, Preview as usual ok.

Seriously, we no longer have the right to say what we think? in this case sorry, if it starts like that for me, as much as I say nothing more, if we can not say anything more. thank you for your message anyway. :wink: