Topaz Studio crashing

Studio continues to crash in the middle of my editing. Very frustrating not having a phone number to call someone!

4 Likes

Hi, can you supply a little more information please:

  • What were you doing when the crash occurred?
  • What type of image are you editing, type and dimensions?
  • Are you using Studio, I assume v2.0.11, as a standalone or plugin? If a plugin what is the host?

Please them start Studio, click on Help-> Graphics info., press Copy and paste the information here too please.

I have the same problem, it works until you try to put a look onto your image, it is not my computer, why am I so sure well, I completed one last night and I was pleased with, then I loaded the second into Photoshop apply the Topaz Filter TS 2 and AI Clear is fine, Dehaze is fine, but then when you click on the Apply Look button, gone crashes out, it is the same in the Stand alone TS 2, I am running a iMAC 2019, and it has been fine on v2.0.11 I have done at least 10 images with no ssues until last night.

1 Like

Please check your system against the System Requirements noted here:

Please also note that minimum requirements are so that the application will function but you should expect slow performance and large files may cause crashing.

I am an IT Consultant, I know the rules and I am not stupid, I have done 10 to 20 image processes not a problem, as I said I did one last night worked fine, then do another and crashes started,that is not a hardware issue that is software

3 Likes

I didn’t say you were stupid, I asked for information in order to help. Should you wish not to post that information raise a support request at the Topaz Labs website as this is a user to user forum.

See my post, the second in this thread.

I agree with you that an app should not crash and barf it’s guts no matter if the HW pre-reqs are met or not. That is the point you are correctly making. And no matter what the above requested HW report shows, that is not going to help diagnose the problem; so, essentially the request to you was a pointless deflection.

The only worthwhile action is to collect debug/trace logs and submit them to the dev team for analysis (support@topazlabs.com) I have done this numerous times, including recently…of course, I haven’t gotten any worthwhile responses other than “we haven’t figured it out, yet”; it looks like a resource issue", but that’s really the only recourse that you have. Again, the app should NOT puke if it runs out of resources; that is what is called correct SW programming…but, it happens.

Nobody here is equipped to analyze a Studio crash-dump. A user-user forum, otherwise know as the company’s free support staff, is ok for some issues, but not fatal crashes. You won’t get anywhere here despite this forum section being labeled “Product Technical Support”; unfortunately, no company support/dev staff is going to respond here to give you worthwhile guidance.

Here is where you turn on the app tracing; I could point you to the log folder on a Windows machine, but since you are on a Mac someone else would need to do that or you may be able to poke around and find it.

File_logging-on

The log dir should have files that look like this:

Studio_log_files

1 Like

What I have done is once un-installed and re-installed from my Topaz Account, unlike last night it has installed 2.0.10 and touch wood as they say it seem to be working again, just for record the file logging is in the same place on the Mac version so that is now on. I am hopeful that it going to continue working.

1 Like

THANK YOU! This is what’s happening me. As soon as I add a look, the program crashes and I loose all my work. This is a waste time and very frustrating!

1 Like

I have tried this and the program still crashes.

Thank you!

Application & Version: Topaz Studio 2 Version 2.0.11

Operating System: macOS Mojave (10.14)

Graphics Hardware: Intel Iris OpenGL Engine

OpenGL Driver: 4.1 INTEL-12.10.12

CPU RAM: 16384 MB

Video RAM: 1536 MB Total, 1536 MB In Use

Preview Limit: 3820 Pixels

When I un-installed and re-downloaded TS2 last night i got 2.0.11 again, tonight I used CLeanMyMac to uninstall TS2 completely, I then logged into my accout at Topaz, in my account found the products I purchased and re-downloaded TS2, the difference tonight was I got 2.0.10 version and that seems to be working for me, and I also went into System Preferences and in Security & Privacy and changed access to Disks for TS2, and that seems to have sorted my iussue at the moment.

That’s interesting that you got the previous version during your re-install… We haven’t been told about another rollback on the production release, I don’t think.

Unless something was pulled over a holiday weekend (hmmm, not likely) to fix the DeNoise launches Sharpen issue that all the Win users have reported.

JGR’s info to you above re: what to capture and where to send it is your best shot for tech spt vs. user surmises… ditto his opinions on coding.

I have not a clue whay I got the older version, but I have just ran 2 images through the process and it works, I am sticking with 2.0.10. hopefully will hear from Support Monday at some time
.

If it ain’t broke don’t fix it! Glad you can at least work with the prev. vers.!

I would raise a support request at the main website asking the limitations on the GPU memory as the 1.5GB you have is under the recommended minimum. But I believe Mac’s may have more tolerance.

!Thank you!

I found an interim fix to my crashes (always while scrolling through 'Looks"), and failed interfaces between Lightroom and TS2… Verion 2.0.10 is still the downloadable version on the Topaz Labs site. Sign n to your account, re-downlaod 2.0.10 and install – it will (when prompted) uninstall the more recent updated version that is causing the problems. Voila. Everything works. No crashes.

Same here! As soon as I go to add a look and make an adjustment, the program crashes and restarts the computer. I’ve sent several support tickets about this with all the information about my XPS 8930 desktop…it seems to be a software glitch.