Topaz Studio 2 version 2.0.12 is now available

Are you running Windows or Mac?

I was able to use LR CC with 2.0.12. I did however have to go to preferences, external editors, and on custom re-point it to the Topaz Studio 2.app After doing that when bring up the menu on my image, choosing “Edit in Topaz Studio 2…” works

The regular preset does not however. - I’ll look into this one.

1 Like

yes, own all of them and yes again, same folder same disk. This problem never happened in Studio 2 version 2.0.10. The problem started with version 2.0.11 and continues in version 2.0.12. Incidentally, if I’m in PS I can go to filters, studio 2 and all 3 plugins are available. The problem is only with LR and that is where my normal workflow begins.

1 Like

The plugins are greyed out for me when I go from LR or ON1 to Studio. They’re fine if I go from Photoshop or Affinity Photo or use as a standalone. Windows 10.

1 Like

I downloaded the TS 2.0.12 (commercial rel.) installer from the Topaz Downloads page online using the link provided at the top of this thread.

All host programs on my Win PC were closed when I double-clicked that Win installer.

See attached for message that came up!

It is asking me (telling me) it’s going to uninstall a “beta” before installing the production rel. 2.0.12 of Topaz Studio 2. I don’t currently have a Topaz Studio beta release (of any vers.) on my PC.

Why would I be getting this message? I am running 2.0.11PR of TS… Only beta I have now is GAI…

I aborted the install b/c I didn’t know what would disappear that I didn’t want to disappear.

TS Win Installer - Msg @ Start of Install Process for v. 2.0.12PR (installer from Topaz website Downloads pg):

On my Mac it took two attempts to install, this was a problem with an earlier version which appears to have been reintroduced.

I opened TS2 via ON1.

I tried AI Adjust and it worked OK. But I would question why plugins are grouped under the Filter menu when a plugin is not really a filter, better to have a dropdown just for plugins.

Back in TS2, the applied AI Adjust showed accurately in the preview pane but it did not show at all in the Looks thumbnail where the original image prior to adding AI Adjust was still being used, which meant I was unable to see what a Look would look like unless it was applied.

Image returned to ON1 OK.

That’s a great point. Would be more intuitive to find plugins that way via a “Plugins” menu!

AMEN!!!

Updated to 2.0.12 , the plugins are working as they should, but the crop tool seem to cause distortion, weather I’m using the aspect ratio or free hand cropping. I also tried the height and width but I still get distortion. I’m using Windows 10

Following the comment by Russell about recreating LR external editor preset I have done this and can now Edit In from LR again, as well as sending from On1 & Bridge.

Plugins there and seem to work after a quick test.

So with some work it is two steps forward.

The one step back is that the bug where just adding a Precision Contrast filter causes image to go fuzzy has returned having seemed to have been fixed in 2.0.11. Topaz can’t reproduce this on 2.0.12 so back to accumulating and sending evidence.

On iMac running 10.14.6, latest supplemental build.

No plugins were available from Studio until 2.0.11. Are they available when you use Studio 2 v2.0.12 as a standalone?

Note that I can confirm that the Plugins (3) are not available from within Studio v2.0.12 when called from LR on Windows, or indeed ON1 Photo RAW or Capture One. I have asked Development for confirmation of this.

Just follow the install through, that is a issue with the message only on the installer and has been reported a while ago. You can also update from the Help-> Check for updates menu.

I get the same, but it works fine.

image

1 Like

In a private conversation with Russell he recommended the following:
“I was able to get it to work by going to preferences and manually re-configuring my external editor to point at the Topaz Studio 2.app file. And then choosing “Edit in Topaz Studio 2…” instead of clicking on the Topaz Studio 2 preset.”
I have done this and it works seamlessly. Here is a screen shot of my preferences.


Please let me know how it works for you.

i am using a Mac. No, LR was NOT shut down (oops).No, I didn’t run studio as a standalone before restarting studio 2.

Try exiting from LR & PS, run studio as a standalone and then it should be OK. If you can’t call via the preset then just above your post there is a post from Stephen where Russell got it working for him.

I updated from the earlier version and everything went fine. All the items which are shown as changed are working as described. I’m unable to test anything on a Mac, but the others all went just fine.

Topaz Studio 2.012 crashed with latest mac update. Sent Support Request.

Russel’s method worked for me! thanks. will get to test it out now

1 Like

oops…i have successfully opened and can run TS2 from LRCC, but in the middle of processing, i get an unexpected error. not sure if it will help, but here’s the report that was generated (this happened 3 times)…

TS2 Crash Report (RS).txt (18.3 KB)

Please raise a support request at the main website and attach the Report which I have copied into a text file. Just download to your computer and attach it to the support request.