Topaz Studio 2 version 2.0.12 is now available

Topaz Studio 2 version 2.0.12 update is now available. Here’s the change log:

  • Fixed Mac stability issue
  • Fixed aspect ratio of mask on filters
  • Fixed collapsed tabs resetting when switching between menus
  • Fixed look panel overlapping crop panel
  • Fixed color theme style
  • Updated style across the app
  • Added plugin support for AI products
  • Added inches, centimeters, and millimeters options to both resize and crop
  • Added lock functionality to cropping
  • Changed “Stain Glass” look to “Stained Glass”

Downloads can be found here, just in case you don’t get notified:
https://topazlabs.com/downloads/#studio

5 Likes

i updated to ts2. when i try to access it from LR CC (using Photo/Edit in) the JPG gets created but TS2 never gets loaded.
i exited LRCC after updating TS2.
if i launch TS2 as a standalone, it works but then i need to import the photo into LR…adds an extra step.
i’m on an IMAC
thanks for any help to fix this

I too am still unable to invoke Studio 2 fron LR on Mac with this version. Running a Mac Pro 64GB RAM OSX 10.14.6 “Edit in” creates the TIFF file but it does not call up TS2. TS2 seems to run quite well as a standalone but that does nothing for my workflow. I and the other Mac users would greatly appreciate your devoting some time and resources to fixing this problem.

2 Likes

I note that the release notes do not mention any resolution of the issues with LR integration, and this is still not working for me.

However, sending a file from On1 or Bridge now does open the file in Studio 2, which it did not in 2.0.11 and involving Studio 2 as a Photoshop filter also loads the image file.

So there has been some progress in taking things back to how they were in 2.0.10.

LR Integration does work on Windows but would need to be manually updated if the Program files are on any drive other than the C:\ drive.

I can help with a External Editor Preset for Windows but not for Mac

i have the same exact problem…how do you import into LRCC after running TS2 as a standalone? i’m wondering if there’s an easy way to do this. thanks

If you create the file when you call an external editor from LR it will create it in the folder of the original image.

If you then open that image to edit in TS2 and Export to the folder where the file from LR was created after you edit it, you can then synchronize the folder and LR will import the Studio export.

Updated without issue. Opened as standalone, exported as jpg. When opening in PS, Pixel ratio is still off:

Win 10

Am not interested in workarounds to use Studio 2.0.12. If I can’t edit from LR to Studio as I did in 2.0.10 I’m not interested. Topaz needs to spend more time in making sure their updates are working properly.

6 Likes

No one has said anything about workarounds …

Why can’t you edit in LR, I don’t have an issue? Can you give your OS and confirm that when you updated to 2.0.12 you ran Studio 2 first as a standalone.

I will NOT download ANY upgrades from 2.0.10 until I am assured that the LR interface issue is fixed. It is absolutely necessary to me for efficient workflow please FIX this issue!!

1 Like

Thank you, Topaz, for getting 2.0.12 out for us!
And, accessing it from Photoshop, is working, for me, on my MacBook Pro

PC Win 10 Stand Alone.

TS 2.0.12 Works like a charm.

_DSC8807-tiff%20(600%20x%20398)

After updating to TS2.0.11 I was unable to access TS 2 from LRCC Classic. I was However able to make the transfer through Photoshop (LR>PS>TS2) and return to LR via the same route. While this cludge does work it is very inconvenient to say the least. I filed a Help Request with Tech support, but no answer yet. This whole software development process is very frustrating for the user. We pay for a well tested healthy product not a half-hearted effort that leaves the user/customer in the role of beta tester. I’ve been a happy Topaz customer for at least 6 years and this new “face” on product development is astonishingly inept. Please fix it! I will pass on the “opportunity” to download/install TS 2.0.12.

3 Likes

System is win 10 64 bit. From LR I select photo, right click and select “edit in Studio 2”. Next I select “edit copy with LR adjustments”. Studio 2 opens and I select “filters” then “plugins” and they are greyed out and not available.

thanks AiDon, but that’s quite a few extra steps. It wouldn’t be so bad to have to do it, but it would definitely make me use other options (TS1?) to avoid the workflow interruption. Most other Topaz products will return to LRCC, putting the photo in the catalogue…will this be changed in the future to allow a smoother integration? thanks

We are looking into this. We’ll get it solved as soon as possible.

1 Like

Do you own Adjust AI, DeNoise AI and Sharpen AI and are they installed in the same Program folder on the same Disk? That would be in sub-folders in the Topaz Labs Folder.

Are you using Windows or Mac? And when you updated was LR shut down, and did you run Studio as a standalone before restarting Studio 2?