Topaz Photo AI v2.3.1


This week we have several fixes and polis changes relating to camera profiles, including new support for custom DCPs!

As always, a full change log is below.

Please give us any feedback or report issues with this release. We’ll be updating TPAI regularly to address those pieces of feedback and issue reports. If there’s a specific image you’d like us to see, you can send it us at this dropbox link.

Released February 1st, 2024
Mac: Download
Windows: Download

Changes since 2.3.0

  • Add translation for Hasselbled H5D-40
  • Add Olympus TG-7 camera profile
  • Fix Sony translation issue for DSLR-A900
  • Fix Panasonic G95D translation
  • Update HUE and LUT info for camera profiles
  • Support custom DCP camera profiles
  • Fix scale text field being invalid at max value
  • Do not use Adobe DNG render cache when exporting
  • Fixed crash on Mac when remove object fails
  • Fixed app not launching for some users
  • Fix LrC instance merging not working on new LrC versions
  • Automatic Lensfun Update

**Very disappointed with the remove tool. It is more complicated that it needs to. Also I am getting unacceptable results. For me this tool it is not usable as of version 2.3.1.
**Windows 10 16GB NVIDIA GeForce RTX2060.
I was getting acceptable results before I implemented versuin 2.3.1

1 Like


I don’t recall Svetlina or Harald mentioning using the plugin, Ps or File > Automate … per your comment in the closed thread for 2.3.0. Guess they’d have to say.

I didn’t say there was, I stated " I don’t have any issues so there may be other factors such as using as a plugin via automate from PS etc."

  Face Recovery seems to be broken in 2.3.1.

  Every image with a face in it, that I tried to process, the AutoPilot gets stuck on “Detecting Faces”.  never getting past that point.

  The attached image is one that I have verified works just fine in 2.3.0, but gets stuck at the “Detecting Faces”. stage in 2.3.1.

  I’ve reverted back to 2.3.0, which works just fine on faces.


Yes, I tested it in stand-alone mode. Not in plugin mode. But I imagine it will be the same problem as “@Fotomaker” mentioned using the plugin version via Photoshop.

1 Like

Humm, I think I’ll wait another 2 weeks for the bugs to be fixed. Especially since, according to the changelog, they haven’t fixed the deletion tool bug for Windows, only MacOS.


Sorry for keeping an old closed thread alive by continuosly referring to it, but the rug got kind of pulled there from under us while in the middle of an ongoing thing…

I was gonna ask people what GPU they’re having problems with, because it seems to me (just a highly speculative observation) that I don’t see many people mentioning problems with AMD cards, while on the other hand I read a lot of mentions of Nvidia. Then you posted and said everything is fine for you with Nvidia. :innocent:

Anyway - to not make this post longer:

Win 10 - AMD Radeon RX 6700 - Running PAI 2.3.0 as standalone. No problems at all using remove before activating upscale. Tried both with .CR3 and .jpg. (Before anyone comments on version - I’ll try the same in 2.3.1 in a bit)

Edit: Same in 2.3.1 - no problem at all.

1 Like

I’m a W10 user, 2 bugs was fixed :1. Crop with face recovery; 2. Remove Tool crash
at the end of progress.

In 2.30 ,to run Remove Tool, we must run Upscale or Denoise or Sharpness first(
not only the Upscale,this is slower than Denoise) ,2.3.1 works.


Sorry - Forget everything I previously said. After reading the post from @td_atelier about other models than upscale (this was either not mentioned previously or I just plain missed it) I reverted to 2.3.0 for the sake of testing and turned off Autopilot completely in Preferences. PAI crashed.

2.3.1 did however fix this.

@AiDon Just ot of curiosity - did you try to reproduce in 2.3.0 with Autopilot off or did you also just go by the upscale/no upscale?

I don’t have this problem, my 2.3.1 detects face just fine in your picture.
Windows 10, Nvidia 3070, 537.58 drivers.

1 Like

Can you change that the preselection selects the new models when you turn on enahnce?

I have selected Hifi but it uses the old models.

Memorymanagement seems now to be ok.

1 Like

But I’m not interesting in Remove Tool, this is not Topaz doing not good enough,Other software such as Skylum,HitPaw and Adobe have remove tools,all of these can only remove simple objects, a dog in the filed…a car in plaza…etc, computer AI is very difficult to remove an half object in a complex scenes,that can not be AI.the results
sometimes looks funny(Strange).So I prefer Topaz Gigapixel AI to Photo AI.

I’m not sure I’m following…

But my point was that a number of people said (in the previous thread) that unless you had upscale “active” you could not use the remove tool.

This I tested, and I could actually remove in 2.3.0 without having the upscale active which I reported back on.

Then I read your post and realized that even though I didn’t have the upscale active there was either a Denoise or Sharpen being done to the pictures I tried (either one or the other models did activate)

So I went back and tried - with Autopilot completely off - after which PAI crashed when trying to do a removal which meant I kind of had to retract my comment about “I don’t have any issues…” So my reason for tagging you were more acknowleding that you pointed out something new that I haven’t seen (which is why you got my like as well). Any extra info is valuable, and that you provided (for me).

This version seems to be also unstable with Photoshop when using automate for upscale.
W10 128GB 7950X RTX4080

I turn Autopilot off,So crashed, I think that remove tool using the Data copy of the picture, not the original picture information,after upscale or denoise,the date had
been copied to memory( eg. var data1 = data_picture) ,but remove tool call the dada1 intead of dada_picture. if Autopilot is off completely, dada1 is not in memory,is null,then crashed.

1 Like

I always have autopilot off and upscale/not upscale makes no difference on my rig. Eventually, with the help of the logs, they should be able to work it out.

Note that with autopilot off it still needs to evaluate the image … so I guess off means it doesn’t perform any DeNoise, sharpen or upscale.

1 Like

Hi. Is the Remove tool crash fixed in this new version? I’m not seeing anything about it in the release notes, so I guess not? Just asking so I know if I should update or not. As mentioned in the previous thread, this crash happens only if no upscaling has been turned on beforehand. You can see my detailed explanation and bug reproduction steps here.

1 Like

I have not been able to reproduce your remove tool crash.

I am also not having any issues with face detection stalling.

GPU: NVIDIA GTX 2070 Super
CPU: AMD Ryzen 7 3700X
Memory: 32GB
Monitor: ASUS ROG PG348, 3440x1440 @ 100Hz, G-Sync Enabled