Topaz Photo AI | v2.3.1 | Face Detection Bug

Photo AI 2.3.1 Autopilot gets stuck on Detecting Face when loading an image. It was working fine with 2.3.0. I processed an image earlier without any problems. Then I ran the update a few minutes later. And now that same image that worked fine before is stuck on Detecting Faces. It seems to work alright on images that don’t have a face.

Steps to reproduce issue:

  1. Update Photo AI to 2.3.1
  2. Open an image with a face.
  3. Autopilot gets stuck on Detecting Faces.

Topaz Photo AI [v2.3.1] on [Windows]


I have exactly the same problem after updating to version 2.3.1.
The face detection stucks in an endless loop.

1 Like

I have exactly the same problem, stuck in endless loop!!!

Last night I uninstalled 2.3.1 and reinstalled 2.3.0. It only took a few minutes. The previous version still works fine.


Me too!

Same here. Ver 2.3.1 on Windows 11

After updating to 2.3.1 on Windows 10 Pro from the previous version it gets stuck on Detecting Faces. Deselecting Autopilot does not prevent getting stuck nor using an image with no faces at all this version still gets stuck. Version 2.3.0 worked fine when I used it yesterday.

Where can I get the prior version? I have the same problem.

I’m having the same problem (on Windows 11 Pro). Photo AI version 2.3.1 frequently hangs on Detecting Faces. I reverted to 2.3.0 and, so far, it seems to work OK.

Here’s the link to Topaz Photo AI 2.3.0


I have the same problem. Did a complete uninstall and fresh install; no improvement.

Bless you!!

1 Like

Same problem 2.3.1.

It is interesting that there are these problems detecting faces. There must be a common thread with all these posts as I have a Win 11 PC, AMD Ryzen 9 6900HX with 32GB RAM and a RTX3060/6GB and have no problems, as you can see from the screenshots here:


It would be a good idea to post your OS, CPU, RAM, GPU and GPU driver version.

I have the same problem. How to revert to the previous version?

Deinstall 2.31, install 2.30

1 Like

I have the same issue. Windows 10 Pro, Intel I i5-7600K CPU, 64GB RAM, RTX 3060Ti 8GB.

Hi John,
I open Photo AI via File/Plug-in extras; it opens in Autopilot, then gets so far through the process and then hangs indefinitely. I then can’t do anything other than quit Photo AI.
I use Nikon so the RAW files are .NEF.

1 Like

We’ve had a Windows users report similar issues with this update.

We’d like to get some more information to help troubleshoot the problem you are having. First, could you send us your computer’s full system profile?

How To Obtain Your System Profile (Windows)

Also if you can, please go to Help > Open Log Folder , then please send me all of the files within that folder. You should be able to attach them directly as a response to this email.


You can securely submit your files(s) to my Dropbox using the link below. Please be sure to send me a note to let me know you sent something.

Dropbox File Request

After you have done this You can choose one of these two workarounds to resolve this issue:

  • Disable the Autopilot in the app’s Preferences > Autopilot menu

  • Uninstall the current application version and then revert back to Topaz Photo AI v2.3.0 using the following download link: Topaz Photo AI | v 2.3.0 | Windows Installer


1 Like

[Please describe your issue here. Try to include logs (Help → Logging) and add screenshots if necessary.]I have a problem with Photo AI. I have tried old versions but the same problem occurs. The problem is when using “Face Detection” it places a ‘black block’ across the face of the subject. Also with the latest version [2.31] it has started introducing artifacts in faces (with face detection off).
This happens with both RAW and JPEG images from either Canon (R5) or Nikon (Z7 II).

Steps to reproduce issue:

  1. Step 1
  2. Step 2
  3. Step 3

Topaz Photo AI [v1.x.x] on [Windows/Mac]