Topaz Photo AI v1.1.5 - v1.1.6

Downloaded v 1.1.5 and installed over the 1.1.4 version. Still the same bugs in stand alone. Once PAI is opened full screen it can only be minimized, not reduced (Little square icon). While it is opened full screen I can’t access the task bar (Windows 10 and 11). Once PAI is minimized I can’t open it again and have to use task manager to close. Mouse over the icon in the task bar shows blank.

After using the masking tool to mask subjects the Subject only switch has no effect for sharpening. It sharpens everything not just the subject.
Windows 11,AMD Ryzen CPU, RX5600 XT GPU, 32 GB ram.

1 Like

I’ve had the same experience with certain images.

I wish the adjustments went from a true zero gradually & progressively up to a full 100. But, generally, the settings behave like they’re over 50+ when in (what I’d consider) the 10-15 position. That’s why I was curious.

1 Like

@anthony.lawn @adam.mains

I find the ‘Apply’ (or, Accept - when I’m finished making settings & reviewing previews and ready to send back to Ps layer) stage processing (Ps 2023 Plugin, Win 11 Pro) progressively faster with each iteration of new release. Which is very positive!

I also have the same issue. Is there a way to revert back until the problem is fixed.


Uninstall rel. 1.1.5 if you’d like to roll back.

Then go to the “Product Releases” Discussion tab - all the products are listed there - including the most recent 2-3 PAI releases. You can grab PAI 1.1.4 there if it worked better for you.

1 Like

I also have this issue. If you do raw from Lightroom it works fine.

Face rendering is impressive and very nice, thanks. But, the neck or other parts of persons, eg. forearms, seem to be just horrible. I hope that this can be fixed in future.


me too

Same crop issue here. Makes the program unusable for me.

1 Like

I also still have the GPS tags getting stripped. I found if I apply them via Lightroom they don’t get stripped. I use a Canon GP-EP2 with my R7 and R5, and that data gets stripped. I can provide RAW files if you would like to debug.

Normal denoise in Photo AI uses the Low Light model from De Noise AI and it has the same problems there. Not sure what Strong is.

I have the same problem. I agree it is unusable like this.

1 Like

I use ON1 for my catalog and main editor. I am finding that making adjustments and outputting the results from ON1 to a tiff before PAI gives better results than using PAI on the raw file first.


Please read the thread for solutions to issues you are facing, don’t just post after looking at the last post. There is a search provided for your use.

Anyone here could have searched for crop and found there was a fix …

Yeah, “bug” or not is really just a matter of semantics. This is NOT what happened in 1.1.4, and it’s making the tool completely unusable for many people in 1.1.5 … not to mention it doesn’t seem to be possible to download 1.1.4 to revert, so we’re totally stuck. I’m sending crops to PhotoAI and then getting completely different areas of the photo showing up. The file is absolutely fine in LR, and the TIFF export that was created to move over shows perfectly fine in Photos and anything else I open the image in. Please at least give us an option to download the previous version so we can get the things we’re trying to get done accomplished while we wait for this to be dealt with.

Edit: Found the rollback instructions, thanks @Fotomaker

1 Like

Did you try the Alpha with the fix mentioned above.

I did not, I’m not a beta tester so I’m not sure I have access, and I’m in the middle of a rush to polish up some photos for a club comp submission deadline, so the previous version was good enough for this evening :slight_smile:

(Topaz Photo AI v1.1.4)

For anyone who had the cropping issue, we’ve released 1.1.6 which should address the issue. It has the same fix that the alpha build had. You can find links at the top of the page, or update from within the release version of the app (not the alpha).


I had previously installed the alpha version and now installed 1.1.6. How do I remove the reference to the alpha version in Lightroom “Photo/Edit In” menu?