Topaz Photo AI v1.1.5 - v1.1.6

I use ON1 for my catalog and main editor. I am finding that making adjustments and outputting the results from ON1 to a tiff before PAI gives better results than using PAI on the raw file first.


Please read the thread for solutions to issues you are facing, don’t just post after looking at the last post. There is a search provided for your use.

Anyone here could have searched for crop and found there was a fix …

Yeah, “bug” or not is really just a matter of semantics. This is NOT what happened in 1.1.4, and it’s making the tool completely unusable for many people in 1.1.5 … not to mention it doesn’t seem to be possible to download 1.1.4 to revert, so we’re totally stuck. I’m sending crops to PhotoAI and then getting completely different areas of the photo showing up. The file is absolutely fine in LR, and the TIFF export that was created to move over shows perfectly fine in Photos and anything else I open the image in. Please at least give us an option to download the previous version so we can get the things we’re trying to get done accomplished while we wait for this to be dealt with.

Edit: Found the rollback instructions, thanks @Fotomaker

1 Like

Did you try the Alpha with the fix mentioned above.

I did not, I’m not a beta tester so I’m not sure I have access, and I’m in the middle of a rush to polish up some photos for a club comp submission deadline, so the previous version was good enough for this evening :slight_smile:

(Topaz Photo AI v1.1.4)

For anyone who had the cropping issue, we’ve released 1.1.6 which should address the issue. It has the same fix that the alpha build had. You can find links at the top of the page, or update from within the release version of the app (not the alpha).


I had previously installed the alpha version and now installed 1.1.6. How do I remove the reference to the alpha version in Lightroom “Photo/Edit In” menu?

It appears to me that v1.1.5 and v1.1.6 always sharpen the subject only, regardless of the setting of the “Subject Only” switch. It used to (also incorrectly) sharpen everything, regardless of the switch setting in an earlier version.

You should be able to just uninstall the alpha and I believe it should remove it. If for some reason that doesn’t work, you can always go to LrC’s Preferences > External Editing, and then delete it manually from the “Additional External Editor” section.

It shouldn’t matter, but just out of curiosity, do you have your Prefs set to auto-detect subjects?

This week’s v1.1.5 brings back (regression) the “access violation” error with PaintShopPro 2022 that was fixed in the previous release. PSP version x64.

v1.1.5 works fine with PSP 2023 for me.

Hi - thanks for updating and improving regularly. However I have found a strange bug in v 1.1.6: If I only use the Remove noise tool, whatever value I set in the strength slider, it has not effect. The detail slider seems to be responsive but not the strength slider. Normally, if I would set the strength to the lowest possible value, I would expect no or only subtle noise removal. I have downloaded earlier versions down to 1.1 and see the same effect. Is it possible that some components do not work properly and do not get removed when an update is applied?
Thanks for checking, Markus (Mac Studio, Monterey 12.6.2)

Hi, Thank you for your continuing development work - the difference is noticeable. Just a bit of feedback (PAI v1.1.5 and v1.1.6, macOS Ventura, MacBook Pro M1 Max 32GB, Canon R5/ R7 raw files).

The initial Autopilot masking is generally good (currently editing perched birds), but adjustments with the AI brush can be frustrating and I would like to be able to choose a manual brush where required (I know you know this and, I think, you’re working on it!). The initial Autopilot assessment for Noise reduction and Sharpening (Strength/ Clarity) continues to be over-enthusiastic (in my opinion) and inevitably requires intervention - see screen shots of Autopilot settings and my settings and Lightroom Classic screen capture comparing the results (notice the over-sharpness in the feathers and loss of detail around the eye with the Autopilot version - on the left). I have uploaded the raw file to your Dropbox link so you can have a play.

Keep up the good work - and happy new year! Phil

1 Like

Since v.1.1.6. the model downloads are done in full speed. :smiley: :+1:

1 Like

It does make an attempt at identifying the subject. Sometimes it does that really well, at other times it does a laughably poor job of it. Occasionally, it does not find a subject. The situation did not change in version 1.1.6 regarding the (non-)effect of the “Subject Only” switch in the Sharpen menu panel.

1 Like

Feature Detection is set to “Default” in the Preferences, BTW.

1 Like

If you change your Pref (even if temporarily to test…) to Do Not Detect Subject, does your entire image get sharpened? Vs just the subject.

OK, interesting. When I changed the pref to “None”, it sharpened the whole photo. I then selected a portion of the photo to be the subject, and the Subject Only switch worked as it should, whether on or off. I went in and changed the preference back to “Default”, and now it sharpens the parts of the photo that it should with “Subject Only” in either position! Maybe something didn’t get initialized as it should have, and switching the preferences cleared it up? Who knows, but I’m glad that it works now.

1 Like