Topaz Photo AI v1.1.1

Photo AI found the main subject, in this case a knife clam throwing a shadow upon the surrounding flat sand on a beach. But the shadow was included in the mask. It’s not interesting to have the shadow-part of the sand sharpened while the major part of the sand is unsharpened. So I deleted the shadow-part from the object with the new brush? First with the largest, then … ,ending up with the smallest brush. But the smallest brush still marked areas across the border of the clam. I could either choose to have parts of the clam unsharpened - or parts of the sand included in the mask.
Unfortunately the sharpening precisely followed the fractalized division of this segment and not the edge along the clam, which left me with a very obvious sharpened area of grains close to the clam - breaking up the impression of an unsharpened surrounding base.
Eigil Skovgaard

Don’t forget to include the example of what you are seeing.

Also include your technical computing environment including: OS, RAM, GPU with dedicated vRAM and driver version.

I know, but this behavior speaks for itself (the fractalization is not sufficient to find the actual borders and can’t be modified with the brush to adapt). Further the situation was managed to prioritize the production, and in this case I will not distribute the image. Finally, the environment is not critical in this case. This is an obvious limitation in the level of fractalization - it’s too coarse - and can’t be modified.

1 Like

I’m seeing the same issue on the latest version, where the sharpening is not limited to the subject and is acting on the whole image. Really noticeable on some with low depth of field where parts of the background are being sharpened.

The subject refinement shows the correct part of the image has been selected as the ‘subject’ but it’s sharpening the whole thing.

I’m sure that was working in earlier versions.

How did you manage to reinstall 1.1.0. I would like to do the same but I don’t think I have any download of the old version and can’t find old versions available to download.

Edit: I have found the download on the release thread for 1.1.0 and re-installed.

The fact that 1.1.1 sharpens outside of the ‘subject’ makes it unusable for me, even though there some nice things in the new one.

I will update again when that’s fixed.

Topaz Photo AI v1.1.0 - Product Releases / Topaz Photo AI - Topaz Discussion Forum ( just noticed your post, this is a link back to 1.1.0 you can go back on any of the products you buy on topaz, i have found in a number of cases that an update can cause issue but it’s good to be able to try them out and roll back if needed, until it is sorted at a later date.

Desktop: HP ENVY TE01 Windows 11 version 10.0.22621 Build 22621
NVIDIA GeForce RTX 2060 Driver version
Dedicated video memory: 6144 MB GDDR6

Same issue on my laptop.
HP PROBOOK 470 G5 Windows 11 version 10.0.22621 Build 22621
NVIDIA GeForce 930MX Driver version
Dedicated video memory: 2048MB DDR3

Getting haloing around subject. Same pic using Sharpen AI does not show this.


I’d like to report another issue - something is broken with the colours, see below:
The TIFF file freshly exported BEFORE adjustments:

The same AFTER saving the image in Photo AI:

1 Like

I’m very happy with your product. One improvement request: 90% of your “find subject” feature results do not align with my opinion of what the subject is (I can imagine how difficult that is). I then need to toggle the sharpen everything switch on. Can you make that setting sticky or allow a user set the default as desired? I don’t normally want to take the time to refine the subject on most photos. Thanks.

Same issue here. Also, opening a jpg file (that was exported from LR) in Photo AI removes the camera metadata.

Does the tif image have the same colour profile embedded after saving in PhotoAI? The muted colours suggests there is a colour profile mismatch between the input image and the output image.

i often use pai in batch mode.
unfortunately I can not set the facial restoration because I can not set a maximum value.
It is always worked with 100 percent.
Unfortunately, this often looks awful.

The latest version of Photo AI v1.1.1 seems to be broken with the message “Exception while opening image: Image is not supported”. The image in question is a Nikon NEF taken with a Nikon Z9. Previous version of Photo AI have worked fine.

TL;DR: Photo AI strips all metadata (including Color Space information) from the TIF upon saving which could be the reason for the muted colors, buth Lightroom is also not innocent as the Color Space information looks weird for both the panorama and a freshly created TIF from any dng.

More Details:

  1. I’ve checked the Color Space information with Exiftool for both the dng and the tif from my previous post - both were showing as “Uncalibrated” :face_with_raised_eyebrow: OK, looks like I need a different sample
  2. Since the dng was a panorama stiched together in Lightroom I’ve checked another dng with Exiftool - this was showing correctly as “Adobe RGB” (I have Adobe RGB set up in my camera body)
  3. I’ve created a tif from that dng in Lightroom (Ctrl+Alt+E) with the following settings: ProPhoto RGB Color Space with 16-bit depth and 240ppi resolution
  4. After the tif file was created, I’ve enlarged it in Lightroom to trigger the update of the preview - colours match the dng
  5. Opened the tif in Windows Photo Viewer - colours look exactly the same as in Lightroom
  6. Ran Exiftool for the tif - Color Space: “Uncalibrated” :face_with_raised_eyebrow:
  7. Loaded the tif in Photo AI - colours immediately muted
  8. Saved the image in Photo AI - the preview in LR immediately updated to the muted colours
  9. Ran Exiftool on the tif saved by Photo AI - all EXIF info which was there before saving was gone (including the Color Space)
  10. Ran Exiftool on a TIF that was created in the previous version of Lightroom (12.0) and Photo AI (1.1.0) - Color Space is “Uncalibrated”, but there is an additional field called “Profile Description” which says “ProPhoto RGB”

See images attached.
1st image - Lightroom vs. Photo AI between steps 7 and 8
2nd image - Exiftool output for the original dng (green), the tif before (yellow) and after (orange) saving in Photo AI (steps 2, 6 and 9 respectively)

This version is unusable. As soon as I use an ADD brush to a mask the program disappears. Using JPG files and RAW files. This happens no matter what files I am using. Windows 10 64 gig RAM, Intel Core 9 i9 9900k Nvidia Geforce RTX 2070 Super ( selected as the processor)

1 Like

May need to drop back a version, as I’m encountering something completely different:

Canon R5 compressed RAW file. On processing from the RAW file, I’m seeing this on the interface. It seems to still process the end result correctly (see later attachment), but with this state it was difficult to refine the subject selection

trying to refine the subject it would seemlingly ‘lock’ on the calculations and take up to 30 seconds to come back to allow more refinement.

Once all the processing is complete, it ends up with a good output, but just the hassle and lack of being able to compare before/after leads me to just want to back out to the previous release and try on the next one.

I’m not sure that exiftool is useful in this instance. I have plenty of tif files that just state “Uncalibrated” in the meta data, but when opened in Photoshop have Adobe RGB or other profiles attached.

I’ve opened a ProPhoto RGB tif in PhotoAI, processed it and saved. The tif still has a ProPhoto profile when opened in Photoshop and the colours are unchanged throughout the process.

The tif I used was created in LR, but an earlier version. I’ll update to the latest version and try again sometime today.

I also noticed the sharpening of whole image instead of the “subject”, however the “subject only” switch is “on”.

The new update has removed my ability to control what the autopilot does when opened from photoshop. How can I stop the program from auto saving to photoshop. Thanks.