Topaz Photo AI v1.0.8


This week is focused on a few smaller fixes while we prepare some of the bigger changes. It includes a few background fixes as well as stuff like finally having the app save the window size and location and some new command line options.

If you own DeNoise, Sharpen, and Gigapixel with up-to-date licenses then you already have access to Topaz Photo AI!

Please give us any feedback or report issues with this release. We’ll be updating TPAI regularly to address those pieces of feedback and issue reports. If there’s a specific image you’d like us to see, you can send it us at this dropbox link.

Released November 3, 2022
Mac: Download
Windows: Download

Changes since 1.0.7:

  • Add --showSettings and --skipProcessing flags to command line interface
  • Window position should now be saved between app runs
  • AVX check should no longer trigger antivirus
  • Installer will now attempt to use HTTPS to avoid firewall issues
  • Image preview should now clear after closing and re-opening an image
  • Fixed an issue where CLI didn’t cap the amount of simultaneously saving images
  • Fixed Autopilot dots not being correct in Sharpen
  • Fixed Enhance parameters being wrong if controls were modified before resizing

We still have a lot more planned! Here’s some of the things we are actively working on improving:

  • AI Brush
  • Performance of the preview panel (particularly when zoomed out on large images)

Same issue I highlighted earlier today when using sharpen in the plugin version.
A mask is selected:

But after clicking “Done” it is still not possible to apply the mask selectively:

However, if the masked is refined…

…or even just one click of the brush applied and then removed:
Then it becomes possible to apply the mask as required:

I am using the plugin from On1 PR 2023, so cannot say if PS users would experience this. They would need to check it out. I can’t see it being a PR issue myself.
Mac mini 16GB, OS Ventura

1 Like

How do I change the dpi from 72 to 300dpi? I can’t find a place to change the settings.

is anybody ever going to fix the installler problem saying there isn’t an Internet connection? No problem with any of the other installers. Multiple internet connections, both wired and wireless. The installer has an issue for more than a few.

1 Like

the image sharpening with the auto mode is too strong even on the lowest setting for my taste. even when i turn of the sharpening the image will be sharpened and that looks just right on my images.


This was supposed to be fixed in this one, but I guess the fix doesn’t quite work. Is there a way for you to click past the error and have it work or does it prevent the install entirely?

There is currently no DPI setting. What are your thoughts on where to put it/how to set it in a way that works with how you use the app? We may take a look in the future.

I think we can maybe fix this for the next version. I’ll add it to our bug tracker. Thanks for the report!

Hello. I’m not entirely certain of how this chat/message function works, but wanted to report that I applied 4 updates to Topaz Photo AI tonight and now it crashes when I invoke it from the plug-in from LightRoom Classic. I had done a half dozen edits today prior to the updates and all went well. I have shut down LRC and started back up again - it still crashes. I will reboot my system and try again. I am running Windows 10 on an HP X360 Spectre with OLED screen and 16GB RAM.
Thank you.
Regards - Randy


I have an owned copy of Photo AI and have been using it from early beta days. I have been able to install each update since the commercial release, including v1.0.7. However, v1.0.8 goes through the installation process to completion, but fails to open. I have rebooted, uninstalled, reinstalled, rebooted and the usual trick, but Photo AI is now not usable and I can’t see a method of dropping back to an older, working version. My hardware has worked for past releases:
Windows 10 Home 10.0.19045
Intel Core I5 5200U CPU@ 2.20 GHz
12 GB installed memory.

1 Like

Why are you adding to the CLI! You won’t even tell anyone how to use it.

I have been meaning to post for a long time about this bug going back many releases. It happens in 1.08 also. I have Win10 21H2. I have my task bar set to automatically hide.

When Photo AI is maximized and I move the mouse cursor to the bottom of the screen the task bar does not come up. I tried changing the task bar settings to have the task bar on the left side, but the same problem exists. Of course, it works properly with all other programs, including Topaz Denoise AI, Sharpen AI, and Gigapixel AI.

I also discovered that the window restore icon does not do anything. Only the minimize and maximize icons work.

As well as landscape, I’d like a seascape mode that excludes sky and water from the sharpening.
My other minor problem is that when I open it as a plugin, it opens on the screen the main program was on rather than my second screen. De noise and sharpen are happy on the other screen!
Like the new AI brush.

Definitively not the most important thing, but from a graphical point of view this button is placed way too much in the corner.… :stuck_out_tongue_winking_eye:


1 Like

Wonderful product that enhance my Photoshop work flow

I will try but i don’t see in “Changes” nothing about of quality of result.
Every test show DenoiseAI and SharpenAI does a much better resullt.
Why you don’t work on quality of result ?

Latest version of Photo AI (1.0.8) and latest version of Lightroom Classic (12.0.1), using raw files in Lightroom, the ‘Edit in’ command creates a new file in Lightroom but does not open the new created file in Photo AI. Tried on two PCs Win11 and Win10.

I use Topaz Photo AI as a plugin from Photoshop. I have regularly with most critical images tested the Photo AI against DeNoise AI, i.e. made an extra copy of the smart object to run DeNoise AI as the second filter. The turning the DeNoise AI layer on/off I can compare the results.
Today I updated Photo AI from 1.0.7 to .8 after having run the .7 version, and to include the latest changes I re-invoked Photo AI by double clicking the line “Topaz Photo AI” to the right of the eye symbol. This would - with DeNoise AI - open the app. without showing any updates, and the app. would rerun with former settings and return.
In this case I had in the .7 session added the sharpen feature, as Photo AI didn’t do that by itself.
Now when I ran the .8 version from the eye-line - I expected Photo AI to rerun the actual combination of denoising and sharpening. But that didn’t happen. The app. opened as if it was the first time, and I had to add the sharpen feature again. If this rerun were made as an update caused by another filter being changed in Photoshop, then the sharpen part could be missing, or - will it just stop and wait for me to reinvoke the once selected combination again? That’s different from what we have done so far - and a bit less elegant.

I am experiencing a bug when invoking Photo AI from an external editor (im my case Capture One via the Capture One plugin from Photo AI), if the filename contains local characters like German Umlaute (äüö).
Filename: C:\Users\jens\AppData\Local\Temp\CaptureOneTemp1\cb720c05-0e94-46f8-a050-eb3cd3bb3271\20220716-Nürburgring-Truck-Grand-Prix-160249.tif
will not open because the filename is not transferred woth the correct coding table.
The PhotoAI log states:
[2022-11-04 13:26:42.597, 0.00 ns] [4160] Info | Log directory: “C:/ProgramData/Topaz Labs LLC/Topaz Photo AI/Logs”
[2022-11-04 13:26:42.597, 378.70 μs] [4160] Debug | Processing argument “C:\Users\jens\AppData\Local\Temp\CaptureOneTemp1\cb720c05-0e94-46f8-a050-eb3cd3bb3271\20220716-N?rburgring-Truck-Grand-Prix-160249.tif”
[2022-11-04 13:26:42.609, 11.86 ms] [4160] Info | Parent process ID: 16944 “P1.C1.PluginHostProcess” “Capture One”
[2022-11-04 13:26:42.609, 93.20 μs] [4160] Info | No valid files passed, not running as external editor mode.

Note, the “ü” in the filename was not transferred correctly.