Topaz Photo AI v1.0.10


This release is focused on bug fixes and stability and performance - don’t want to break anything leading up to Black Friday! Our larger projects are still being worked on in the background, and we’re excited to show y’all them afterwards!

If you own DeNoise, Sharpen, and Gigapixel with up-to-date licenses then you already have access to Topaz Photo AI!

Please give us any feedback or report issues with this release. We’ll be updating TPAI regularly to address those pieces of feedback and issue reports. If there’s a specific image you’d like us to see, you can send it us at this dropbox link.

Released November 17, 2022
Mac: Download
Windows: Download

Changes since 1.0.9:

  • Fixed a potential crash on super pixel generation
  • Fixed an issue where the Photoshop plugin wouldn’t start sometimes on Mac
  • Fixed plugin installation for Photoshop Elements and Affinity Photo 2
  • ExifTool start error from LrC now comes with a support link to help fix the issue
  • Fixed tooltip showing image settings getting stuck, can now get unstuck by hovering any image in batch view
  • Uninstaller should now remove everything properly
  • Installer will now ask to close Capture One on Windows to avoid plugin installation issues
  • There is now a warning when closing an image whose settings have been modified
  • Fixed mask mode sometimes saying “No Filters Active” instead of “Viewing Original”

We still have a lot more planned! Here’s some of the things we are actively working on improving:

  • AI Brush
  • Performance of the preview panel (particularly when zoomed out on large images)

Any Timeframe? :sweat_smile:

1 Like

Win 11 Pro desktop PC. Just ran Standalone & Ps (2022) Plugin.

Both launched & ran okay.

I see slight pixel shift in the returned Ps layer. But not the radical hop that sometimes occurred.

@anthony.lawn Will one of the future additions to the File menu be a “Open Recent” like the older products have? It would be helpful.

Thx. Have a nice holiday!

My Affinity Photo 2 plug in now works. Thanks.

Photoshop 2023 takes almost 40 sec to start up due to the Topaz Photo AI plugin (v1.0.10). Without the plugin, it takes about 2 sec. I’m on macOS Monterey 12.6.1 (M1 Mac Studio).

These are from 1.0.9 (that thread is now “obsolete”) but I wanted to share these “outtakes” from the blog post I wrote the other day. PAI is giving me very satisfying restorations/upscales of 1999-era 1-megapixel images, just like in Gigapixel days:

Nope still crashes when called from Affinity Photo ver 1 on Win 11.

1 Like

Thanks for the update. Here, after the update, Photoshop CC 22023 (24.01) crashed when opening Photo AI as a plugin. I had to remove the plugin and reinstall Photo AI. After a restart of the Mac, everything worked nicely again.

Warning to all, do not have host applications (those that will call Photo AI as a plugin) open at the time of the install otherwise you may have crashes in the host app as both the plugin & DLLs change with each install.

As there is no option to reinstall the plugins from Photo AI you will need to shut down the hosts and reinstall Photo AI.


Version 1.0.10 shows the same problems than the version before: parts of the image are blurried.


The plugin doesn’t work on Affinity Photo 2 running on Mac OS.
I also WISH a plug-in can be developed for Photo App running on MAC. I am sure a lots of. users would like to do a click and the edit App can do all the professional suggestions. That was,TOPAZ can broaden its users…

Plug-in (still) working with On1 Photo Raw 2023. Sends to PAI and returns as a layer. So it must be an issue specific to Affinity.
Mac Mini 16GB, Ventura.

Plugins still working for me on a Windows 10 PC both for Affinity Photo 2 & ACDsee Photo Studio Ultimate 2023. Still problems with the refine brush though.

The devs have already said that work on the refine brush etc., is being held over to the next update

1 Like

Hi Russell - is there any log created from the same timestamp of the failure in C:\ProgramData\Topaz Labs LLC\Topaz Photo AI\Logs? If yes, can you please share it with me? Thank you.

Hi Eric - is the plugin not opening or is it not showing up for you in Affinity Photo 2? If it’s not showing up at all, make sure you go to Affinity Photo 2 > Preferences > Photoshop Plugins, and check allow “Unknown” plugins to be used. Let me know if it’s still not working for you. Thank you.

1.0.10 on M2 MacBook Air.

I dropped in 25 images, and the bottom preview tiles do not scroll. Attempting to scroll moves a bit, then it snaps back, so I cannot get to anything past the first 11 photos.

I have had similar issues when batch processing and have raised it countless times. The devs have not got round to it yet it seems. (I haven’t tried v10 yet). My Sony ARW files do not preview in the film strip either.

Yes, that’s true for any plugin that will run from hosts like Ps. Their producers all say to be sure the host is shut down during plugin installation.

And most software, even if not symbiotic like that, say in instructions to have all other apps closed during installation. (But I’m one of the crazies who read the manual before using a new camera too…).

Btw, did you get the new Affinity? Is it a radically different design than the 1st one? If so, is it more Lr-like than Ps-like in v. 2? I’m getting promo emails…

Can you define your definition of “scroll”? When I scroll with a Magic mouse, by swiping my finger left/right, the bottom pane does not “scroll”… When I click on one of the images in the film strip, click and hold, and then DRAG the film strip, mine “scrolls” perfectly.