Topaz Photo AI v0.9

Hello everyone!

This week’s update focuses on various plugin experiences, some RAW updates/fixes, and various UI changes. One of the big features is a new Lightroom plugin which can be accessed from Lightroom’s File > Plug-In Extras menu. This allows RAW files to be sent to Photo AI instead of being forced to convert to TIFF first.

This release also rolls back some things added in 0.8.0: Quality Assessment and Basic Adjustments for RAW input. To put it short, these did not live up to our expectations for a release feature. We want to pull them back for now and consider looking into them later.

If you own DeNoise, Sharpen, and Gigapixel with up-to-date licenses then you have access to Photo AI. You will need to claim a Photo AI license by going to your account before you’ll be able to login.

This is an early access release, so there will be some issues you may run across. Issue reports and general feedback are much appreciated. If there’s a specific image you’d like us to see, you can send it to us at this dropbox link. Below the changelog are a list of issues we’re already aware of.


v0.9.0
Released September 1, 2022
Mac: Download
Windows: Download

Changes since 0.7.2:

  • Autopilot accuracy improved by 9% against an internal test set
  • Added support for RAW files via Lightroom via File > Plug-In Extras menu
  • Installer should now download the specific models your machine supports
  • Added support for EXR images
    – This is limited to EXRs with up to 4 channels which will be interpretted as RGBA
  • Added some missing camera corrections
  • Added ability to add corrections to file name on output
  • Added a warning for when invalid file names are passed in on Windows
    – The issue here is external editors passing in files that can’t be passed in directly
    – To fix this pre-emptively you can turn on Worldwide Language support in Windows (Image Not Loading from Lightroom Plugin to Topaz Photo AI - Topaz Labs)
  • Now able to detect a lot more host editors when used as external editor
  • Tweaked some color handling code for RAW files
  • Various UI changes
    – Colors on Autopilot list changed from green to light blue
    – Autopilot dot added on button to associate the dot with autopilot
    – Added busy indicator instead of static images when processing
    – Fixed small visual bug when progress bar was at a near-zero percentage
    – Misc. margin, padding, and color changes

Fixed:

  • Fixed instance merging on Mac (LR should no longer open multiple windows)
  • Fixed detection for RAW images that can use RAW model
    – Some images with unexpected metadata were using the non-RAW model, but these should now use the correct model instead
  • Fixed right panel no longer showing tooltips
  • Fixed “unsaved changes” prompt showing up incorrectly in plugin mode
  • Fixed a crash on exit issue on certain Macs
  • Fixed crop not working when no crop origin was set in metadata

Removed:

  • Removed ability to thumbs up/down autopilot settings
  • Reverted the Quality Assessment feature
  • Reverted the Basic Adjustments feature

Known issues:

  • “No Filters Active” showing after trying to process an image
    – Need more information on these instances. Generally has to do with model files missing, so attempting to re-install to the default paths might fix it.
  • Image size in the Resize area of the right panel may not match the cropped image size of an imported RAW file
  • Image saving might hang occasionally when saving from Lightroom
4 Likes

is it possible to export an image from topaz photo ai to photoshop

Y’all be the DJ Khaled of icons… “Another One”

Oh-oh…

Screen Shot 2022-09-01 at 4.18.15 PM

Wired university connection. macOS Monterey, Intel.

I quit the installer and relaunched, and the app seemed OK (so far).

Maybe I need those downloads after all? “No filters active” at 4X:

Gave results at 2X:

Problem is with Low Resolution model. Does not work above 2X.

Downloaded app again on M1 MBP, Ventura latest beta on university wi-fi. Model downloads completed successfully.

Win 11 Pro desktop. Processor choice = Auto (I’m running AMD RX6800 XT & Intel i9 12th gen - not sure which PAI chooses…). PAI .9 initial tests.

JPG image tests - to start…

  • Install went smoothly using Win installer from website - no in app update. Installed over previous rel.

Standalone:

  • Launch with no issues
  • I like ability to hover over light Blue words in AutoPilot part of settings panel to see Subject or Faces Detected.
  • I like the relating of the Green Dots to the AutoPilot portion of the settings panel and to the quality settings below it. Makes it easy to see what A.P. affected.
  • With “Enhance” = ON, PAI did nice job with a night photo that included ppl in moiton
  • ONLY 1 of 4 equal-sized heads/faces was detected in the scene (it’s an image I’ve previously Dropboxed to Yazi…)
  • A Group of 4 dancers was (mostly) selected as the Subject for the scene (it was close enough if there would be a Masking function to manually add in the missing bit).
  • Before/After Snips below. Labelled in filenames. Dancers in costume.

Ps 2022 Plugin:

  • Launched, processed, saved processed to Ps layer - No issues. I just reduced the “Fill” a bit on the Ps layer to compensate for some brightening on cactus tips.
  • I like the consistency of the UI appearance b/wn the Standalone & the Plugin (so no one thinks features are accidentally missing…) but with the disclaimer re: resizing in Ps.
  • I was able to do more Ps processing to the PAI saved to layer output - e.g., nothing became corrupted with the file/image such that I couldn’t keep “playing” with the PAI-processed image from the plugin to make more alterations to it in Ps.
  • Snips below - desert scene. Labelled in filename.

Other General Reactions:

  • I’m glad the Raw Adjustments & Quality Rating were removed. No value-add to them at this time & caused other issues…
  • I don’t see any Tool Tips in my righthand Settings Panel - thought the Changelog said they’d be there. Did I misunderstand? Is there a new notation besides “?” ?

I mostly prefer to work in Ps. But will try some Raw images tomorrow… with the Standalone.

Snips: (mentioned in Notes above)






When I send RAW image from LR through Plug-in extra and have anything but CPU chosen, program crashes and I get the error message “An internal error occurred. Failed to process photo…”. When I send a TIFF image form LR through edit in, same thing happens without message.

The download and install worked fine.

Ran the following test:

  1. In standalone dropped in a Nikon NEF file and saved as a DNG. DNG was recognized and could be edited in Affinity Photo and SilkyPix 11.
  2. Called from Affinity Photo as a plug in. Everything worked fine.
  3. During the test the Photo AI v0.9 crashed once. There was no specific action I was just moving the mouse across the screen when it happened. Tried several times to repeat the crash but was not able to.

Overall very pleased with the changes and performance. Ran these test multiple times. The way I tested would be the way I use the product. Nice work.

Mac mini M1 (2020) 16GB, 1TB

Photo AI 0.9 continues to really smooth out detail to unusable levels (top). You don’t get this in Topaz Denoise AI (bottom)

4 Likes

Photo AI enlarge image does not operate in Photoshop or stand alone. How do I resolve this?

Won’t operate as a plug-in, should operate as standalone. What’s your OS and how are you opening the images when using as a standalone?

Try opening through the File Open menu and make sure it isn’t a RAW.

It says in the app under Resize that that function doesn’t work in Photoshop as a filter plugin…

interesting. PAI 0.9 (mac) added wire rim glasses during facial recovery.
these two screen caps were taken at a wedding twenty years ago just moments apart. glasses were added to the left image. even odder, the left and right lenses are different shapes.

what is ‘enhance’ enhancing?

3 Likes

RAW processing seems much improved from earlier versions, not seeing major colour changes in returned DNGs as in earlier versions.

However, for me, before it can be considered as a usable RAW preprocessor call from Lightroom, On1 etc it has to handle .xmp files associated with RAW file. DNGs come back without keywords assigned to RAW files.

1 Like

This is actually a little bit weird if you ask me and suggests Photo AI when it comes to faces is trawling a database of facial features and sticking a higher quality version of one that matches the original facial features on to the face! So are the eyes even the eyes of the original person? Raises a few questions?

Win 11 desktop. Standalone. Testing Canon .CR2 raw image.

Crisped up the original image of a building in San Diego.

Didn’t select the building as a Subject. Just ID’d some tiny patch in center of image as Subject. Coral overlay at center is the area that was selected.

No significant color shifts to the image in processing.

V0.8 to V0.9 I get a message that there are 4 updates available?
image

Also woeful download speeds:
image

2 Likes

Just downloaded & installed TPAI v0.9. For me still the same problem, works as a standalone, but still crashes when I try to use it as a Photoshop plug-in. Tried with a Nikon raw (NEF) file, TPAI crashed, then tried with a JPG file, again TPAI crashed. Have had to go back to using TPAI v0.6 as that works fine.

What is your PS version?

Did you duplicate the layer before editing in Photo AI as it can’t edit a locked layer?

Do a lot of small bird photography in woodland so need to use high ISO and Topaz is my go to app but with this new TP AI it just does not seem to be able to recognise small subjects in a large area.
Need a brush to manually remove what is not wanted. Thankyou, Russ.

PS. to save another post. I use On1 Photo RAW 2022 with my own camera profiles, when I send RAW images to Topaz Photo with only the camera profile added they come back with the On1 PR own profile without an option to change, is this an On1 or Topaz action as I am sending a RAW file? Thankyou.

1 Like

As you can see from this pic the face detection is on a cat:

Sent to Photo AI:

Returned to PS: