Topaz Photo AI not saving back to Lightroom - v1.3.6

When I first purchased Photo Ai a couple of months ago, it worked perfectly well. Now it doesn’t. This seems to be as a result of upgrading the software. I have tried uninstalling it twice but this hasn’t provided a solution. The photos will process but not save back to Lightroom. Has anyone got any amazing solutions to fix this issue?

Steps to reproduce issue:

  1. Step 1
  2. Step 2
  3. Step 3

Topaz Photo AI [v1.x.x] on [Windows/Mac]

@kate.lacy thanks for submitting this.

Are you using the File > Plug-in Extras > Process with Topaz Photo AI or the Photo > Edit in > Topaz Photo AI workflow?

Please send me the log files so I can see what’s going on in the application. To do that, open Topaz Photo AI and go to the Help > Open Log Folder menu option and upload all the logs files in the folder.

Hi Tim

I am using the Photo>Edit in>Topaz Ai workflow.
Please see log below:


Topaz Photo AI Installer Log.txt (3.44 MB)

2023-05-24-06-16-15.tzlog (95.8 KB)

2023-05-28-13-15-0.tzlog (1.24 KB)

2023-05-25-19-18-34.tzlog (107 KB)

2023-05-28-11-46-47.tzlog (106 KB)

2023-05-28-12-22-43.tzlog (253 KB)

2023-06-01-03-17-9.tzlog (9.33 KB)

2023-05-22-17-57-16.tzlog (1.23 KB)

2023-05-22-17-46-44.tzlog (239 KB)

2023-05-22-19-17-20.tzlog (1.22 KB)

2023-05-22-20-02-27.tzlog (1.21 KB)

2023-05-22-19-04-32.tzlog (1.01 MB)

@kate.lacy just to confirm, have you changed the save location by any chance?

Can you check if the images are being sent to the original folder.
If they are, you’ll have to drag those DNG files into the collection.

Hi Tim
Can you give me more detail about how to do that please? As far as I knew the Topaz edited photos get sent back to Lightroom, not a folder.

@kate.lacy Can you send a screen-recording of your workflow? You’ve already tried uninstalling and reinstalling which should’ve fixed most plugin communication conflicts.

I want to see exactly how you’re using the apps and maybe find the problem.
Loom is a great free software for screen recordings. You can upload the recording here.


This is frustrating. Is there any way you could give me a call rather than having a few days between emails. I have paid for the product and it isn’t working. I want proper IT support;



Unfortunately we do not do live phone support.

If you submit a support ticket at I can give you a link to schedule a screen-share with me or someone on my team.

Hi Tim

I have no idea why but it seems to be working again although not as a Plug In. I have to load directly from a folder. Go figure! Thanks for the suggestion of using the ‘’. I will try it in the future if I need to.


1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.