Topaz Photo AI Installation Fails on Mac Sonoma 14.4.1

I am having issues installing Topaz Photo Ai. It gets stuck downloading the Ai Models. Progress does not go past 47/57. I will include logs for reference.


Topaz Photo AI [v3.0.3] on [Mac]
Installer Log 7-Jun-2024.txt (44.8 KB)

Hi Fabian, yesterday, June 7, I installed Photo AI on my Macbook running Sonoma 14.5. No issues. Could upgrading to Sonoma 14.5 be an option for you?

Cheers,
Thomas

First, please disable antivirus, firewall, VPN, or proxy that may be on your computer. These are known to block the installer from downloading the model files.Run the installer again. Once the installation finishes or fails, do not close the installer window and follow the steps below to send me the installer logs :

  1. While the installer window is open, click the following menu on the top of your screen, Window > Installer Log.
  2. Click the dropdown menu on the top bar and select “Show All Logs”.
  3. Then save the file and email it to me.

Topaz Photo Ai Installer Logs (Mac)

Thanks Thomas. I updated to 14.5 today and tried again. I’m still running into issues. I appreciate your help!

Hey John,

Please see attachment for Logs.

Thanks in advance,
Fabian

Installer Log 8-Jun-2024.txt (44.9 KB)

Sorry to hear that, was hoping that it could help. You do have sufficient disk space remaining for the complete installation, right?

Just checked, I have more than plenty left.

Please follow the instructions below to perform a clean install to better troubleshoot why you had this problem with Topaz Photo AI:

Start by clearing any previous plist files that are on your computer for Topaz Photo AI by following the steps in the link below:

Topaz Photo AI | plist Files Mac

After you have done this, disable any antivirus, firewall, VPN, or proxy software that might be active on your computer. These tools are sometimes known to interfere with the installer’s ability to download the model files.

Please also ensure that the Topaz Photo AI installer has all the proper settings in your system by going to your Mac System Settings > Privacy & Security tab and scrolling down to the security section. You will want to make sure you have 'App Store and identified developers ’ selected. Here is a video example:

Example of Proper System Preferences

Finally, rerun the installer. You can download a new installer from the downloads page directly :

Topaz Labs Download Page

Let me know how that goes for you and I’ll keep an eye out for your reply.

Then I am puzzled. I cannot imagine that it would be an issue of the software since I had no problems at all with the installation…and I did it on two different Macbooks (since I just recently replaced one).
Maybe delete the download and try the whole exercise again?

Maybe the Topaz-team will reply with some ideas…

Good luck!

Hey John,

I followed your instructions to perform a clean install and I’m still running into the same issue. The download keeps stopping at the same spot. Here is a screenshot of where it is getting stuck.

I will also attach logs from todays install.

Installer Log 11-Jun-2024.txt (81.3 KB)

Topaz Photo AI does install on my computer even though the install is not fully completing. It is buggy and needs to download packages each time it is used.

Let me know what my next steps should be.

Thank you,
Fabian Vicuna

Please send me your system profile information so I can check if your computer hardware is up to date.

You can securely submit your files(s) to my Dropbox using the link below.

Please be sure to send me a note here to let me know you sent something.

Hey John,

I was able to solve my issue. For some reason my internet connection with Spectrum has issues downloading files. I connected to my hotspot and was able to download the program.

Thank you so much for your help.

Sincerely,
Fabian

1 Like