Topaz Photo AI 2.4 crashes when using „Remove Noise“ on MacPro running MacOS Ventura!

Photo AI crashes everytime when using „Remove Noise“.
System: MacOS 13.6.4

Steps to reproduce issue:

  1. Step 1: Start Photo AI 2.4
  2. Step 2 Open Image (PNG, JPG, TIF)
  3. Step 3 Choose Enhancement „Remove Noise“

After Step 3 the App crashes immediately.
All the other enhancements are working fine!

Topaz Photo AI [v1.x.x] on [Windows/Mac]

A post was merged into an existing topic: Adjust Lighting Error & Crash | MacOS M3

Please follow the instructions below to perform a clean install to better troubleshoot why you had this problem with Topaz Photo AI:

Start by clearing any previous plist files that are on your computer for Topaz Photo AI by following the steps in the link below:

Topaz Photo AI | plist Files Mac

After you have done this, disable any antivirus, firewall, VPN, or proxy software that might be active on your computer. These tools are sometimes known to interfere with the installer’s ability to download the model files.

Please also ensure that the Topaz Photo AI installer has all the proper settings in your system by going to your Mac System Settings > Privacy & Security tab and scrolling down to the security section. You will want to make sure you have 'App Store and identified developers ’ selected. Here is a video example:

Example of Proper System Preferences

Finally, rerun the installer. You can download a new installer from the downloads page directly :

Topaz Labs Download Page

Let me know how that goes for you and I’ll keep an eye out for your reply.

If you are continue to have problems please reach out to us at the following link:

Topaz Labs | Support Page

Thank you for the detailed advice! I did all the steps, installed a new and tried it again.

The funny thing is that now after choosing the „Remove Noise“ enhancement I can see the menu, which I could not see before. But then the App crashes again. I tried several times – it always crashes.

Any other enhancemant works fine. And the old „Topaz DeNoise“ App is working fine too!

Kind regards, Wolfgang.

I’d like to get some more information to help troubleshoot the problem you are having.

Could you send us your computer’s full system profile?

Also if you can, please try to recreate this crash in Topaz Photo AI, then go to Help > Open Log Folder, please send me all of the files within that folder. You should be able to attach them directly as a response to this email.

You can securely submit your files(s) to my Dropbox using the link below. Please be sure to send me a note to let me know you sent something.

Dropbox File Request

Hello John,

thanks a lot for trying to help with the former issue.

But since the last update (2.4.1) everything is working fine!

Kind regards

1 Like

This topic was automatically closed after 60 days. New replies are no longer allowed.