Topaz NOT SAVING with edits to Lightroom Classic

Topaz Photo AI Processed Images DO NOT SAVE to Lightroom Classic. The TIF image is saved but it is the same as the original RAW file.

New IMac. 24 gb RAM. Latest software. Have downloaded and then deleted/reinstalled but still does not save Topaz edits to LR (Topaz Sharpen works??).

I am a longtime Topaz user (previously on Windows) and have never experienced this issue. Please HELP!!

Steps to reproduce issue:

  1. Selected Edit in Topaz AI
  2. Saved Topaz edit
  3. Opened TIF file in LR - - - - no edits saved

Topaz Photo AI [v3.0.4] on [Windows/Mac]

Can you confirm with me which Lightroom Classic plugin you are using:

  • The RAW plugin, accessed through File > Plug-in Extras > Process with Topaz Photo AI
  • The External Editor plugin, accessed through Photo > Edit in > Topaz Photo AI

John - I use the External Editor plugin (as I have used previously in Windows). Photo>Edit in>Topaz Photo AI.

Thank you.

Bruce

Would you mind taking a screen recording of this behavior so I can see exactly what is happening while using this workflow?

Loom is a great free application for this: Loom | Free Screen & Video Recording

2024-07-04-13-59-24.tzlog (104.0 KB)

Loom would not work - says engineers are working on it?

Here’s the log file. B

Just tried it in Photoshop (Beta). Edits worked fine in PS.

B

John - PARTIALLY SOLVED… Topaz is saving the edited photo back to the disk. If I Import the edited photo it comes in to LR correctly.

So, the question is… how to get the saved Topaz Edited photo to Lightroom without the extra step which I did not have to do before.

Thanks.

There is something wrong. The tiff file did not get saved to the external disk when using the plug in within Lightroom Classic 13.4 on the Mac. Lightroom Classic cannot find the tiff file, when I try to locate the file, the tiff file is not on the external disk that contains the collection of photos. The original .CR3 is there, but not the resulting .tiff file.

Please follow the instructions below to perform a clean install to better troubleshoot why you had this problem with Topaz Photo AI:

First please make sure that you have Lightroom Classic fully closed before proceeding.

Start by clearing any previous plist files that are on your computer for Topaz Photo AI by following the steps in the link below:

Topaz Photo AI | plist Files Mac

After you have done this, disable any antivirus, firewall, VPN, or proxy software that might be active on your computer. These tools are sometimes known to interfere with the installer’s ability to download the model files.

Please also ensure that the Topaz Photo AI installer has all the proper settings in your system by going to your Mac System Settings > Privacy & Security tab and scrolling down to the security section. You will want to make sure you have 'App Store and identified developers ’ selected. Here is a video example:

Example of Proper System Preferences

Finally, rerun the installer. You can download a new installer from the downloads page directly :

Topaz Labs Download Page

Let me know how that goes for you and I’ll keep an eye out for your reply.

Thanks John. Unfortunately, that did not solve the issue.

LR appears to create a TIF file (-Edit.tif) but when opened it is the same as the original RAW file that was edited in Topaz.

If I Input the file (which is named differently, -Edit.topaz.denoise.tif) it puts that file into LR view.

B

Hi -
That seemed to work, although now the file is saved as .dng (which is what I was expecting, and it shows up in the finder and the lightroom classic catalog. I also updated as 3.04
Thanks

Edit-In no longer seems to automatically load the images back to LR.

Following instructions … (me)… using File/Plug-in Extras/Process in Topaz Photo AI, WORKS!

Thank you for working with me though I did seem to find a solution on my own.

Regards.

Bruce

1 Like