Topaz Is Not working Properly

Topaz is Not Working Properly, Im Very Disappointed, Did I waste My Money?

You are Not Helping at all, is not working!! It freezes !!

Please supply the required information listed here:

Since updating to Topaz AI 2.2.2 I have been unable to use the program on my Mac due to extreme slowness.
I can’t even change the settings in Topaz
otehr programs operate normally, and I’ve tried freeing up resources (closing all otehr programs etc)
Please advise

We need more details. :eyes:

Not sure what details you need. Updated to 2.2.2 TopazAI now unworkable. If I open settings it takes several minutes to change a single setting or try to scroll down. Most settings can;t be changed due to slowness of response. previous version worked fine. I removed and reinstalled it - same. Topax denoise and sharpen also work normally.

Model Name: iMac
Model Identifier: iMac21,1
Model Number: MGPL3X/A
Chip: Apple M1
Total Number of Cores: 8 (4 performance and 4 efficiency)
Memory: 8 GB
System Firmware Version: 10151.61.4
OS Loader Version: 10151.61.4

You don’t even meet the minimum technical requirements outlined in the Topaz Labs website.

From Topaz site:

Minimum Hardware Requirements

Mac Operating System| = Big Sur 11 and higher

CPU & Graphics Card| = Apple Silicon processors|

System Memory (RAM) = 8GB

Sorry, my bad I was looking at the Intel CPU requirements.

Using Activity monitor looks like CPU usage is fine, Topaz AI uses > 5GB of Memory ( also my antivirus program is using 2GB - which I can’t seem to shut down even if I ‘force quit’ the program).
Topaz Sharpen and Denoise ~ 500 MB

So it does seem related to RAM usage. Unfortunately I can;t upgrade the RAM on this Mac

What is the av app, free or paid?

Paid (Webroot)
Since rebooting the AV shrunk to 600MB,
Topaz AI = 4.5 - 5 GB once opened with total around 7GB

But is still barely functional

Is there a general problem with running Topaz on Macs? I see so many reports from Mac users having issues.

I’m not sure but I see that most of the Mac problems are with entry level, no offence intended, as otherwise they can be prohibitively expensive.

One bonus with Win PC’s is that the are expandable and you can get a top line model starting at $1000. For example my Asus ROG Strix with 32GB RAM, Ryzen 9, 1GB SSD and RTX3060/6GB cost less than $1500 and can be expanded.

Obviously I would prefer a top of the line Mac M3 with 32GB unified memory and 14" screen… But…

1 Like

Please follow the instructions below to perform a clean install to better troubleshoot why you are having this problem with Topaz Photo AI:

Start by clearing any previous plist files that are on your computer for Topaz Photo AI by following the steps in the link below:

Topaz Photo AI | plist Files Mac

After you have done this, disable any antivirus, firewall, VPN, or proxy software that might be active on your computer. These tools are sometimes known to interfere with the installer’s ability to download the model files.

Please also ensure that the Topaz Photo AI installer has all the proper settings in your system by going to your Mac System Settings > Privacy & Security tab and scrolling down to the security section. You will want to make sure you have 'App Store and identified developers ’ selected. Here is a video example:

Example of Proper System Preferences

Finally, rerun the installer. You can download a new installer from the downloads page directly :

Topaz Labs Download Page

Why are users having to do all this, just to install a new version?

There are numerous posts about installing problems, especially on Macs.

Even on a Windows, it is not straight forward uninstall.

I think Topaz need to sort this out.