Topaz Gigapixel AI 5.5.1 keeps crashing

The latest version of Topaz Gigapixel AI 5.5.1 keeps crashing on my Mac. OS X 10.15.7.

I tries twice to uninstall it and re-install it, but no luck. It keeps crashing when I start the app up.

How can I fix it? Thanks

3 Likes

Same here. MAc OS X 10.14.6 It keeps crashing when I switch between the different AI models. Very frustrating. Please help!

1 Like

Hopefully someone from Topaz Labs will jump in here and help us with this. I have tried many things, even fresh installation, but it still crashes.

2 Likes

Same here… running 10.14.6 on a 27" iMac 5k retina/32Gb ram. No problems with earlier versions, but GPAI 5.5.1 keeps crashing… without warning… usually as soon as any options are selected.

1 Like

I am having the same problem on 10.14.6 on a 27" iMac 5k retina/16Gb ram in both standalone or calling it from Photoshop.

1 Like

Ditto.

Gigapixel 5.5.1 On 2019 16" MBP running Catalina 10.15.7

Boof!

1 Like

Same here on macOS 10.14.7 I’ve also had problems with files being overwritten and not renamed, color shifts, saved files not Preserving Source File Type, the program crashes randomly during use and every time after a conversion is done… Pretty much a hot mess here.

1 Like

Same issue, MacBook Pro 16", BigSur 11.2.1. It keeps freezing the second I load a photo or folder.

1 Like

We also have experienced crashing as soon as trying to load a file.

macOS 10.15.7

Installed from the full offline installer.

1 Like

We just tried with version 5.5.2. It no longer crashes on open, however now we get an ‘Error loading model, please try again.’ error.

Installed from the full offline installer.

I’m having the same issue on Windows PC. Running Windows 10 with latest update, AMD 8 core CPU, Radeon 590 8GB GPU and 32 GB of system RAM so I know its not a lack of power or RAM. Prior to upgrading to v5.5.2 it was running fine. Now when I load an image I get processing error. Error loading model no matter what the settings selected.

Topaz Labs this is not good enough. There is clearly an issue with the latest update across both MAC and PC platforms and we have all paid a considerable amount of money for your software. This is not what a professional IT company does to their customers and then fails to respond to questions posed. The right thing to do is to come on here and work out a solution NOT leave people with a useless piece of software that they can do nothing with. We expect and demand better service from you.

1 Like

Gigapixel shuts down my iMac …it’s only 3 years old and 16 gig ram very sad

Same issue. I agree. We deserve a refund. The software is utterly useless now.

Im surprised no one from their support team has responded to any of this. Have any one of you received any help?

I changed the AI Processor to my graphics card and it did not crash again for me. At least not yet.

Go to File - Preferences - AI Processor
Click on the one that is showing (mine was the CPU) and a drop down menu will allow you to change it.

1 Like

still dealing with the issues as well, moreso everytime I upload an image or start to process it.

Just a week ago it was working smoothly so I have no idea why it’s not working now of all times

Same here. Crashes as soon as I drop a file into it. Useless!

I did the same thing as kevin.williams, and now it works for me to (I’m using PC):

I changed the AI Processor to my graphics card and it did not crash again for me. At least not yet.

Go to File - Preferences - AI Processor
Click on the one that is showing (mine was the CPU) and a drop down menu will allow you to change it.

Changing the au processor type off auto to CPU fixed the problem for me too.
Mac Mini Big Sur

Go to Preferences and change Performance from AUTO to CPU. That worked for me.