Topaz Denoise Black Screen

Just installed Topaz DeNoise AI it worked twice and now all I get is a Black Screen after saving the output as a Jpeg file. Also the ouput is not saved back into Lightroom with the applied effect.

Need some help with this.

1 Like

Same here. I have tried saving as dng, tiff, and jpg. Still get the same result, a balck image.

1 Like

Same here, a black saved image.

1 Like

Make sure that when you call the application from Lightroom use the File Save option (Ctr+S) and not the Save as button.

2 Likes

For everyone having problems with images saved as totally black, go to Help-> Graphics info, click the Copy button and post the results here.

Application & Version: Topaz Denoise AI Version 1.0.0
Operating System: Windows 10 (10.0)
Graphics Hardware: Intel® HD Graphics 4400
OpenGL Driver: 3.3.0 - Build 20.19.15.4531
CPU RAM: 16282 MB
Video RAM: 1500 MB Total, 1024 MB In Use
Preview Limit: 3135 Pixels

For all who are having issues with black images being produced you will need to check that your PC meets the System Requirements. Troubleshooting tips are here in this article as is a link to minimum technical requirements.

Troubleshooting:

If the GPU you are using does not meet the minimum requirements and you have a secondary high-performance GPU read this article to learn how to set up DeNoise AI, or indeed any other application, to use switchable graphics:

I all else fails there are options in the preferences panel where you can switch to CPU processing (slower) and also select not to use maximum AI models in the processing. These preferences are found in File-> Preferences.

Unfortunately the HD4400 is not a supported GPU for GigaPixel AI but if you read the post above there are other options you can use if you don’t have Dual GPUs on your system.

No black screen but not sure where to post this. First thing I noticed when using is lag- I have a Nvidia 1060 and Intel i-5- lag is annoying. I also miss an option for a side-by-side comparison view. Inconsistencies in UI of Topaz products really disrupts the workflow.

If you are using a i5 make sure your virtual RAM is set to a minimum of your installed RAM and at least a maximum of double that.

As for the side by side view choose the Split Icon at the top of the screen.

Thanks for the tip- I have 16GB of RAM and no problems with lag in any other demanding programs, plugins, or games.
Issue IS with AI Denoise.
Yes, I used the split screen- I just prefer the side by side as in other Topaz plugins like Texture Effects, and in Studio- no UI consistency.

Application & Version: Topaz Denoise AI Version 1.0.2
Operating System: Windows 10 (10.0)
Graphics Hardware: Intel® HD Graphics 530
OpenGL Driver: 3.3.0 - Build 25.20.100.6446
CPU RAM: 16283 MB
Video RAM: 1500 MB Total, 1200 MB In Use
Preview Limit: 3466 Pixels

Hi,

Go to File-> Preferences and select CPU for the processing mode (slower) unless you have a Dual GPU system. If you do have a dedicated High-performance GPU it will show if you run DxDiag from the search box. If so then use this link to show you how to set up switchable graphics:

I’m getting black images. There is no "Use CPU… " option in prefrences. What can I do?

Application & Version: Topaz DeNoise AI Version 2.0.0
Operating System: Windows 10 (10.0)
Graphics Hardware: Intel® HD Graphics 630
OpenGL Driver: 3.3.0 - Build 25.20.100.6472
CPU RAM: 16206 MB
Video RAM: 1500 MB Total, 1200 MB In Use
Preview Limit: 3466 Pixels

Go to preferences and click on Advanced then Reset to recalibrate the processing and it should pick up CPU.

Can you also post the CPU details please.

That worked brilliantly. Thanks!

1 Like

Hi,
I was pleased with the trial and I have recently purchased DeNoiseAI. I am finding some problems with the full version I did not see in the trial? I am using it to process ~30MB raw DNG files from Pentax K3ii and ~48MB raw DNG files from Pentax K1. I opened the K3ii files only during the trial but had no problems, either as standalone or as a plugin to Photoshop Elements 14.1.

With the purchased version, the app opens and previews work as before but I am having problems with the it returning a blank image (to DNG) on save either as standalone or when opened as plug in to Photoshop Elements 14.1. This seems partly fixed for K3ii files when I enabled the discrete GPU option and allowed high memory usage. I did not need to do that with the trial version. Why is that?

I can open the K1 files either as standalone or from plugin but I have not been able to save any processing back to PSE or as a new DNG file; i get the blank image.

I do not get any error messages and if used in standalone mode i get a small blank file which is completely black. If opened as a plugin from PSE then the result is a blank image in the editor, which can only be removed by rolling back the history in PSE.

Can you suggest any reason why I am having these problems?

Application & Version: Topaz DeNoise AI Version 2.0.0
Operating System: Windows 10 (10.0)
Graphics Hardware: Intel® UHD Graphics 630
OpenGL Driver: 3.3.0 - Build 26.20.100.7262
CPU RAM: 8007 MB
Video RAM: 1500 MB Total, 1200 MB In Use
Preview Limit: 3466 Pixels

Also submitted as support request ID number: 220365

Thanks

I followed the steps suggested to select the NVidia GPU.
Now configured like this:
Application & Version: Topaz DeNoise AI Version 2.0.0

Operating System: Windows 10 (10.0)

Graphics Hardware: GeForce GTX 1050/PCIe/SSE2

OpenGL Driver: 3.3.0 NVIDIA 441.12

CPU RAM: 8007 MB

Video RAM: 4096 MB Total, 3965 MB In Use

Preview Limit: 6518 Pixels

Setting the Switchable graphics to the NVidia GPU looks have fixed the problem! Got one image back from Standalone mode that I couldn’t save before.

I also made sure that Topaz DeNoiseAI.exe was selected and set to high performance in the windows display graphics settings. (for all I know this might be a duplicate redundant action?)

It is a redundant action but I advise using the windows graphics rather than the NVIDIA control panel.

The black screen issues you see on the HD630 is because it is underpowered compared to the GTX1050 and doesn’t have any dedicated vRAM, well 128MB, and has issues with preview sizes.

Note you should allocated all Topaz AI apps to the high performance GPU through the windows graphics entry.

Initially, because of DNG issues, if you have any problems with colors etc. export as TIF instead from the standalone.