Topaz AI 3.1... faster but crashes/fails constantly on Windows 11

3.1 is much faster than 3.0.12 however I have yet to see it finish a job. I’ve gotten a few “unknown error” stoppages as well as a few Windows 11 crashes and reboots. 3.0.12 process the same videos just fine. Basically unusable, I’ve downgraded back to 3.0.12 until this is fixed.

Windows 11 here. No crashes. Done about 3 three hour long videos and 2 one hour videos. Information is key. With you saying Windows is crashing, that suggests to me hardware issues. Could be the higher power draw from 3.1.0 is why it now fails.

2 Likes

Already tried low power mode and monitored temps… machine has a 1200W power supply, 64GB ram, NVME (M.2) drives, Intel i9 12900KF, Asus motherboard. Its not the machine!

Sometime it just gives up with “unknown error” without actually crashing.

The models just fail constantly. You can’t say “its a hardware issue” if it wasn’t there before. No Windows crashes here, plenty of model failures

There is some issue managing VRAM. I run 2 instances, DDV model seems fine, is much faster…quality is probably a bit less than before but it’s OK. Gaia and Proteus are where the problems really start. If running 1 DDV, then the Gaia or Proteus will usually fail “unknown error”. If they do start they are insanely slow as a 2nd instance but seem fine, and fast running alone.

I have 2 1080ti’s and a 5900x 64gb ram and heavily watercooled…no temp issues here.

Edit, spoke too soon. Windows will crash if 2 Gaia models actually do manage to start.

I’ve got a, nVidia 3060 Ti… mostly using Artemis (grain 5 size 1) on low-res 8mm tapes captured at 1920x1080, upscaling to 4K. 3.0.12 ran around 3fps, 3.1 runs about 6fps so 3.1 much faster. Running more tests now.

I have only tried to do two instances of Artemis models running at the same time, and I decided that the speed increase was not worth it. With the two 1080s though, that shouldn’t be an issue. I did notice that my CPU was maxed out with two instances. I had to run 4 instances before to max-out my CPU before.

When you say “two instances” does that mean a setting of 2 in the Max Processes Preference setting? I’ve been running with a setting of 2.

Windows 11 here. No crashes. Almost always a PSU issue, really. You need a quality power supply. A bit of wattage, naturally, but primarily stability.

Not true. Earlier versions ran considerably slower. 3.1 asks a lot from your CPU, and from your GPU.

By two instances, I mean running two copies of the CLI running. Unless the overhead of having the GUI open impacts things a lot, it should be the same. I do know that playing videos in the GUI slows thing down.

Which has always baffled me. Playback should not affect processing speed at all. (At least not in a way perceptible to the human eye). And yet it slows down things considerably. Always feels like a bug (the entire Preview, really) they persistently ignore.

Well if that’s happening you have to be hardware constrained. If you’re running VEAI on a GPU and your CPU is @ 100%…You need a better CPU. I’ve never seen the playback slowdown anything.

Pretty silly response. It’s supposed to “ask” a lot from the hardware. It’s also supposed to manage resources appropriately.

3.0 Had a problem of just not doing things efficiently, I like the features it added but processing didn’t match 2.8(?) at all. After spending a day with 3.1 I can say that it definately kicks it up but it’s sloppy with resources, it’s like flooring the gas pedal and just spinning the tires where 3.0 was like a little car full of fat chicks.

I’ve never had to use “low power mode” before but I found that with 3.1 it actually makes it a reasonable program. Now it’s under using the GPUs and CPU yet it’s still running much…much faster than 3.0 so I can’t complain. 44C and 50% TDP is pretty light compared to how 2.8 used to run.

Not silly at all. Your position was that it couldn’t be hardware “if it wasn’t there before.” To which I rightfully replied that v3.1 is a lot more demanding on your system than previous versions, so that “it wasn’t there before” makes no sense.

And it does. Topaz, however, is not responsible for your hardware purchases. My RTX 3080 Ti can. and actually does at times, draw 350W (cuda cores also in effect because of underlying AVFS VapourSynth denoising process), plus what my nearly fully loaded i9 12900K wants. So, trust me when I tell you, that all these “Windows 11 crashes and reboots” from the OP are simply hardware related; i.e, usually crappy power supply. TVAI, by itself, does not cause Windows to reboot. Nor will it cause a BSOD – again, unless you have crappy hardware (say, unstable memory, for instance). As in every other man-made system, you only notice the faults when you push it to the limits. And TVAI does just that.

The OP is running a 1200w PSU with a 12900K and a 3060TI…He’s not running “crap” and his PSU is more than enough. It’s safe to assume if he bought a 12900K and a 3060TI he didn’t buy his PSU from Aliexpress so just stop.

It’s always the “Beta Testers” that seem to be shills, granted I’m techincally a beta tester…just waiting for the Linux version. Point is this program needs refinement, The OP has told you what his hardware is and it is more than reasonable. If VEAI cannot cope with what he is running then it needs work, it is that simple.

Here we go again. I don’t care if he has a 2400W power supply: it needs to be not crap. Aka, it needs to be of high-quality; especially when it comes to stability. Which is to say, under stress voltage shouldn’t drop even a sliver, or start to fluctuate. A good power supply simply costs money. Mine cost ca. 300 euros. A PSU is really like speakers: usually the part people skimp on, and typically only bought for wattage. :slight_smile:

And TVAI actually can cope, is the whole point. I’ve literally never had TVAI/VEAI crash on me, like ever. At one point it hang, closing the temp file (which was fortunately still readable), but it never crashed, or made my Windoze crash. In fact, as a beta tester, I simply know that it’s as good as impossible for a program to make Windows itself crash/reboot. Everything (since the 90ties) runs in Protected Mode, so the program itself may crash, but Windows won’t. Where this happens, after all, is typically when your video card gets underpowered, or other undervolting issue (again: PSU stability). Or having crappy video drivers (yes, it always comes down to having crappy something.)

The ‘shill’ part in me is simply responding to BS claims, as made by the OP, about TVAI being horriblle software that makes their Windows reboot/crash, and being utterly unusable. I have had plenty critique on TVAI/VEAI before, and never mince words in that regard, either. But it’s always important to separate fact from fiction, and to only fault Topaz for the things they actually do wrong – and nor for all the ails in peope’s personal systems.

I have a similar setup to OP:

Windows 11 22H2 (which the latest upgrade of a system that started in Vista 3 PCs ago)
Intel i9-12900KF - AIO Water cooled - Overclocked to 5.1 GHz on all cores
EVGA RTX-3080 Ti Hybrid (AIO water cooled) w12GB VRAM
32 GB DDR5 5400 RAM
Gigabyte Aorus Master MB

Here is my $.02:

My machine has been running upscales constantly since Thursday without a single failure. I have already processed 47 480p originals to 2160p, using Proteus to upscale to 960p and then Artemis HQ to upscale the the recovered details to 2160p. During those runs, my PC pulls around 750 watts and both the CPU and GPU average around 60°C. The CPU is around 80% loaded and the GPU around 90%.

It isn’t Windows 11 or hardware. The problem is an issue with some software on the PC other than Topaz or the OS. Keep in mind that once the processing begins, it is ffmpeg that does the all the work. The Topaz AI is just a dashboard to the ffmpeg process(es). If it crashes on one machine and not another the problem is in the machine that crashes.

ETA: My PS is a Seasonic PX-1000

Still think it’s hardware. :slight_smile: Might actually be Windows, though. Mine got messed up, at some point, using DriverEasy (don’t do that: use whatever driver Windows offers, for anything other than discrete audio cards, or video cards, of course). Some third-pary drivers caused a BSOD at times. A full reinstall solved that again.

Also, try a BIOS update. Sounds a b it like a helpdesk answer, but I’ve had it help for me once too, when I got the occasional BSOD for alleged memory errors. Rock stable ever since.

Whatever it is, though, it’s not TVAI.

Good point about BIOS updates. Also reminds me to mention that I am running my GPU with Resizable BAR.

It is also, for anyone having problems in Windows, worth checking your system files by running:

sfc /scannow

and if you have problems reported, run:

dism /online /cleanup-image /restorehealth

The first scans your system files for integrity issues and the second fixes any problems.

I have a Thermaltake 1200W ToughPower. Everything in this machine is top-shelf. I built it myself about a year ago. Samsung Pro M.2 SSDs.

Last night it crashed Windows a bunch of times. I tried every BIOS setting and Topaz setting, including low power.

I normally export to Pro Res LT (.mov) as that is best for editing videos on my 2019 Mac Pro with Adobe Premiere 2023.

Just for the heck of it I tried to export as H.265 Main NVIDIA (.mov) but it crashed again.

Because I won’t give up… I tried H.265 Main NVIDIA (.mp4) and guess what - it worked!

So this leads me to believe the problem may be creating .mov files in Windows? I know Windows cannot play mov files so maybe this is related - although 3.0.12 created them fine.

I also noticed when exporting to .mp4 my processor temp ran about 20℃ cooler… Pro Res LT really cooks it. Still got same 6.3fps with mp4 as ProRes but better temps.

Unfortunately the resulting .mp4 file does not play in Quicktime on the Mac. I does work in Premiere so I guess thats not an issue.