Studio v1.6.7/v1.6.8 ... Not Ready for PRD

It would appear that this thread makes the answer to your question quite obvious.


True enough - I have decided to hold off.

But it would still be nice to see some sort of statement from Topaz.


Really just a statement to advise whether the problems are isolated or widespread and (more to the point) if this is going to be it for upgrades for a few weeks - or will there be an emergency update coming within a day or so. In other words should we hold off or is it safe to upgrade?

Right now every time I edit a photo Studio asks if I want to upgrade. I’ve paid for everything Topaz has ever had to offer, so it would be nice to be using Glow from within Studio if it is safe to do so.

1 Like

It looks like 1.6.7 was pulled. I see the main site says 1.5.3 is the most current version and Studio is also telling me 1.5.3 is the most current.

1 Like

We released the 1.6.7 release to a limited amount of users. Only announcing it to the Studio group and people who were actively in the Studio application, We’re working on and update to fix those issues right now which will release publically soon (1.6.8), and we’re also making a previous installers version available that will point toward the last stable release (in this case 1.5.3) on the installers page as well.

This update should fix the missing assets, missing textures, and synching issues. The other issues mentioned we are aware of and actively tracking and trying to reproduce, in order to deliver fixes there as well.

We’ll have a full statement soon that specifically addresses each concern listed here, right now we’ve rolled back to 1.5.3 on the live version, pending the release of 1.6.8.

Sorry for the delay we’ve been working to determine causes and build fixes.


Thanks @HeathRobinson. Appreciate the official word.


Thank you - info is much appreciated.

1 Like

My Pleasure,
We’re going to have a nice long talk about all this next week :smiley:


Win 10 PC, the update on the PR to 1.6.8 went smoothly. Ran it from within Topaz Studio. I now have my Impression brushes back. Some of the overlapping text appears to be resolved but need to check on other machines.

1 Like

Seeing that another user is reporting getting Impressions with PR 1.68 I updated and still no brushes. Thought perhaps uninstalling and reloading both PR and Beta would clear any old problems…Now, not only do I not get the brushes in Impression but in Impression, it doesn’t pick up the images in presets…sometimes the image loaded does not appear either and presets and image appear as white screens. All other apps appear to load correctly.

Later development…Although I had restarted my equipment twice with no change in results, I did a cold boot and found that the image problem in Impression has seemed to correct itself. Still no brushes.

1 Like

@HeathRobinson honestly there are simple things that need to be checked before these updates go out, for instance I upgraded to v1.6.8 automatically and all went fine until I checked the contents of the AppData tgrc directory and found 2,002 files there which I thought had been moved to the D:\ drive on my PC.

I checked the D:\ drive directory and all were there:

These are simple things that need to be right.

1 Like

Currently, my only issue is the issue with the duplication of the TGRC files, the same as @AiDon mentioned… As far as Impressions, I seem to have all of the brushes. I also seem to have all the texture assets. I did not have any issues with missing brushes and textures in 1.6.7 or 1.5.3 either.

The install went smoothly, no issues, and rather quick. Initial startup was seemed much faster than previous versions. I had no issues/crashes that had been mentioned in previous versions when scrolling through the Effect Panel.

Overall this iteration seems to be the best of those released recently, at least in my opinion.

1 Like

I, too, am missing brushes and textures. In addition, I am missing two of my Effects categories - Trending and New. Disappeared after last update. This seems to happen after every one of Topaz’ updates. I’m a bit sick of this. I paid good money for Topaz software, but I spend as much time getting it to work as advertised as I do using the software.

1 Like

The Brush stroke part of Impression has been missing for many of us and has been reported…the sliders however are working for the various effects. The Textures have only been reported as missing by one other person. I’m on Win 10, version 1.68 and the Texture file and its Effects are working normally. As far as categories, the Effects Menu has been changed, Trending is no longer included. If you go to the Sorting area and click on the little up and down arrows, it gives sorting ability and New and Popular (Trending) are included.

1 Like


I agree with both of you whole heartedly!

I miss the good old days of having dependable plugins and getting enjoyment out of processing images.

Now ALL my TIME is spent… with very little processing.
Reading all the misfortunes that members are having with the past or current updates.

Uninstalling and Reinstalling Updates and sometimes not getting the right info about Updating for Mac
and Window users till a day later after an update is released?

Trying to figure out what is and what isn’t supposed to be happening or working?

Why Topaz is still releasing Updates on a weekend or Holiday?

Why Studio keeps going backwards and not getting better?

I think at this stage, Topaz should go back to the drawing board and wait till the New Year.
You are only confusing, wearing down & frustrating the Beta testers.

We have mentioned many of our frustrations with Studio before in an earlier post that you have acknowledged that you would take into consideration… still seems to be the same old thing? We should not have to go thru work arounds to get things done.

You have people questioning if the should download the next update or not… now that’s just crazy.

Merry Christmas everybody and lets Hope that Studio is better in the coming year?
I would use an emoji… but they don’t work either?


@Torcello Hi Jack,

It seems that all of studio works fine in Affinity with even Alpha channels being returned and you can click on the background alpha channel and create a mask layer from it and attach it to a layer.

Even works for ReMask also … strange?

1 Like

I find that is only confuses the Beta testers more!

Now you are selectively picking users, no wonder when I read that there is this version or that version available … I don’t know how I missed one or didn’t see it in an Announcement Post?

Now I understand why there is so much confusion among the Beta testers… and I have been one from the start?

Honestly making limited releases, then taking them back, then releasing a new one… what’s going on at Topaz?

I hope you read this before your weekend meeting.

After reading the comments and complaints by members and with Topaz saying that they took our previous concerns with serious thought. They seem to be doing the same old things again and again… VERY disheartening to say the least!

They are now going to have yet another meeting about our concerns and their failures with Studio… stay tuned!


Studio Beta has today reached new heights of confusion! I loaded one image via LR and got another, entirely different, image. Honestly, you could not make this up.


This happened to me too and I thought I wasn’t paying attention and clicked the wrong image. Ugh. Thanks for sharing.


“All Beta testers are equal, but some Beta testers are more equal than others.”