Studio v1.6.7/v1.6.8 ... Not Ready for PRD

It is sadly disappointing after all the issues reported that they haven’t been resolved before the PRD version is released.

Issues introduced with the last Beta:

  • Impression Brushes are lost, still lost!

Then there is …

  • Glow wasn’t validated until I logged in again using switch user. I was logged in to the same user ID.
  • Problems with displaying original whilst using the heal brush
  • Window control
  • Menu Items and Adjustment text still cut off.
  • If you select to download Hi-Res Textures you need to close the dialog and reopen it to get it to start

It is almost that we have to go through and retest everything again!

Screenshot of Impression & Glow


All my Impression brushes and textures are lost as well.
Glow was validated upon the first start.

I think the public will be outraged when they find that they lost all the brushes and texture with the Impression Adjustment.


And then on my PRD pc I get this message, what is an undefined adjustment?


Then I moved tgrc from AppDataLocal on the C:\drive to the D:\Topaz Studio\tgrc folder and get the following:

  • localappdata … 1,407 files/1.09GB
  • new folder … 3,341 files/1.33GB

Not everything was moved and we have duplicates in both directories? Why?

1 Like

I did not experience any of the things you mention using Windows. I rechecked the items you listed and all seem to be working without a problem…the only thing that is a problem are the missing Brushes in Impression. I do have the Textures.

Studio - I moved the tgrc file from C: to D: and there were no brush t/n’s at all shown in it. 1.26 GB (1,361,326,080 bytes) 3,177 Files. I could not readily discern a visual duplication other than the different sizing. Those that appeared similar in T/N scrolling were too far apart for a side by side and had completely different file numbers (not different version numbers)


That was my experience also.

1 Like

Same here!

1 Like

I suspect some of us have much more important things to do than mess with software issues like this., I am not outraged but Studio just went from being a gem to an irritant I don’t have time for. I will just stick with Photoshop and the original filters until Studio grows up. Note to developers: Holidays are not the time to release software that isn’t ready as some people have enough stress as it is.


In the good old days, when each separate Plugin had its own UI - the beta testing was at a moderate pace; it allowed you to spend more time using and enjoying them. The frequency of testing is a tad rebarbative. I have not lost faith in Topaz products, but when I realised that there was little time for me to enjoy the suite of plugins, I stopped at 1.5.3, and will not update until I figure there will be a major bonus.

The compression induced by gathering all Plugins under one UI puts pressure on us. It is exhausting, as the once leisurely pace - one Plugin at a time - has become telescoped into “all the Plugins all of the time!” But if that’s the way forward, God bless Topazlabs.

I will take this opportunity to wish all at Topazlabs a Happy and Holy Christmas.



Since installing the PR version I cannot get ‘Apply’ to work in either the old Beta 1.6.6 nor the PR 1.6.7, I just get a blank. This appears to be happening just in the plug-in versions.

It’s Friday again, folks.

Update: My tests show that the cause of this is cropping. But it is not every crop, only some, and it’s not cropping to a known ration or an unknown ratio. It appears to be related to the severity of the crop.

I am cropping in LR and creating a jpg copy with LR edits. I am not working from the original. What I do not understand is, if it is a copy with edits it should be an original jpg image in its own right and should not have any cropping information attached to it. Certainly, the stand-alone version of Studio handles it without a problem as does my other editing software.

The questions are: if LR is creating a brand new stand-alone image, what is it that is being passed into Studio plug-in that it doesn’t like? And why does it happen only on some of the crops and not every one? And why is the stand-alone Studio accepting it?

What I do not accept is that Studio plug-in does not handle an image that has been re-saved as a new complete jpg image within LR. It’s nonsense.




Now that Glow has been ported I’m having exactly the same problem with that as I STILL have with Impression i.e. browsing the effects causes Studio to crash. Consistently, and in both public and beta. Impression worked fine up until the last public release, Glow also worked fine in beta (until the trial period expired of course), now it’s gone the same way. I’m really starting to lose confidence in this product now.


I agree. I have worked in code development for 30 years and Friday is the worst day to release anything new. Especially Friday at 5PM which is what the business side of the company I work for seems to always want for some reason.


I had to restart Topaz Studio in order to enable Glow.

1 Like

It was released yesterday (Thursday).

1 Like

This thread has made me hesitate to install the latest update - I currently have 1.5.3. Is it recommended to stick with this version for a while longer?

Regarding brushes lost in Impression - are only custom brushes created by the user not carried over to the new version? If so, that wouldn’t be an issue for me.



The area where you can visually choose the brush stroke you want to use is missing. The sliders and presets work.

1 Like

Just to be awkward - I have all the Impression brushes in both versions.

1 Like

Not sure whether to allow the upgrade from 1.5.3 or not. Right now I don’t have any problems, but I’m not interested in becoming a beta tester.

It would be nice to see a statement from Topaz.


I am happy at 1.5.3 - it even works quite well inside Affinity Photo!

I will update/upgrade when a really stable, feature-packed beta arrives in the not too distant future.

But that’s just me… :slight_smile:

1 Like